aboutsummaryrefslogtreecommitdiff
path: root/deskutils/tuxcards/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-01-11 23:36:07 +0000
committerPatrick Li <pat@FreeBSD.org>2002-01-11 23:36:07 +0000
commitd5ff811e034038f549ef25e2c7120f3b36e1bb67 (patch)
treeaf150b0f6dec7a40c0a2a72b1bc47e127b762f92 /deskutils/tuxcards/Makefile
parentba2488b269ad96b52da357c93416436c9a8087b5 (diff)
downloadports-d5ff811e034038f549ef25e2c7120f3b36e1bb67.tar.gz
ports-d5ff811e034038f549ef25e2c7120f3b36e1bb67.zip
Add port misc/tuxcards A small Application, which organizes your notes
in a tree, so they are easier to find. Clone of the Windows software "CUECards" PR: 33734 Submitted by: Tilman Linneweh <freebsdports@arved.de>
Notes
Notes: svn path=/head/; revision=52937
Diffstat (limited to 'deskutils/tuxcards/Makefile')
-rw-r--r--deskutils/tuxcards/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/deskutils/tuxcards/Makefile b/deskutils/tuxcards/Makefile
new file mode 100644
index 000000000000..15d429298230
--- /dev/null
+++ b/deskutils/tuxcards/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tuxcards
+# Date created: 08 Jan 2002
+# Whom: Tilman linneweh <freebsdports@arved.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tuxcards
+PORTVERSION= 0.8
+CATEGORIES= misc kde
+MASTER_SITES= http://tuxcards.de/src/ \
+ http://www.arved.de/bsd/src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+
+MAINTAINER= freebsdports@arved.de
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_GMAKE= yes
+USE_QT_VER= 2
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+pre-patch:
+ @${PERL} -pi -e 's|\$$\(prefix\)/doc|\$$\(prefix\)/share/doc|' \
+ ${WRKSRC}/tuxcards/docs/en/Makefile.in
+ @${PERL} -pi -e 's|-O2||' ${WRKSRC}/configure
+.ifdef(NOPORTDOCS)
+ @${PERL} -pi -e 's|install-data-am\: install-data-local||' \
+ ${WRKSRC}/tuxcards/docs/en/Makefile.in
+.endif #NOPORTDOCS
+
+.include <bsd.port.mk>