aboutsummaryrefslogtreecommitdiff
path: root/deskutils/tuxcards
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-01-08 16:36:53 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-01-08 16:36:53 +0000
commit8ff6a82cd92f0a38cca0fb86129d67289c89e79d (patch)
tree62cc85de62b5d095d8e2db8023d3ba8eb0672c88 /deskutils/tuxcards
parentb68900d3dcb026495e6bc205991815e5b0a1e471 (diff)
downloadports-8ff6a82cd92f0a38cca0fb86129d67289c89e79d.tar.gz
ports-8ff6a82cd92f0a38cca0fb86129d67289c89e79d.zip
qmake changed locations, fix tuxcards for $LOCALBASE-based
qmake-installations.
Notes
Notes: svn path=/head/; revision=97695
Diffstat (limited to 'deskutils/tuxcards')
-rw-r--r--deskutils/tuxcards/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/deskutils/tuxcards/Makefile b/deskutils/tuxcards/Makefile
index 271560301564..a139b57b3069 100644
--- a/deskutils/tuxcards/Makefile
+++ b/deskutils/tuxcards/Makefile
@@ -20,9 +20,20 @@ MAKE_ENV= QTDIR="${QT_PREFIX}"
post-patch:
@${REINPLACE_CMD} -e 's|warn_on|warn_on thread|g' ${WRKSRC}/tuxcards.pro
+.include <bsd.port.pre.mk>
+
+# Add this condititonal while people might still have old versions
+# of qmake, living in X11BASE, installed. This should go away eventually.
+
+.if exists(${X11BASE}/share/qt/mkspecs/freebsd-g++)
do-configure:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
-spec ${X11BASE}/share/qt/mkspecs/freebsd-g++ tuxcards.pro
+.else
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
+ -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ tuxcards.pro
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
@@ -31,4 +42,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/docs/en/*.* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>