aboutsummaryrefslogtreecommitdiff
path: root/deskutils/tuxcards
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-08-08 15:38:31 +0000
committerPatrick Li <pat@FreeBSD.org>2002-08-08 15:38:31 +0000
commitc51c962f3e3f5fefcb8a9b19337631140ba11b44 (patch)
tree98bbfed14e7c7205b8827276bc5a371a422ee61d /deskutils/tuxcards
parent89d0fd75d710b096d5627623ddbb450c849103c6 (diff)
downloadports-c51c962f3e3f5fefcb8a9b19337631140ba11b44.tar.gz
ports-c51c962f3e3f5fefcb8a9b19337631140ba11b44.zip
PERL -> REINPLACE_CMD
PR: ports/41442 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=64230
Diffstat (limited to 'deskutils/tuxcards')
-rw-r--r--deskutils/tuxcards/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/deskutils/tuxcards/Makefile b/deskutils/tuxcards/Makefile
index 4197b8cdc780..84fdcf338187 100644
--- a/deskutils/tuxcards/Makefile
+++ b/deskutils/tuxcards/Makefile
@@ -19,13 +19,14 @@ USE_GMAKE= yes
USE_QT_VER= 2
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
+USE_REINPLACE= yes
pre-patch:
- @${PERL} -pi -e 's|\$$\(prefix\)/doc|\$$\(prefix\)/share/doc|' \
+ @${REINPLACE_CMD} -e 's|[$$](prefix)/doc|\$$\(prefix\)/share/doc|' \
${WRKSRC}/tuxcards/docs/en/Makefile.in
- @${PERL} -pi -e 's|-O2||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
.ifdef(NOPORTDOCS)
- @${PERL} -pi -e 's|install-data-am\: install-data-local||' \
+ @${REINPLACE_CMD} -e 's|install-data-am\: install-data-local||' \
${WRKSRC}/tuxcards/docs/en/Makefile.in
.endif #NOPORTDOCS