aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xfce4-xkb-plugin/Makefile
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-08-23 12:07:11 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-08-23 12:07:11 +0000
commitc8eb2422e21e4672d3d2c4921afa9a3b1d460f04 (patch)
tree910d2849a431871cdf7f38ef0cab381a9037fdb0 /deskutils/xfce4-xkb-plugin/Makefile
parentb34f3b9bef201b5c9b90d625d7cc719f47cd47a3 (diff)
downloadports-c8eb2422e21e4672d3d2c4921afa9a3b1d460f04.tar.gz
ports-c8eb2422e21e4672d3d2c4921afa9a3b1d460f04.zip
Add xfce4-xkb-plugin, an xkb-compatible keyboard layout switcher panel
plugin for Xfce 4.
Notes
Notes: svn path=/head/; revision=117115
Diffstat (limited to 'deskutils/xfce4-xkb-plugin/Makefile')
-rw-r--r--deskutils/xfce4-xkb-plugin/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/xfce4-xkb-plugin/Makefile b/deskutils/xfce4-xkb-plugin/Makefile
new file mode 100644
index 000000000000..2b6bbe26f9d0
--- /dev/null
+++ b/deskutils/xfce4-xkb-plugin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xfce4-xkb-plugin
+# Date created: 2004-08-27
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-xkb-plugin
+PORTVERSION= 0.3.2
+CATEGORIES= deskutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= des@FreeBSD.org
+COMMENT= Keyboard layout switching plugin for XFce4
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_INC_LIBTOOL_VER= 13
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>