aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-24 07:35:40 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-24 07:35:40 +0000
commit08c99f3ad5e81fd0d89c32e9337608d9a9bb4e35 (patch)
tree83aac97dcee746842718f1f34dfa58caca71df28 /deskutils
parent91696069c0e8874f735d4e30d164e5f922dd9819 (diff)
downloadports-08c99f3ad5e81fd0d89c32e9337608d9a9bb4e35.tar.gz
ports-08c99f3ad5e81fd0d89c32e9337608d9a9bb4e35.zip
- Convert USE_GETTEXT to USES (part 1)
Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=316407
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/babytrans/Makefile3
-rw-r--r--deskutils/cairo-dock/Makefile3
-rw-r--r--deskutils/deforaos-todo/Makefile3
-rw-r--r--deskutils/glipper/Makefile3
-rw-r--r--deskutils/gnochm/Makefile3
-rw-r--r--deskutils/gnotime/Makefile3
-rw-r--r--deskutils/gtodo/Makefile3
-rw-r--r--deskutils/plasma-applet-cwp/Makefile3
-rw-r--r--deskutils/plasma-applet-daisy/Makefile3
-rw-r--r--deskutils/plasma-applet-serverstatuswidget/Makefile3
-rw-r--r--deskutils/plasma-applet-yawp/Makefile3
-rw-r--r--deskutils/rubrica/Makefile3
-rw-r--r--deskutils/steadyflow/Makefile3
-rw-r--r--deskutils/timer-applet/Makefile3
14 files changed, 14 insertions, 28 deletions
diff --git a/deskutils/babytrans/Makefile b/deskutils/babytrans/Makefile
index 78abfb4cde7b..e63bbf32cc3c 100644
--- a/deskutils/babytrans/Makefile
+++ b/deskutils/babytrans/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://fjolliton.free.fr/babytrans/
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+/GNOME front-end for Babylon Translator .dic files
-USE_GETTEXT= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gtk12 gnomeprefix
GNU_CONFIGURE= yes
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
diff --git a/deskutils/cairo-dock/Makefile b/deskutils/cairo-dock/Makefile
index b2d8c0b8017a..03cabd3bffd2 100644
--- a/deskutils/cairo-dock/Makefile
+++ b/deskutils/cairo-dock/Makefile
@@ -17,11 +17,10 @@ LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
USE_GNOME= gnomehack pkgconfig glib20 gtk20 librsvg2 libxml2
USE_LDCONFIG= yes
USE_XORG= xrender xtst
-USES= cmake
+USES= cmake gettext
MAKE_JOBS_SAFE= yes
MAN1= cairo-dock.1
diff --git a/deskutils/deforaos-todo/Makefile b/deskutils/deforaos-todo/Makefile
index 015c0ed1fd25..333a3abe7fdb 100644
--- a/deskutils/deforaos-todo/Makefile
+++ b/deskutils/deforaos-todo/Makefile
@@ -16,9 +16,8 @@ LICENSE= GPLv3
LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
Desktop:${PORTSDIR}/x11/deforaos-libdesktop
-USES= pkgconfig
+USES= pkgconfig gettext
USE_GNOME= gtk20 desktopfileutils
-USE_GETTEXT= yes
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX}
diff --git a/deskutils/glipper/Makefile b/deskutils/glipper/Makefile
index 2167bdd74e34..63aaaf1d0659 100644
--- a/deskutils/glipper/Makefile
+++ b/deskutils/glipper/Makefile
@@ -12,9 +12,8 @@ COMMENT= Clipboard manager for the GNOME panel
USE_BZIP2= yes
USE_ICONV= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intltool pygnomedesktop pygnomeextras
USE_PYTHON= 2.5+
INSTALLS_ICONS= yes
diff --git a/deskutils/gnochm/Makefile b/deskutils/gnochm/Makefile
index 81908cd5544f..912d4b1e7909 100644
--- a/deskutils/gnochm/Makefile
+++ b/deskutils/gnochm/Makefile
@@ -14,11 +14,10 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/chm/_chmlib.so:${PORTSDIR}/textproc/pychm
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack pygnome2 pygtk2 pygnomeextras
GNU_CONFIGURE= yes
USE_PYTHON= 2.2+
-USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/deskutils/gnotime/Makefile b/deskutils/gnotime/Makefile
index dce5204383a9..5e32efc35825 100644
--- a/deskutils/gnotime/Makefile
+++ b/deskutils/gnotime/Makefile
@@ -16,9 +16,8 @@ COMMENT= A time tracker for gnome2
LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
USE_XORG= xscrnsaver
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix gtkhtml3 intlhack libgnomeui
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool libltdl
LIBTOOLFILES= configure ../${QOF_DISTNAME}/configure
diff --git a/deskutils/gtodo/Makefile b/deskutils/gtodo/Makefile
index df737a1999e5..056be6c66f46 100644
--- a/deskutils/gtodo/Makefile
+++ b/deskutils/gtodo/Makefile
@@ -10,8 +10,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An Gtk2 Todo list manager
USE_GMAKE= yes
-USE_GETTEXT= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix gnomevfs2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/plasma-applet-cwp/Makefile b/deskutils/plasma-applet-cwp/Makefile
index f834b239355c..c2cf26dea1d1 100644
--- a/deskutils/plasma-applet-cwp/Makefile
+++ b/deskutils/plasma-applet-cwp/Makefile
@@ -13,9 +13,8 @@ COMMENT= Weather plasma applet for KDE4
LICENSE= GPLv3
-USE_GETTEXT= yes
USE_BZIP2= yes
-USES= cmake
+USES= cmake gettext
USE_KDE4= automoc4 kdeprefix kdelibs
USE_QT4= gui dbus network opengl svg phonon webkit xml \
qmake_build moc_build rcc_build uic_build
diff --git a/deskutils/plasma-applet-daisy/Makefile b/deskutils/plasma-applet-daisy/Makefile
index 99ab022fcd50..7854989fa563 100644
--- a/deskutils/plasma-applet-daisy/Makefile
+++ b/deskutils/plasma-applet-daisy/Makefile
@@ -17,10 +17,9 @@ COMMENT= Simple launcher plasma applet for KDE4
LICENSE= GPLv3
-USES= cmake
+USES= cmake gettext
USE_KDE4= automoc4 kdeprefix kdelibs workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
-USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-serverstatuswidget/Makefile b/deskutils/plasma-applet-serverstatuswidget/Makefile
index 399ed6c78671..f919fb74f079 100644
--- a/deskutils/plasma-applet-serverstatuswidget/Makefile
+++ b/deskutils/plasma-applet-serverstatuswidget/Makefile
@@ -17,8 +17,7 @@ MAINTAINER= jhale@FreeBSD.org
COMMENT= Server monitoring plasma applet for KDE4
USE_BZIP2= yes
-USES= cmake
-USE_GETTEXT= yes
+USES= cmake gettext
USE_KDE4= automoc4 kdeprefix workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
diff --git a/deskutils/plasma-applet-yawp/Makefile b/deskutils/plasma-applet-yawp/Makefile
index 866624297a08..cae17d95c181 100644
--- a/deskutils/plasma-applet-yawp/Makefile
+++ b/deskutils/plasma-applet-yawp/Makefile
@@ -18,10 +18,9 @@ COMMENT= Weather plasma applet for KDE4
LICENSE= GPLv2
USE_BZIP2= yes
-USES= cmake
+USES= cmake gettext
USE_KDE4= automoc4 kdeprefix workspace
USE_QT4= qmake_build moc_build rcc_build uic_build
-USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/deskutils/rubrica/Makefile b/deskutils/rubrica/Makefile
index 95687416acff..dbd599254c4a 100644
--- a/deskutils/rubrica/Makefile
+++ b/deskutils/rubrica/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_BZIP2= yes
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gconf2 gnomeprefix libglade2
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
MAKE_JOBS_SAFE= yes
diff --git a/deskutils/steadyflow/Makefile b/deskutils/steadyflow/Makefile
index abf749766499..39659c199041 100644
--- a/deskutils/steadyflow/Makefile
+++ b/deskutils/steadyflow/Makefile
@@ -19,10 +19,9 @@ LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
USE_XZ= yes
-USES= cmake pkgconfig
+USES= cmake pkgconfig gettext
GLIB_SCHEMAS= net.launchpad.steadyflow.gschema.xml
USE_GNOME= desktopfileutils glib20 gtk30
-USE_GETTEXT= yes
INSTALLS_ICONS= yes
CMAKE_ARGS= -DCOMPILE_GSETTINGS_ON_INSTALL:BOOL=ON \
-DWANT_AYATANA:BOOL=OFF
diff --git a/deskutils/timer-applet/Makefile b/deskutils/timer-applet/Makefile
index c43d8111ca17..67adc55261b3 100644
--- a/deskutils/timer-applet/Makefile
+++ b/deskutils/timer-applet/Makefile
@@ -17,10 +17,9 @@ RUN_DEPENDS= gnome-audio>0:${PORTSDIR}/audio/gnome-audio \
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= pathfix
+USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack pygnomedesktop
USE_PYTHON= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/libexec