aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-05-07 13:08:36 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-05-07 13:08:36 +0000
commit1e94fc4ae32ac3041606443fc9d17e38ad21e1ac (patch)
tree39451c1bf4b87dd24eeac5c778c6ece8e7fd1031 /deskutils
parent3e7a3ca7508c1de1f69194fd69152543da67f1ce (diff)
downloadports-1e94fc4ae32ac3041606443fc9d17e38ad21e1ac.tar.gz
ports-1e94fc4ae32ac3041606443fc9d17e38ad21e1ac.zip
Add xfce4-taskbar-plugin 0.1.0, a taskbar plugin for xfce4-panel.
PR: ports/65984 Submitted by: Matt Lancereau <matt@rimasec.net>
Notes
Notes: svn path=/head/; revision=108616
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/xfce4-taskbar-plugin/Makefile31
-rw-r--r--deskutils/xfce4-taskbar-plugin/distinfo2
-rw-r--r--deskutils/xfce4-taskbar-plugin/pkg-descr6
-rw-r--r--deskutils/xfce4-taskbar-plugin/pkg-plist4
5 files changed, 44 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index dd9eac54950b..86218578ba9a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -107,6 +107,7 @@
SUBDIR += xchm
SUBDIR += xfce4-calendar
SUBDIR += xfce4-notes-plugin
+ SUBDIR += xfce4-taskbar-plugin
SUBDIR += xmaddressbook
SUBDIR += xmdiary
SUBDIR += xopps
diff --git a/deskutils/xfce4-taskbar-plugin/Makefile b/deskutils/xfce4-taskbar-plugin/Makefile
new file mode 100644
index 000000000000..497068162654
--- /dev/null
+++ b/deskutils/xfce4-taskbar-plugin/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xfce4-taskbar-plugin
+# Date created: 2003-04-26
+# Whom: Matt Lancereau <matt@rimasec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-taskbar-plugin
+PORTVERSION= 0.1.0
+CATEGORIES= deskutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
+ http://www.bsd-blax.org/ports/mirrors/
+DISTNAME= xfce4-taskbar-plugin-${PORTVERSION}
+
+MAINTAINER= matt@rimasec.net
+COMMENT= A taskbar plugin for xfce4-panel
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=13
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/deskutils/xfce4-taskbar-plugin/distinfo b/deskutils/xfce4-taskbar-plugin/distinfo
new file mode 100644
index 000000000000..22df789dc314
--- /dev/null
+++ b/deskutils/xfce4-taskbar-plugin/distinfo
@@ -0,0 +1,2 @@
+MD5 (xfce4-taskbar-plugin-0.1.0.tar.gz) = 02eb7fe6f1b1b944a60643f61b4fdd38
+SIZE (xfce4-taskbar-plugin-0.1.0.tar.gz) = 300008
diff --git a/deskutils/xfce4-taskbar-plugin/pkg-descr b/deskutils/xfce4-taskbar-plugin/pkg-descr
new file mode 100644
index 000000000000..7958d26ff545
--- /dev/null
+++ b/deskutils/xfce4-taskbar-plugin/pkg-descr
@@ -0,0 +1,6 @@
+xfce4-taskbar-plugin is a taskbar plugin for the xfce4-panel.
+The size of the taskbar can be changed via the properties dialog.
+
+Author: Andre Lerche <a.lerche@gmx.net>
+
+WWW: http://xfce-goodies.berlios.de/
diff --git a/deskutils/xfce4-taskbar-plugin/pkg-plist b/deskutils/xfce4-taskbar-plugin/pkg-plist
new file mode 100644
index 000000000000..ef20fd209481
--- /dev/null
+++ b/deskutils/xfce4-taskbar-plugin/pkg-plist
@@ -0,0 +1,4 @@
+lib/xfce4/panel-plugins/libtaskbar.so
+lib/xfce4/panel-plugins/libtaskbar.la
+lib/xfce4/panel-plugins/libtaskbar.a
+@unexec rmdir %D/lib/xfce4/panel-plugins 2>/dev/null || true