aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-06-07 22:44:21 +0000
commit2fa62596744270745d9d0540f5bbd839f6b78d23 (patch)
treeb7e5a1ec8ce92178c23aff878c9671b8c96b7b89 /deskutils
parente496938a05b08a6dc0a4f3562f7615a574354e2e (diff)
downloadports-2fa62596744270745d9d0540f5bbd839f6b78d23.tar.gz
ports-2fa62596744270745d9d0540f5bbd839f6b78d23.zip
Convert my ports to optionsNG
Notes
Notes: svn path=/head/; revision=298711
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/treeline/Makefile30
1 files changed, 18 insertions, 12 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index 878b59924d3b..f0ccd5422946 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -7,7 +7,7 @@
PORTNAME= treeline
PORTVERSION= 1.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/:treeline \
http://treeline.bellz.org/plugins/:plugins \
@@ -24,11 +24,6 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
${PYTHON_SITELIBDIR}/PyQt4/QtNetwork.so:${PORTSDIR}/net/py-qt4-network
-OPTIONS= ASPELL "install with aspell support" off \
- ISPELL "install with ispell support" off \
- PYXML "use pythons py-xml instead of textproc/expat2" on \
- HTTPLOAD "install httpLoad plugin" off
-
WRKSRC= ${WRKDIR}/TreeLine
USE_QT4= # empty
USE_PYTHON= 2.5+
@@ -38,21 +33,32 @@ DESKTOP_ENTRIES= "TreeLine" "Structured information storage program" \
"${DATADIR}/icons/tree/treeline.png" "treeline" \
"Utility;" false
+OPTIONS_DEFINE= HTTPLOAD PYXML
+OPTIONS_SINGLE= SPELLER
+OPTIONS_SINGLE_SPELLER= ASPELL ISPELL
+
+ASPELL_DESC= Install with aspell support
+HTTPLOAD_DESC= Install httpLoad plugin
+ISPELL_DESC= Install with ispell support
+PYXML_DESC= Use pythons py-xml instead of textproc/expat2
+
+OPTIONS_DEFAULT= ASPELL PYXML
+
.include <bsd.port.options.mk>
-.if defined(WITH_ASPELL)
+.if ${PORT_OPTIONS:MASPELL}
BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
.endif
-.if defined(WITH_ISPELL)
+.if ${PORT_OPTIONS:MISPELL}
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
-.if defined(WITHOUT_PYXML)
+.if !${PORT_OPTIONS:MPYXML}
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
.endif
-.if defined(WITH_HTTPLOAD)
+.if ${PORT_OPTIONS:MHTTPLOAD}
DISTFILES+= httpload2.py:plugins
PLIST_SUB+= HTTPLOAD=""
.else
@@ -62,14 +68,14 @@ PLIST_SUB+= HTTPLOAD="@comment "
do-install:
@cd ${WRKSRC} && ${PYTHON_CMD} install.py \
-p ${PREFIX} -d ${DOCSDIR} -i ${DATADIR}/icons -x
-.if defined(WITH_HTTPLOAD)
+.if ${PORT_OPTIONS:MHTTPLOAD}
@${INSTALL_DATA} -d ${PREFIX}/lib/${PORTNAME}/plugins/
@${INSTALL_DATA} ${DISTDIR}/httpload2.py ${PREFIX}/lib/${PORTNAME}/plugins/
.endif
post-install:
${RM} ${DOCSDIR}/INSTALL ${DOCSDIR}/LICENSE
-.if defined(NOPORTDOCS)
+.if !${PORT_OPTIONS:MDOCS}
${RM} ${DOCSDIR}/*
${RMDIR} ${DOCSDIR}
.endif