aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2005-07-25 16:13:01 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2005-07-25 16:13:01 +0000
commitb90b51bb0dfa8ce1808820afdc79b7c1ef1e3c89 (patch)
tree9e3f4fe934f6f91ed7401beb14d46d0253329156 /deskutils
parentd1904a95140ae38397da87fcf6a2fdc1f5887911 (diff)
downloadports-b90b51bb0dfa8ce1808820afdc79b7c1ef1e3c89.tar.gz
ports-b90b51bb0dfa8ce1808820afdc79b7c1ef1e3c89.zip
Add kchmviewer 0.92, a Qt/KDE viewer for CHM files.
KchmViewer is a chm (MS HTML help file format) viewer. Unlike most existing CHM viewers for Unix, it uses Trolltech's Qt widget library, and does not depend on KDE or Gnome. However, it may be compiled with full KDE support, including KDE widgets and KIO/KHTML. The main advantage of KchmViewer is non-english language support. Unlike others, KchmViewer in most cases correctly detects help file encoding, correctly shows tables of context of russian, korean, chinese and japanese help files, and correctly searches in non-english help files. WWW: http://kchmviewer.sourceforge.net/
Notes
Notes: svn path=/head/; revision=140103
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/kchmviewer-kde4/Makefile42
-rw-r--r--deskutils/kchmviewer-kde4/distinfo2
-rw-r--r--deskutils/kchmviewer-kde4/files/patch-src-kchmmainwindow.cpp10
-rw-r--r--deskutils/kchmviewer-kde4/files/patch-src-xchmfile.cpp11
-rw-r--r--deskutils/kchmviewer-kde4/pkg-descr11
-rw-r--r--deskutils/kchmviewer-kde4/pkg-plist6
-rw-r--r--deskutils/kchmviewer/Makefile42
-rw-r--r--deskutils/kchmviewer/distinfo2
-rw-r--r--deskutils/kchmviewer/files/patch-src-kchmmainwindow.cpp10
-rw-r--r--deskutils/kchmviewer/files/patch-src-xchmfile.cpp11
-rw-r--r--deskutils/kchmviewer/pkg-descr11
-rw-r--r--deskutils/kchmviewer/pkg-plist6
13 files changed, 165 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index bdc669abc6d3..f422342c3383 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -77,6 +77,7 @@
SUBDIR += kbirthday
SUBDIR += kblticker
SUBDIR += kchm
+ SUBDIR += kchmviewer
SUBDIR += kdepim3
SUBDIR += kdissert
SUBDIR += kickpim
diff --git a/deskutils/kchmviewer-kde4/Makefile b/deskutils/kchmviewer-kde4/Makefile
new file mode 100644
index 000000000000..1b9d0baf6d76
--- /dev/null
+++ b/deskutils/kchmviewer-kde4/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: kchmviewer
+# Date created: Mon Jul 25 10:42:16 CEST 2005
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kchmviewer
+PORTVERSION= 0.92
+CATEGORIES= deskutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= A Qt/KDE viewer for CHM files
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+
+.if !defined(WITHOUT_KDE)
+USE_KDELIBS_VER=3
+PLIST_SUB+= KDE=""
+CONFIGURE_ARGS+=--with-kde
+.else
+USE_QT_VER= 3
+PLIST_SUB+= KDE="@comment "
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_KDE)
+ @${ECHO_MSG} "You can disable KDE support by defining WITHOUT_KDE."
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g;s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/deskutils/kchmviewer-kde4/distinfo b/deskutils/kchmviewer-kde4/distinfo
new file mode 100644
index 000000000000..9132adcc1529
--- /dev/null
+++ b/deskutils/kchmviewer-kde4/distinfo
@@ -0,0 +1,2 @@
+MD5 (kchmviewer-0.92.tar.gz) = da89c8b3b8b5db7dc509957194414d2b
+SIZE (kchmviewer-0.92.tar.gz) = 557714
diff --git a/deskutils/kchmviewer-kde4/files/patch-src-kchmmainwindow.cpp b/deskutils/kchmviewer-kde4/files/patch-src-kchmmainwindow.cpp
new file mode 100644
index 000000000000..8b0129d1aec3
--- /dev/null
+++ b/deskutils/kchmviewer-kde4/files/patch-src-kchmmainwindow.cpp
@@ -0,0 +1,10 @@
+--- src/kchmmainwindow.cpp.orig Mon Jul 25 12:51:22 2005
++++ src/kchmmainwindow.cpp Mon Jul 25 12:52:48 2005
+@@ -22,6 +22,7 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <errno.h>
++#include <unistd.h>
+
+ #include "kde-qt.h"
+
diff --git a/deskutils/kchmviewer-kde4/files/patch-src-xchmfile.cpp b/deskutils/kchmviewer-kde4/files/patch-src-xchmfile.cpp
new file mode 100644
index 000000000000..01e4543826da
--- /dev/null
+++ b/deskutils/kchmviewer-kde4/files/patch-src-xchmfile.cpp
@@ -0,0 +1,11 @@
+--- src/xchmfile.cpp.orig Mon Jul 25 12:27:20 2005
++++ src/xchmfile.cpp Mon Jul 25 12:28:16 2005
+@@ -1189,7 +1189,7 @@
+ FIXENDIAN32(off_url);
+
+ if ( RetrieveObject ( &m_chmURLSTR, buf, off_url + 8, sizeof(buf) - 1) == 0 )
+- return false;
++ return QString::null;
+
+ buf[sizeof(buf) - 1] = '\0';
+ url = KCHMViewWindow::makeURLabsoluteIfNeeded ((const char*)buf);
diff --git a/deskutils/kchmviewer-kde4/pkg-descr b/deskutils/kchmviewer-kde4/pkg-descr
new file mode 100644
index 000000000000..ba5dc0cabd52
--- /dev/null
+++ b/deskutils/kchmviewer-kde4/pkg-descr
@@ -0,0 +1,11 @@
+KchmViewer is a chm (MS HTML help file format) viewer. Unlike most existing
+CHM viewers for Unix, it uses Trolltech's Qt widget library, and does not
+depend on KDE or Gnome. However, it may be compiled with full KDE support,
+including KDE widgets and KIO/KHTML.
+
+The main advantage of KchmViewer is non-english language support. Unlike
+others, KchmViewer in most cases correctly detects help file encoding,
+correctly shows tables of context of russian, korean, chinese and japanese
+help files, and correctly searches in non-english help files.
+
+WWW: http://kchmviewer.sourceforge.net/
diff --git a/deskutils/kchmviewer-kde4/pkg-plist b/deskutils/kchmviewer-kde4/pkg-plist
new file mode 100644
index 000000000000..47e1550fb9b9
--- /dev/null
+++ b/deskutils/kchmviewer-kde4/pkg-plist
@@ -0,0 +1,6 @@
+bin/kchmviewer
+%%KDE%%lib/kde3/kio_msits.a
+%%KDE%%lib/kde3/kio_msits.la
+%%KDE%%lib/kde3/kio_msits.so
+%%KDE%%share/applnk/kchmviewer.desktop
+%%KDE%%share/services/msits.protocol
diff --git a/deskutils/kchmviewer/Makefile b/deskutils/kchmviewer/Makefile
new file mode 100644
index 000000000000..1b9d0baf6d76
--- /dev/null
+++ b/deskutils/kchmviewer/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: kchmviewer
+# Date created: Mon Jul 25 10:42:16 CEST 2005
+# Whom: Markus Brueffer <markus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kchmviewer
+PORTVERSION= 0.92
+CATEGORIES= deskutils kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= markus@FreeBSD.org
+COMMENT= A Qt/KDE viewer for CHM files
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+
+.if !defined(WITHOUT_KDE)
+USE_KDELIBS_VER=3
+PLIST_SUB+= KDE=""
+CONFIGURE_ARGS+=--with-kde
+.else
+USE_QT_VER= 3
+PLIST_SUB+= KDE="@comment "
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_KDE)
+ @${ECHO_MSG} "You can disable KDE support by defining WITHOUT_KDE."
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g;s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/deskutils/kchmviewer/distinfo b/deskutils/kchmviewer/distinfo
new file mode 100644
index 000000000000..9132adcc1529
--- /dev/null
+++ b/deskutils/kchmviewer/distinfo
@@ -0,0 +1,2 @@
+MD5 (kchmviewer-0.92.tar.gz) = da89c8b3b8b5db7dc509957194414d2b
+SIZE (kchmviewer-0.92.tar.gz) = 557714
diff --git a/deskutils/kchmviewer/files/patch-src-kchmmainwindow.cpp b/deskutils/kchmviewer/files/patch-src-kchmmainwindow.cpp
new file mode 100644
index 000000000000..8b0129d1aec3
--- /dev/null
+++ b/deskutils/kchmviewer/files/patch-src-kchmmainwindow.cpp
@@ -0,0 +1,10 @@
+--- src/kchmmainwindow.cpp.orig Mon Jul 25 12:51:22 2005
++++ src/kchmmainwindow.cpp Mon Jul 25 12:52:48 2005
+@@ -22,6 +22,7 @@
+ #include <signal.h>
+ #include <string.h>
+ #include <errno.h>
++#include <unistd.h>
+
+ #include "kde-qt.h"
+
diff --git a/deskutils/kchmviewer/files/patch-src-xchmfile.cpp b/deskutils/kchmviewer/files/patch-src-xchmfile.cpp
new file mode 100644
index 000000000000..01e4543826da
--- /dev/null
+++ b/deskutils/kchmviewer/files/patch-src-xchmfile.cpp
@@ -0,0 +1,11 @@
+--- src/xchmfile.cpp.orig Mon Jul 25 12:27:20 2005
++++ src/xchmfile.cpp Mon Jul 25 12:28:16 2005
+@@ -1189,7 +1189,7 @@
+ FIXENDIAN32(off_url);
+
+ if ( RetrieveObject ( &m_chmURLSTR, buf, off_url + 8, sizeof(buf) - 1) == 0 )
+- return false;
++ return QString::null;
+
+ buf[sizeof(buf) - 1] = '\0';
+ url = KCHMViewWindow::makeURLabsoluteIfNeeded ((const char*)buf);
diff --git a/deskutils/kchmviewer/pkg-descr b/deskutils/kchmviewer/pkg-descr
new file mode 100644
index 000000000000..ba5dc0cabd52
--- /dev/null
+++ b/deskutils/kchmviewer/pkg-descr
@@ -0,0 +1,11 @@
+KchmViewer is a chm (MS HTML help file format) viewer. Unlike most existing
+CHM viewers for Unix, it uses Trolltech's Qt widget library, and does not
+depend on KDE or Gnome. However, it may be compiled with full KDE support,
+including KDE widgets and KIO/KHTML.
+
+The main advantage of KchmViewer is non-english language support. Unlike
+others, KchmViewer in most cases correctly detects help file encoding,
+correctly shows tables of context of russian, korean, chinese and japanese
+help files, and correctly searches in non-english help files.
+
+WWW: http://kchmviewer.sourceforge.net/
diff --git a/deskutils/kchmviewer/pkg-plist b/deskutils/kchmviewer/pkg-plist
new file mode 100644
index 000000000000..47e1550fb9b9
--- /dev/null
+++ b/deskutils/kchmviewer/pkg-plist
@@ -0,0 +1,6 @@
+bin/kchmviewer
+%%KDE%%lib/kde3/kio_msits.a
+%%KDE%%lib/kde3/kio_msits.la
+%%KDE%%lib/kde3/kio_msits.so
+%%KDE%%share/applnk/kchmviewer.desktop
+%%KDE%%share/services/msits.protocol