aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-05-12 06:33:23 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-05-12 06:33:23 +0000
commit1dfa1ba01a317731508dcfc725b9b72947e7ae95 (patch)
tree037b5b7ef35956aa3551658bf2a292451e37ec0f /deskutils
parent9e17465086fde24bea2f9f0268cee272edd90fd7 (diff)
downloadports-1dfa1ba01a317731508dcfc725b9b72947e7ae95.tar.gz
ports-1dfa1ba01a317731508dcfc725b9b72947e7ae95.zip
Upgrade, 3.4 -> 3.5.
PR: 3181 3372 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=6444
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/cal/Makefile33
-rw-r--r--deskutils/cal/distinfo2
-rw-r--r--deskutils/cal/files/patch-aa21
-rw-r--r--deskutils/cal/files/patch-ab57
4 files changed, 60 insertions, 53 deletions
diff --git a/deskutils/cal/Makefile b/deskutils/cal/Makefile
index 6848522ce28a..804fc9d6ac17 100644
--- a/deskutils/cal/Makefile
+++ b/deskutils/cal/Makefile
@@ -1,30 +1,29 @@
# New ports collection makefile for: cal
-# Version required: 3.4
-# Date created: 6 July 1996
-# Whom: Andrey Zakhvatov <andy@cgu.chel.su>
+# Version required: 3.5
+# Date created: 2 April 1997
+# Whom: Andrey Zakhvatov <andy@icc.surw.chel.su>
#
-# $Id: Makefile,v 1.3 1996/11/17 09:05:25 obrien Exp $
+# $Id$
#
-DISTNAME= cal-3.4
-CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
+DISTNAME= cal-3.5
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= utils/shell
-MAINTAINER= andy@cgu.chel.su
+MAINTAINER= andy@icc.surw.chel.su
-WRKSRC= ${WRKDIR}/cal34/source
+WRKSRC= ${WRKDIR}/cal-3.5/source
+MAKEFILE= makefile.unx
ALL_TARGET= cal
MAN1= cal.1
-pre-patch:
- @ /bin/mv ${WRKSRC}/makefile.unx ${WRKSRC}/Makefile
-
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/cal ${PREFIX}/bin/cal
- @${INSTALL_MAN} ${WRKSRC}/cal.1 ${PREFIX}/man/man1/cal.1
- @ if [ ! -d ${PREFIX}/etc/cal ]; then ${MKDIR} ${PREFIX}/etc/cal; chmod 0755 ${PREFIX}/etc/cal; fi
- @ if [ ! -f ${PREFIX}/etc/cal/calcol ]; then ${INSTALL_DATA} ${WRKDIR}/cal34/cal.col ${PREFIX}/etc/cal/calcol; fi
- @ if [ ! -f ${PREFIX}/etc/cal/caldat ]; then ${INSTALL_DATA} ${WRKDIR}/cal34/cal.dat ${PREFIX}/etc/cal/caldat; fi
+ ${INSTALL_PROGRAM} ${WRKSRC}/cal ${PREFIX}/bin/cal
+ ${INSTALL_MAN} ${WRKSRC}/cal.1 ${PREFIX}/man/man1/cal.1
+ @${MKDIR} ${PREFIX}/etc/cal
+ @chmod 0755 ${PREFIX}/etc/cal
+ if [ ! -f ${PREFIX}/etc/cal/calcol ]; then ${INSTALL_DATA} ${WRKDIR}/cal-3.5/cal.col ${PREFIX}/etc/cal/calcol; fi
+ if [ ! -f ${PREFIX}/etc/cal/caldat ]; then ${INSTALL_DATA} ${WRKDIR}/cal-3.5/cal.dat ${PREFIX}/etc/cal/caldat; fi
.include <bsd.port.mk>
diff --git a/deskutils/cal/distinfo b/deskutils/cal/distinfo
index 91b5a358d064..7633bf9ab996 100644
--- a/deskutils/cal/distinfo
+++ b/deskutils/cal/distinfo
@@ -1 +1 @@
-MD5 (cal-3.4.tar.gz) = 699c45fd22917dcd32578206b1f8e38c
+MD5 (cal-3.5.tar.gz) = e947731574da1731bccbe35ad2769a99
diff --git a/deskutils/cal/files/patch-aa b/deskutils/cal/files/patch-aa
index 86a9da909e50..c4e647ffac84 100644
--- a/deskutils/cal/files/patch-aa
+++ b/deskutils/cal/files/patch-aa
@@ -1,16 +1,15 @@
-*** Makefile Thu Dec 28 05:29:16 1995
---- /home/andy/ports/cal/src/source/Makefile Thu Jun 13 23:33:23 1996
+*** makefile.unx.orig Tue Mar 5 06:36:27 1996
+--- makefile.unx Mon May 12 15:23:42 1997
***************
-*** 7,13 ****
---- 7,17 ----
- # To use, enter "make -f makefile.unx"
-
+*** 10,15 ****
+--- 10,19 ----
CC=gcc
+ CFLAGS=-O -Wall -DUNIX -DUSE_REMINDER
+
+ .ifdef PREFIX
-+ CFLAGS+=-DUNIX -DPREFIX="\"${PREFIX}\""
-+ .else
- CFLAGS=-DUNIX
++ CFLAGS+=-DPREFIX="\"${PREFIX}\""
+ .endif
-
- default: cal
++
+ BINDIR=/usr/bin
+ MANDIR=/usr/man
diff --git a/deskutils/cal/files/patch-ab b/deskutils/cal/files/patch-ab
index 200d34f582b6..88ce105c56f4 100644
--- a/deskutils/cal/files/patch-ab
+++ b/deskutils/cal/files/patch-ab
@@ -1,29 +1,38 @@
-*** cal.c Thu Dec 28 05:43:12 1995
---- /home/andy/ports/cal/src/source/cal.c Sat Jun 22 15:47:26 1996
+*** cal.c.orig Fri Jul 12 04:36:33 1996
+--- cal.c Mon May 12 15:23:51 1997
***************
-*** 128,133 ****
---- 128,137 ----
- #define stricmp(a,b) strcasecmp(a,b) /* case-insensitive string comparison */
- #endif
-
-+ #ifdef __FreeBSD__ /* Make FreeBSD compatible with stricmp() */
+*** 130,135 ****
+--- 130,139 ----
+ /* Note: Other unix systems may require this next re-define to work. */
+ /* I believe that SCO is one such system. Please send in any fixes */
+ /* needed to get your system running. */
++ #ifdef __FreeBSD__ /* Make FreeBSD compatible with stricmp() */
+ #define stricmp(a,b) strcasecmp(a,b) /* case-insensitive string comparison */
+ #endif
-+
- #ifdef __ZTC__ /* make Zortech compatible with stricmp() */
- #define stricmp(a,b) strcmpl(a,b) /* case-insensitive string comparison */
- #endif /* __ZTC__ */
++
+ #ifdef __linux__ /* Make linux compatible with stricmp() */
+ #define stricmp(a,b) strcasecmp(a,b) /* case-insensitive string comparison */
+ #endif
***************
-*** 1090,1096 ****
---- 1094,1104 ----
- strcpy(str, file);
- if ((fp = fopen(str, mode)) == NULL) {
- /* If still not found then look in a lib directory */
-+ #ifdef PREFIX
-+ strcpy(str, PREFIX "/etc/cal/");
-+ #else
- strcpy(str, "/usr/lib/");
+*** 1401,1408 ****
+ strcpy(str, ".");
+ strcpy(str, file);
+ if ((fp = fopen(str, mode)) == NULL) {
+! /* If still not found then look in a lib directory */
+ strcpy(str, "/usr/lib/");
+ strcat(str,file);
+ fp = fopen(str, mode);
+ }
+--- 1405,1416 ----
+ strcpy(str, ".");
+ strcpy(str, file);
+ if ((fp = fopen(str, mode)) == NULL) {
+! /* If still not found then look in config directory */
+! #ifdef PREFIX
+! strcpy(str, PREFIX "/etc/cal/");
+! #else
+ strcpy(str, "/usr/lib/");
+ #endif
- strcat(str,file);
- fp = fopen(str, mode);
- }
+ strcat(str,file);
+ fp = fopen(str, mode);
+ }