aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-28 07:46:44 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-28 07:46:44 +0000
commite762f333a1b6d5559dff78899ecee86a045b8954 (patch)
tree1d4cb9e8214d1c01eb38a69fd544c454d2c2a651 /deskutils
parentd523550ac8889dd3363f7e42b934350eb80153bf (diff)
downloadports-e762f333a1b6d5559dff78899ecee86a045b8954.tar.gz
ports-e762f333a1b6d5559dff78899ecee86a045b8954.zip
Add gdeskcal, a calendar for the GNOME 2 desktop featuring alpha-blending.
PR: 48757 Submitted by: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
Notes
Notes: svn path=/head/; revision=76613
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gdeskcal/Makefile70
-rw-r--r--deskutils/gdeskcal/distinfo1
-rw-r--r--deskutils/gdeskcal/pkg-descr5
-rw-r--r--deskutils/gdeskcal/pkg-plist52
5 files changed, 129 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index c224c8d581db..0dd785be337d 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -12,6 +12,7 @@
SUBDIR += dailystrips
SUBDIR += gaddr
SUBDIR += gcal
+ SUBDIR += gdeskcal
SUBDIR += gemcal
SUBDIR += genius
SUBDIR += glabels
diff --git a/deskutils/gdeskcal/Makefile b/deskutils/gdeskcal/Makefile
new file mode 100644
index 000000000000..4a44e3c995f0
--- /dev/null
+++ b/deskutils/gdeskcal/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: gdeskcal
+# Date created: 27 February 2003
+# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdeskcal
+PORTVERSION= 0.30
+CATEGORIES= deskutils python gnome
+MASTER_SITES= http://www.pycage.de/download/
+DISTNAME= gDeskCal-${PORTVERSION:S/./_/}
+
+MAINTAINER= martin.klaffenboeck@gmx.at
+COMMENT= A calendar for the gnome2 desktop with smooth alpha-blending
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
+
+WRKSRC= ${WRKDIR}/gDeskCal-${PORTVERSION}
+
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehier
+NO_BUILD= yes
+
+DATA_DIRS= code data skins
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/gnome/gdeskcal
+ for d in ${DATA_DIRS}; do \
+ ${MKDIR} ${PREFIX}/share/gnome/gdeskcal/$$d ; \
+ cd ${WRKSRC}/$$d && ${FIND} . | \
+ cpio -pdm -L -R ${LIBOWN}:${LIBGRP} \
+ ${PREFIX}/share/gnome/gdeskcal/$$d ; \
+ done
+ ${INSTALL_SCRIPT} ${WRKSRC}/gdeskcal \
+ ${PREFIX}/share/gnome/gdeskcal
+# XXX Gack! This is ugly, but somewhat necessary.
+ ${INSTALL_DATA} ${WRKSRC}/locale/ar_AE/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/ar/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/cs/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/cs/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/de/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/de/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/el/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/el/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/es/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/es/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/fr/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/fr/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/he/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/he/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/hu/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/hu/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/it/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/it/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/ja/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/ja/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/nl/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/nl/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/ru/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/ru/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/tr/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/tr/LC_MESSAGES
+ ${INSTALL_DATA} ${WRKSRC}/locale/zh_CN/LC_MESSAGES/gdeskcal.mo \
+ ${PREFIX}/share/locale/zh_CN/LC_MESSAGES
+ ${LN} -sf ${PREFIX}/share/gnome/gdeskcal/gdeskcal ${PREFIX}/bin/gdeskcal
+
+.include <bsd.port.mk>
diff --git a/deskutils/gdeskcal/distinfo b/deskutils/gdeskcal/distinfo
new file mode 100644
index 000000000000..009fe69b1915
--- /dev/null
+++ b/deskutils/gdeskcal/distinfo
@@ -0,0 +1 @@
+MD5 (gDeskCal-0_30.tar.gz) = c96e038202f891f256aaf306902f44f3
diff --git a/deskutils/gdeskcal/pkg-descr b/deskutils/gdeskcal/pkg-descr
new file mode 100644
index 000000000000..73a4ec03e291
--- /dev/null
+++ b/deskutils/gdeskcal/pkg-descr
@@ -0,0 +1,5 @@
+gDeskCal is a cute little eye-candy calendar for your desktop.
+It features transparency with smooth alpha-blending and its appearance
+can be changed completely by using skins.
+
+WWW: http://www.pycage.de/software_gdeskcal.html
diff --git a/deskutils/gdeskcal/pkg-plist b/deskutils/gdeskcal/pkg-plist
new file mode 100644
index 000000000000..79d8616f4a86
--- /dev/null
+++ b/deskutils/gdeskcal/pkg-plist
@@ -0,0 +1,52 @@
+bin/gdeskcal
+share/gnome/gdeskcal/code/BGWatcher.py
+share/gnome/gdeskcal/code/Cal.py
+share/gnome/gdeskcal/code/CalLabel.py
+share/gnome/gdeskcal/code/CalMediator.py
+share/gnome/gdeskcal/code/CalWindow.py
+share/gnome/gdeskcal/code/Config.py
+share/gnome/gdeskcal/code/ConfigFormatLoader.py
+share/gnome/gdeskcal/code/ConfigLoader.py
+share/gnome/gdeskcal/code/Menu.py
+share/gnome/gdeskcal/code/Navigation.py
+share/gnome/gdeskcal/code/Observable.py
+share/gnome/gdeskcal/code/SkinBrowser.py
+share/gnome/gdeskcal/code/TimeWatcher.py
+share/gnome/gdeskcal/code/__init__.py
+share/gnome/gdeskcal/code/cmdlineparser.py
+share/gnome/gdeskcal/code/configvalues.py
+share/gnome/gdeskcal/code/desktop.py
+share/gnome/gdeskcal/code/errormessage.py
+share/gnome/gdeskcal/code/i18n.py
+share/gnome/gdeskcal/code/values.py
+share/gnome/gdeskcal/data/config.xml
+share/gnome/gdeskcal/data/format.xml
+share/gnome/gdeskcal/gdeskcal
+share/gnome/gdeskcal/skins/default/bg.png
+share/gnome/gdeskcal/skins/default/bg.xcf
+share/gnome/gdeskcal/skins/default/home.png
+share/gnome/gdeskcal/skins/default/next.png
+share/gnome/gdeskcal/skins/default/prev.png
+share/gnome/gdeskcal/skins/default/skin.xml
+share/gnome/gdeskcal/skins/default/today.png
+share/gnome/gdeskcal/skins/big_and_simple/skin.xml
+share/locale/ar/LC_MESSAGES/gdeskcal.mo
+share/locale/cs/LC_MESSAGES/gdeskcal.mo
+share/locale/de/LC_MESSAGES/gdeskcal.mo
+share/locale/el/LC_MESSAGES/gdeskcal.mo
+share/locale/es/LC_MESSAGES/gdeskcal.mo
+share/locale/fr/LC_MESSAGES/gdeskcal.mo
+share/locale/he/LC_MESSAGES/gdeskcal.mo
+share/locale/hu/LC_MESSAGES/gdeskcal.mo
+share/locale/it/LC_MESSAGES/gdeskcal.mo
+share/locale/ja/LC_MESSAGES/gdeskcal.mo
+share/locale/nl/LC_MESSAGES/gdeskcal.mo
+share/locale/ru/LC_MESSAGES/gdeskcal.mo
+share/locale/tr/LC_MESSAGES/gdeskcal.mo
+share/locale/zh_CN/LC_MESSAGES/gdeskcal.mo
+@dirrm share/gnome/gdeskcal/skins/default
+@dirrm share/gnome/gdeskcal/skins/big_and_simple
+@dirrm share/gnome/gdeskcal/skins
+@dirrm share/gnome/gdeskcal/data
+@dirrm share/gnome/gdeskcal/code
+@dirrm share/gnome/gdeskcal