aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-05-07 13:09:21 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-05-07 13:09:21 +0000
commit138a5a429c02cc83b5de48690183d8e665439fa2 (patch)
tree26d65517eb47d4dad362f5dc519452e8326f93f2 /deskutils
parent1e94fc4ae32ac3041606443fc9d17e38ad21e1ac (diff)
downloadports-138a5a429c02cc83b5de48690183d8e665439fa2.tar.gz
ports-138a5a429c02cc83b5de48690183d8e665439fa2.zip
Add xfce4-windowlist-plugin 0.1.0, a windowlist plugin for xfce4-panel.
PR: ports/65985 Submitted by: Matt Lancereau <matt@rimasec.net>
Notes
Notes: svn path=/head/; revision=108618
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/xfce4-windowlist-plugin/Makefile31
-rw-r--r--deskutils/xfce4-windowlist-plugin/distinfo2
-rw-r--r--deskutils/xfce4-windowlist-plugin/pkg-descr12
-rw-r--r--deskutils/xfce4-windowlist-plugin/pkg-plist4
5 files changed, 50 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 86218578ba9a..b0d50d9c1b4d 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -108,6 +108,7 @@
SUBDIR += xfce4-calendar
SUBDIR += xfce4-notes-plugin
SUBDIR += xfce4-taskbar-plugin
+ SUBDIR += xfce4-windowlist-plugin
SUBDIR += xmaddressbook
SUBDIR += xmdiary
SUBDIR += xopps
diff --git a/deskutils/xfce4-windowlist-plugin/Makefile b/deskutils/xfce4-windowlist-plugin/Makefile
new file mode 100644
index 000000000000..acf47109f1ca
--- /dev/null
+++ b/deskutils/xfce4-windowlist-plugin/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xfce4-windowlist-plugin
+# Date created: 2003-04-26
+# Whom: Matt Lancereau <matt@rimasec.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-windowlist-plugin
+PORTVERSION= 0.1.0
+CATEGORIES= deskutils xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/ \
+ http://www.bsd-blax.org/ports/mirrors/
+DISTNAME= xfce4-windowlist-plugin-${PORTVERSION}
+
+MAINTAINER= matt@rimasec.net
+COMMENT= A windowlist plugin for xfce4-panel
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+
+USE_GNOME= gtk20 libxml2
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=13
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/deskutils/xfce4-windowlist-plugin/distinfo b/deskutils/xfce4-windowlist-plugin/distinfo
new file mode 100644
index 000000000000..f05eab0f4880
--- /dev/null
+++ b/deskutils/xfce4-windowlist-plugin/distinfo
@@ -0,0 +1,2 @@
+MD5 (xfce4-windowlist-plugin-0.1.0.tar.gz) = 29b1a752003734c0b8171200dfafb733
+SIZE (xfce4-windowlist-plugin-0.1.0.tar.gz) = 301770
diff --git a/deskutils/xfce4-windowlist-plugin/pkg-descr b/deskutils/xfce4-windowlist-plugin/pkg-descr
new file mode 100644
index 000000000000..afbb48e1b9e4
--- /dev/null
+++ b/deskutils/xfce4-windowlist-plugin/pkg-descr
@@ -0,0 +1,12 @@
+xfce4-windowlist-plugin is a windowlist plugin for the xfce4-panel.
+
+The menubutton shows the icon of the active window.
+
+Leftclick on the menubutton pops up a configurable window
+list (windows on the current workspace or all windows).
+Leftclick on the window list activates the selected window,
+rightclick pops up a window action menu.
+
+Author: Andre Lerche <a.lerche@gmx.net>
+
+WWW: http://xfce-goodies.berlios.de/
diff --git a/deskutils/xfce4-windowlist-plugin/pkg-plist b/deskutils/xfce4-windowlist-plugin/pkg-plist
new file mode 100644
index 000000000000..cd2f2e445b4d
--- /dev/null
+++ b/deskutils/xfce4-windowlist-plugin/pkg-plist
@@ -0,0 +1,4 @@
+lib/xfce4/panel-plugins/libwindowlist.so
+lib/xfce4/panel-plugins/libwindowlist.la
+lib/xfce4/panel-plugins/libwindowlist.a
+@unexec rmdir %D/lib/xfce4/panel-plugins 2>/dev/null || true