aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2005-02-06 11:55:12 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2005-02-06 11:55:12 +0000
commitdba16d0462b106294fc05769120902ce8bf20774 (patch)
treea371097fd85518b221b6d622df32a245027dbb8d /deskutils
parentdceb9848b79e03d1a8cc7521cd164a7934e72771 (diff)
downloadports-dba16d0462b106294fc05769120902ce8bf20774.tar.gz
ports-dba16d0462b106294fc05769120902ce8bf20774.zip
Lower-case the group name, not the entire image file name. This makes
"Display layout as image" work.
Notes
Notes: svn path=/head/; revision=128133
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xfce4-xkb-plugin/Makefile2
-rw-r--r--deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/deskutils/xfce4-xkb-plugin/Makefile b/deskutils/xfce4-xkb-plugin/Makefile
index e31133ad9b01..7355bd6e2ae4 100644
--- a/deskutils/xfce4-xkb-plugin/Makefile
+++ b/deskutils/xfce4-xkb-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-xkb-plugin
PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils xfce
MASTER_SITES= http://download.berlios.de/xfce-goodies/
DIST_SUBDIR= xfce4
diff --git a/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c b/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c
new file mode 100644
index 000000000000..7d72d7b174c1
--- /dev/null
+++ b/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c
@@ -0,0 +1,15 @@
+--- panel-plugin/xkb.c.orig Wed Jun 30 11:46:49 2004
++++ panel-plugin/xkb.c Sun Feb 6 12:51:04 2005
+@@ -264,12 +264,12 @@
+ char *group;
+
+ group = strdup(get_symbol_name_by_res_no(current_group_xkb_no));
++ to_lower(group);
+ strcpy(filename, FLAGSDIR);
+ strcat(filename, "/");
+ strcat(filename, group);
+ strcat(filename, ".png");
+- to_lower(filename);
+
+ free(group);
+