aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2004-05-27 08:27:55 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2004-05-27 08:27:55 +0000
commit345b971621183420d5d41b2d5a89296fe5f16b11 (patch)
treecef7f36ec0fb27c2a471f093e723f798b63bc7ee /deskutils
parentc679f4759f06f3d7d52931971d58f1e01aa8b1c2 (diff)
downloadports-345b971621183420d5d41b2d5a89296fe5f16b11.tar.gz
ports-345b971621183420d5d41b2d5a89296fe5f16b11.zip
deskutils/logjam2 -> deskutils/logjam
GTK2 logjam (was logjam2) is now default and remove the GTK1 logjam. Also, included some tweaks and cleans up like add checks if libraries exist and depend on them by automatic. PR: ports/66620 Approved by: adamw (mentor)
Notes
Notes: svn path=/head/; revision=110119
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/logjam/Makefile52
-rw-r--r--deskutils/logjam/distinfo4
-rw-r--r--deskutils/logjam/files/patch-src::cmdline.c (renamed from deskutils/logjam2/files/patch-src::cmdline.c)0
-rw-r--r--deskutils/logjam/files/patch-src::get_cmd_out.c (renamed from deskutils/logjam2/files/patch-src::get_cmd_out.c)0
-rw-r--r--deskutils/logjam/pkg-descr11
-rw-r--r--deskutils/logjam/pkg-plist13
-rw-r--r--deskutils/logjam2/Makefile69
-rw-r--r--deskutils/logjam2/distinfo2
-rw-r--r--deskutils/logjam2/pkg-descr12
-rw-r--r--deskutils/logjam2/pkg-plist12
11 files changed, 66 insertions, 110 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 9cb08c460d56..7eb1b4f7f082 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -69,7 +69,6 @@
SUBDIR += ljcharm
SUBDIR += ljclive
SUBDIR += logjam
- SUBDIR += logjam2
SUBDIR += mcal
SUBDIR += mdh
SUBDIR += mencal
diff --git a/deskutils/logjam/Makefile b/deskutils/logjam/Makefile
index 549becdbe2dc..0ee3a5666f3c 100644
--- a/deskutils/logjam/Makefile
+++ b/deskutils/logjam/Makefile
@@ -6,20 +6,60 @@
#
PORTNAME= logjam
-PORTVERSION= 3.0.4
-PORTREVISION= 1
+PORTVERSION= 4.4.0
CATEGORIES= deskutils
MASTER_SITES= http://logjam.danga.com/download/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK interface to user journals on www.livejournal.com
+MAINTAINER= mike.patterson@unb.ca
+COMMENT= A GTK2 interface to livejournals, ie www.livejournal.com
LIB_DEPENDS= curl.2:${PORTSDIR}/ftp/curl
MAN1= logjam.1
+USE_BZIP2= yes
USE_GMAKE= yes
+WANT_GNOME= yes
+USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_GNOME= gtk12
+USE_GNOME= gnomehack gnomeprefix gtk20 libxml2 intlhack
+CONFIGURE_ARGS= --program-transform-name="s/$$//"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.ifndef(WITHOUT_GTKSPELL)
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
+.else
+CONFIGURE_ARGS+= --without-gtkspell
+.endif
+
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+PLIST_SUB+= WITH_XMMS=""
+.else
+PLIST_SUB+= WITH_XMMS="@comment "
+CONFIGURE_ARGS+= --without-xmms
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgtkhtml3}!=""
+USE_GNOME+= gtkhtml3
+.else
+CONFIGURE_ARGS+= --without-gtkhtml
+.endif
+
+.if ${HAVE_GNOME:Mlibrsvg2}!=""
+USE_GNOME+= librsvg2
+.else
+CONFIGURE_ARGS+= --without-librsvg
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "logjam has the following tunable option(s):"
+ @${ECHO_MSG} " WITHOUT_GTKSPELL Disable spell checking"
+ @${ECHO_MSG} " WITH_XMMS Enable XMMS music detection"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/logjam/distinfo b/deskutils/logjam/distinfo
index ebee8897e68d..fc31844b9089 100644
--- a/deskutils/logjam/distinfo
+++ b/deskutils/logjam/distinfo
@@ -1,2 +1,2 @@
-MD5 (logjam-3.0.4.tar.gz) = 0259029e23ca6a280c6cb6ff83603ac9
-SIZE (logjam-3.0.4.tar.gz) = 142048
+MD5 (logjam-4.4.0.tar.bz2) = 7ff366dee32d354338132bfd5c5adb46
+SIZE (logjam-4.4.0.tar.bz2) = 604310
diff --git a/deskutils/logjam2/files/patch-src::cmdline.c b/deskutils/logjam/files/patch-src::cmdline.c
index 3b5d9c51ecd5..3b5d9c51ecd5 100644
--- a/deskutils/logjam2/files/patch-src::cmdline.c
+++ b/deskutils/logjam/files/patch-src::cmdline.c
diff --git a/deskutils/logjam2/files/patch-src::get_cmd_out.c b/deskutils/logjam/files/patch-src::get_cmd_out.c
index 91f21b18491e..91f21b18491e 100644
--- a/deskutils/logjam2/files/patch-src::get_cmd_out.c
+++ b/deskutils/logjam/files/patch-src::get_cmd_out.c
diff --git a/deskutils/logjam/pkg-descr b/deskutils/logjam/pkg-descr
index 1de2a476ab49..24d15377b9c4 100644
--- a/deskutils/logjam/pkg-descr
+++ b/deskutils/logjam/pkg-descr
@@ -1,6 +1,9 @@
-"LiveJournal.com... because you like to think other people care."
-LogJam is a client for LiveJournal. It sits unobtrusively in the
-corner of your screen, waiting for you to have something worthwhile to
-tell the world.
+"LiveJournal.com... because you like to think other people care." LogJam is
+a GTK2 client for the LiveJournal API. It sits unobtrusively in the corner
+of your screen, waiting for you to have something worthwhile to tell the
+world. It can read your current music from XMMS, spellcheck with gtkspell,
+and offers preview capabilities using gtkhtml3. It will interface with any
+site running LiveJournal, not just www.livejournal.com, and can create
+offline copies of your journal.
WWW: http://logjam.danga.com/
diff --git a/deskutils/logjam/pkg-plist b/deskutils/logjam/pkg-plist
index 47d68912d639..b14fe3b1be01 100644
--- a/deskutils/logjam/pkg-plist
+++ b/deskutils/logjam/pkg-plist
@@ -1,3 +1,12 @@
bin/logjam
-share/pixmaps/goat.png
-share/pixmaps/goat.xpm
+%%WITH_XMMS%%bin/logjam-xmms-client
+share/gnome/applications/logjam.desktop
+share/gnome/pixmaps/logjam_goat.png
+share/gnome/pixmaps/logjam_pencil.png
+share/locale/de/LC_MESSAGES/logjam.mo
+share/locale/en_GB/LC_MESSAGES/logjam.mo
+share/locale/en_US.UTF-8/LC_MESSAGES/logjam.mo
+share/locale/es/LC_MESSAGES/logjam.mo
+share/locale/he/LC_MESSAGES/logjam.mo
+share/locale/ru_RU/LC_MESSAGES/logjam.mo
+share/locale/uk_UA/LC_MESSAGES/logjam.mo
diff --git a/deskutils/logjam2/Makefile b/deskutils/logjam2/Makefile
deleted file mode 100644
index 93e8ad8fe96f..000000000000
--- a/deskutils/logjam2/Makefile
+++ /dev/null
@@ -1,69 +0,0 @@
-# New ports collection makefile for: logjam2
-# Date created: 30 Oct 2002
-# Whom: michael johnson <ahze@rgv.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= logjam2
-PORTVERSION= 4.4.0
-CATEGORIES= deskutils
-MASTER_SITES= http://logjam.danga.com/download/
-DISTNAME= logjam-${PORTVERSION}
-
-MAINTAINER= mike.patterson@unb.ca
-COMMENT= A GTK2 interface to livejournals, ie www.livejournal.com
-
-LIB_DEPENDS= curl.2:${PORTSDIR}/ftp/curl
-
-MAN1= logjam.1
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-USE_GNOME= gnomehack \
- gnomeprefix \
- gtk20 \
- libxml2 \
- intlhack
-CONFIGURE_ARGS= --program-transform-name="s/$$//"
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-.if defined(WITH_GTKSPELL)
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
-.else
-CONFIGURE_ARGS+= --without-gtkspell
-.endif
-
-.if defined(WITH_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
-PLIST_SUB+= WITH_XMMS=""
-.else
-PLIST_SUB+= WITH_XMMS="@comment "
-CONFIGURE_ARGS+= --without-xmms
-.endif
-
-.if defined(WITH_GTKHTML)
-USE_GNOME+= gtkhtml3
-.else
-CONFIGURE_ARGS+= --without-gtkhtml
-.endif
-
-.if defined(WITH_RSVG)
-USE_GNOME+= librsvg2
-.else
-CONFIGURE_ARGS+= --without-librsvg
-.endif
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "logjam has the following tunable option(s):"
- @${ECHO_MSG} " WITH_GTKSPELL Enable spell checking"
- @${ECHO_MSG} " WITH_XMMS Enable XMMS music detection"
- @${ECHO_MSG} " WITH_GTKHTML Enable GTK HTML3 preview"
- @${ECHO_MSG} " WITH_RSVG Enable librsvg"
- @${ECHO_MSG} ""
-
-.include <bsd.port.mk>
diff --git a/deskutils/logjam2/distinfo b/deskutils/logjam2/distinfo
deleted file mode 100644
index fc31844b9089..000000000000
--- a/deskutils/logjam2/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (logjam-4.4.0.tar.bz2) = 7ff366dee32d354338132bfd5c5adb46
-SIZE (logjam-4.4.0.tar.bz2) = 604310
diff --git a/deskutils/logjam2/pkg-descr b/deskutils/logjam2/pkg-descr
deleted file mode 100644
index 6120de62ab61..000000000000
--- a/deskutils/logjam2/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-"LiveJournal.com... because you like to think other people care." LogJam is
-a GTK2 client for the LiveJournal API. It sits unobtrusively in the corner
-of your screen, waiting for you to have something worthwhile to tell the
-world. It can read your current music from XMMS, spellcheck with gtkspell,
-and offers preview capabilities using gtkhtml3. It will interface with any
-site running LiveJournal, not just www.livejournal.com, and can create
-offline copies of your journal.
-
-(If you want a GTK version, see deskutils/logjam, but that
-version receives no bugfixes.)
-
-WWW: http://logjam.danga.com/
diff --git a/deskutils/logjam2/pkg-plist b/deskutils/logjam2/pkg-plist
deleted file mode 100644
index b14fe3b1be01..000000000000
--- a/deskutils/logjam2/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/logjam
-%%WITH_XMMS%%bin/logjam-xmms-client
-share/gnome/applications/logjam.desktop
-share/gnome/pixmaps/logjam_goat.png
-share/gnome/pixmaps/logjam_pencil.png
-share/locale/de/LC_MESSAGES/logjam.mo
-share/locale/en_GB/LC_MESSAGES/logjam.mo
-share/locale/en_US.UTF-8/LC_MESSAGES/logjam.mo
-share/locale/es/LC_MESSAGES/logjam.mo
-share/locale/he/LC_MESSAGES/logjam.mo
-share/locale/ru_RU/LC_MESSAGES/logjam.mo
-share/locale/uk_UA/LC_MESSAGES/logjam.mo