aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-10 11:01:51 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-10 11:01:51 +0000
commit3e22071ac6e9f5df5a339d255d909122c0a01e46 (patch)
tree4353b50e270e185697c65ccde19126e598e22d2c /deskutils
parent087588272ae644c4ac366b2943ff1e6fecb7af6b (diff)
downloadports-3e22071ac6e9f5df5a339d255d909122c0a01e46.tar.gz
ports-3e22071ac6e9f5df5a339d255d909122c0a01e46.zip
Add deskutils/p5-Data-ICal 0.05, a Perl module to generate iCalendar
(RFC 2445) calendar files. Requested by: edwin
Notes
Notes: svn path=/head/; revision=147825
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/p5-Data-ICal/Makefile49
-rw-r--r--deskutils/p5-Data-ICal/distinfo3
-rw-r--r--deskutils/p5-Data-ICal/pkg-descr5
-rw-r--r--deskutils/p5-Data-ICal/pkg-plist22
5 files changed, 80 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index d70abd4d7d35..626cc0a5bd38 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -116,6 +116,7 @@
SUBDIR += nautilus-sendto
SUBDIR += notification-daemon
SUBDIR += offix-trash
+ SUBDIR += p5-Data-ICal
SUBDIR += pal
SUBDIR += phpgroupware
SUBDIR += phpicalendar
diff --git a/deskutils/p5-Data-ICal/Makefile b/deskutils/p5-Data-ICal/Makefile
new file mode 100644
index 000000000000..3bcc7c0319a2
--- /dev/null
+++ b/deskutils/p5-Data-ICal/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: deskutils/p5-Data-ICal
+# Date created: 10 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-ICal
+PORTVERSION= 0.05
+CATEGORIES= deskutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Data::ICal - Generates iCalendar (RFC 2445) calendar files
+TAGS= calendar ical devel
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/LongString.pm:${PORTSDIR}/devel/p5-Test-LongString \
+ ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ ${SITE_PERL}/Text/vFile/asData.pm:${PORTSDIR}/devel/p5-Text-vFile-asData
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::ICal.3 \
+ Data::ICal::Entry.3 \
+ Data::ICal::Entry::Alarm::Audio.3 \
+ Data::ICal::Entry::Alarm::Display.3 \
+ Data::ICal::Entry::Alarm::Email.3 \
+ Data::ICal::Entry::Alarm::Procedure.3 \
+ Data::ICal::Entry::Event.3 \
+ Data::ICal::Entry::FreeBusy.3 \
+ Data::ICal::Entry::Journal.3 \
+ Data::ICal::Entry::TimeZone.3 \
+ Data::ICal::Entry::TimeZone::Daylight.3 \
+ Data::ICal::Entry::TimeZone::Standard.3 \
+ Data::ICal::Entry::Todo.3 \
+ Data::ICal::Property.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/p5-Data-ICal/distinfo b/deskutils/p5-Data-ICal/distinfo
new file mode 100644
index 000000000000..2eac9ec59165
--- /dev/null
+++ b/deskutils/p5-Data-ICal/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-ICal-0.05.tar.gz) = 6d7d1c37e13786a56ef849658cbd0b9e
+SHA256 (Data-ICal-0.05.tar.gz) = a18989e855483ede04c94ab7939b2233874d2239685cf9491aeadcfc89b388f8
+SIZE (Data-ICal-0.05.tar.gz) = 89689
diff --git a/deskutils/p5-Data-ICal/pkg-descr b/deskutils/p5-Data-ICal/pkg-descr
new file mode 100644
index 000000000000..1998293139b2
--- /dev/null
+++ b/deskutils/p5-Data-ICal/pkg-descr
@@ -0,0 +1,5 @@
+A Data::ICal object represents a VCALENDAR object as defined in the
+iCalendar protocol (RFC 2445, MIME type "text/calendar"), as implemented
+in many popular calendaring programs such as Apple's iCal.
+
+WWW: http://search.cpan.org/dist/Data-ICal/
diff --git a/deskutils/p5-Data-ICal/pkg-plist b/deskutils/p5-Data-ICal/pkg-plist
new file mode 100644
index 000000000000..3057b9b77f48
--- /dev/null
+++ b/deskutils/p5-Data-ICal/pkg-plist
@@ -0,0 +1,22 @@
+%%SITE_PERL%%/Data/ICal.pm
+%%SITE_PERL%%/Data/ICal/Entry.pm
+%%SITE_PERL%%/Data/ICal/Entry/Alarm/Audio.pm
+%%SITE_PERL%%/Data/ICal/Entry/Alarm/Display.pm
+%%SITE_PERL%%/Data/ICal/Entry/Alarm/Email.pm
+%%SITE_PERL%%/Data/ICal/Entry/Alarm/Procedure.pm
+%%SITE_PERL%%/Data/ICal/Entry/Event.pm
+%%SITE_PERL%%/Data/ICal/Entry/FreeBusy.pm
+%%SITE_PERL%%/Data/ICal/Entry/Journal.pm
+%%SITE_PERL%%/Data/ICal/Entry/TimeZone.pm
+%%SITE_PERL%%/Data/ICal/Entry/TimeZone/Daylight.pm
+%%SITE_PERL%%/Data/ICal/Entry/TimeZone/Standard.pm
+%%SITE_PERL%%/Data/ICal/Entry/Todo.pm
+%%SITE_PERL%%/Data/ICal/Property.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/ICal/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Data/ICal/Entry/TimeZone 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data/ICal/Entry/Alarm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/ICal 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Data/ICal/Entry
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data/ICal 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true