aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-17 18:02:39 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-17 18:02:39 +0000
commit7ff50fde20d54fa2ef663024bc7cd7b93cd49d2b (patch)
treed4257badbf8a29c4bce389ca75268fd7464299e8 /deskutils
parent9b1be7c2c98b1d3fce3ac5650d8719cd162264ff (diff)
downloadports-7ff50fde20d54fa2ef663024bc7cd7b93cd49d2b.tar.gz
ports-7ff50fde20d54fa2ef663024bc7cd7b93cd49d2b.zip
o Update to 7.4.8
o Do not overwrite existing files during installation o Respect WWWDOCROOT PR: 89190 Submitted by: infofarmer@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=148639
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/plans/Makefile22
-rw-r--r--deskutils/plans/distinfo6
-rw-r--r--deskutils/plans/pkg-plist3
3 files changed, 16 insertions, 15 deletions
diff --git a/deskutils/plans/Makefile b/deskutils/plans/Makefile
index 7231ea3c3e5d..ab44848fd8b7 100644
--- a/deskutils/plans/Makefile
+++ b/deskutils/plans/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= plans
-PORTVERSION= 7.4.7
-PORTREVISION= 1
+PORTVERSION= 7.4.8
CATEGORIES= deskutils www
MASTER_SITES= http://www.planscalendar.com/release/:plans \
http://www.freebsd.org/gifs/:logo
@@ -25,10 +24,13 @@ USE_PERL5_RUN= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
-DIR= www/data/plans
-PLIST_SUB+= DIR=${DIR}
+WWWDOCROOT?= www/data
+PLANSSUBDIR?= plans
+PLANSDIR?= ${WWWDOCROOT}/${PLANSSUBDIR}
+PLIST_SUB+= DIR=${PLANSDIR}
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+DIR= ${PREFIX}/${PLANSDIR}
post-extract:
${CP} ${DISTDIR}/powerani.gif ${WRKSRC}/theme/graphics/freebsd.gif
@@ -37,12 +39,12 @@ post-patch:
@${RM} -f ${WRKSRC}/theme/plans.template.orig
do-install:
- @${MKDIR} ${PREFIX}/${DIR}
- @${CP} -R ${WRKSRC}/* ${PREFIX}/${DIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${DIR}
- @${FIND} ${PREFIX}/${DIR} -type f -exec ${CHMOD} 644 {} \;
- @${FIND} ${PREFIX}/${DIR} -name '*.cgi' -exec ${CHMOD} 755 {} \;
- @${FIND} ${PREFIX}/${DIR} -name '*.xml' -exec ${CHMOD} 664 {} \;
+ @${INSTALL} -d ${DIR}
+ @${CP} -nR ${WRKSRC}/ ${DIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${DIR}
+ @${FIND} ${DIR} -type f -exec ${CHMOD} 644 {} \;
+ @${FIND} ${DIR} -name '*.cgi' -exec ${CHMOD} 755 {} \;
+ @${FIND} ${DIR} -name '*.xml' -exec ${CHMOD} 664 {} \;
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/deskutils/plans/distinfo b/deskutils/plans/distinfo
index 041a88004996..bc28b4d8c2d1 100644
--- a/deskutils/plans/distinfo
+++ b/deskutils/plans/distinfo
@@ -1,6 +1,6 @@
-MD5 (plans_7.4.7.zip) = 75e77cf0b50e378a9cadb0c39f703947
-SHA256 (plans_7.4.7.zip) = 38bec8aa2c0d2a174717b423e94b7f7364b002316d6b310cefb526ff24530dbf
-SIZE (plans_7.4.7.zip) = 585978
+MD5 (plans_7.4.8.zip) = 46a1d95b6264247088f56b0faa86b020
+SHA256 (plans_7.4.8.zip) = 6be1f2176a93cd76a7c75b4bf0a83bcd6ea1dac1c2b2512c722da8ac8feee94f
+SIZE (plans_7.4.8.zip) = 587278
MD5 (powerani.gif) = b0f85a6c41817a2dcad0ffe6f0729fa8
SHA256 (powerani.gif) = d01c1c8299aa6c0eda0cd7c202bdf5a4ad49400377596fc2e114db6591c66d97
SIZE (powerani.gif) = 7203
diff --git a/deskutils/plans/pkg-plist b/deskutils/plans/pkg-plist
index e489cb6ff84d..261522d42139 100644
--- a/deskutils/plans/pkg-plist
+++ b/deskutils/plans/pkg-plist
@@ -323,10 +323,9 @@
%%DIR%%/theme/upcoming_events.css
%%DIR%%/theme/upcoming_events.js
%%DIR%%/us_english.pl
-
@dirrm %%DIR%%/theme/icons
@dirrm %%DIR%%/theme/graphics
-@dirrm %%DIR%%/theme
+@unexec rmdir %D/%%DIR%%/theme 2>/dev/null || true
@unexec rmdir %D/%%DIR%%/sessions 2>/dev/null || true
@unexec rmdir %D/%%DIR%%/data 2>/dev/null || true
@unexec rmdir %D/%%DIR%% 2>/dev/null || echo "Note: %D/%%DIR%% not empty -- not deleted!"