aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>1999-08-16 08:11:54 +0000
committerJim Mock <jim@FreeBSD.org>1999-08-16 08:11:54 +0000
commit718f64b85e2f07e4d71f5e04a941244c4363cc09 (patch)
tree2317398c77457ae3e5b61a0a094779f8094385cc /deskutils
parent6911f6acbdefa9067f99b906d0d792724618496a (diff)
downloadports-718f64b85e2f07e4d71f5e04a941244c4363cc09.tar.gz
ports-718f64b85e2f07e4d71f5e04a941244c4363cc09.zip
Import of gaddr.
gaddr is a simple address book written using the GTK+ widget set that basically acts like a pile of alphabetized 3x5 index cards. PR: 13018
Notes
Notes: svn path=/head/; revision=20744
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gaddr/Makefile31
-rw-r--r--deskutils/gaddr/distinfo1
-rw-r--r--deskutils/gaddr/files/patch-aa11
-rw-r--r--deskutils/gaddr/files/patch-ab17
-rw-r--r--deskutils/gaddr/pkg-comment1
-rw-r--r--deskutils/gaddr/pkg-descr8
-rw-r--r--deskutils/gaddr/pkg-plist1
7 files changed, 70 insertions, 0 deletions
diff --git a/deskutils/gaddr/Makefile b/deskutils/gaddr/Makefile
new file mode 100644
index 000000000000..c877cb1e824e
--- /dev/null
+++ b/deskutils/gaddr/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gaddr
+# Version required: 1.1.2
+# Date created: 8 August 1999
+# Whom: Jim Mock <jim@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= gaddr-1.1.2
+CATEGORIES= deskutils
+MASTER_SITES= http://www.cse.unl.edu/~cluening/gaddr/
+
+MAINTAINER= jim@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+.if defined(USE_GNOME)
+CONFIGURE_ARGS+= --enable-gnome
+.endif
+
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+
+post-install:
+ @strip ${PREFIX}/bin/gaddr
+
+.include <bsd.port.mk>
diff --git a/deskutils/gaddr/distinfo b/deskutils/gaddr/distinfo
new file mode 100644
index 000000000000..f47e3ce25111
--- /dev/null
+++ b/deskutils/gaddr/distinfo
@@ -0,0 +1 @@
+MD5 (gaddr-1.1.2.tar.gz) = 55f178fd9a296815984b2d57cb678d0f
diff --git a/deskutils/gaddr/files/patch-aa b/deskutils/gaddr/files/patch-aa
new file mode 100644
index 000000000000..49bb7c32d41e
--- /dev/null
+++ b/deskutils/gaddr/files/patch-aa
@@ -0,0 +1,11 @@
+--- db.c.orig Sun Aug 8 10:58:13 1999
++++ db.c Sun Aug 8 10:58:27 1999
+@@ -19,7 +19,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include "db.h"
+
+ /* Definition of a record in linked list
diff --git a/deskutils/gaddr/files/patch-ab b/deskutils/gaddr/files/patch-ab
new file mode 100644
index 000000000000..8b93f7a6682a
--- /dev/null
+++ b/deskutils/gaddr/files/patch-ab
@@ -0,0 +1,17 @@
+--- Makefile.in.orig Sun Aug 8 11:12:01 1999
++++ Makefile.in Sun Aug 8 11:14:15 1999
+@@ -1,7 +1,7 @@
+ # Makefile for gaddr
+ # Cory Lueninghoener 1999 (cluenin1@bigred.unl.edu)
+
+-CC=gcc
++CC?=gcc
+ #CC=cc
+ #DEBUG=--debug
+
+@@ -28,4 +28,4 @@
+ rm -f gaddr
+
+ install: gaddr
+- cp gaddr /usr/X11R6/bin/gaddr
++ @/usr/bin/install -c -o 0 -g 0 -s -m 755 gaddr ${PREFIX}/bin
diff --git a/deskutils/gaddr/pkg-comment b/deskutils/gaddr/pkg-comment
new file mode 100644
index 000000000000..0e86898ed0be
--- /dev/null
+++ b/deskutils/gaddr/pkg-comment
@@ -0,0 +1 @@
+A GTK (and optionally, GNOME) address book
diff --git a/deskutils/gaddr/pkg-descr b/deskutils/gaddr/pkg-descr
new file mode 100644
index 000000000000..7bf6aeaed8a8
--- /dev/null
+++ b/deskutils/gaddr/pkg-descr
@@ -0,0 +1,8 @@
+gaddr is a nice simple little address book written using the GTK+
+widget set. It holds addresses and any other information you want to
+know about a person. It basically acts like a pile of alphabetized
+3x5 cards on which you can write whatever your little heart desires.
+
+WWW: http://www.cse.unl.edu/~cluening/gaddr/
+
+- Jim <jim@FreeBSD.org>
diff --git a/deskutils/gaddr/pkg-plist b/deskutils/gaddr/pkg-plist
new file mode 100644
index 000000000000..58545dd8835c
--- /dev/null
+++ b/deskutils/gaddr/pkg-plist
@@ -0,0 +1 @@
+bin/gaddr