aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-06 14:17:12 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-06 14:17:12 +0000
commit1683d870a07f802e3182d212d7045ffcc7828b76 (patch)
treea303cd6550c276502cdfe446e7535fbf3adf7da2 /devel/Makefile
parenta63cf30be2570c1bab1bf29570cc74a4ca25a1e5 (diff)
downloadports-1683d870a07f802e3182d212d7045ffcc7828b76.tar.gz
ports-1683d870a07f802e3182d212d7045ffcc7828b76.zip
This package implements frequent string operations: searching, replacing,
splitting, matching. It is independent from the Str library, and can replace Str in many cases. Unlike Str, xstr is thread-safe. xstr does not implement regular expressions in general, but an important subset. Some operations of xstr are performed as quickly as by Str; if the string to be processed is small, xstr is often faster than Str; if the string is big, xstr is upto half as fast than Str. Author: Gerd Stolpmann <gerd@gerd-stolpmann.de> WWW: http://www.ocaml-programming.de/packages/ PR: ports/101032 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Notes
Notes: svn path=/head/; revision=169825
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8be20cddffca..52849e829cdd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -708,6 +708,7 @@
SUBDIR += ocaml-sem
SUBDIR += ocaml-sexplib
SUBDIR += ocaml-ulex
+ SUBDIR += ocaml-xstr
SUBDIR += ocaml-xstrp4
SUBDIR += ocamlweb
SUBDIR += ode