aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-03-19 22:43:05 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-03-19 22:43:05 +0000
commit6bb0d30e1b65000c99b44bea21b898a2c5f2bf85 (patch)
tree4844c2f8d71caea04c7a02d1cdc06bc551ebc222 /devel/Makefile
parent0a21728cdf0ecc6c31cddf6b6db80bd0779c584d (diff)
downloadports-6bb0d30e1b65000c99b44bea21b898a2c5f2bf85.tar.gz
ports-6bb0d30e1b65000c99b44bea21b898a2c5f2bf85.zip
Add gpsim.
gpsim is a full-featured software simulator for Microchip PIC microcontrollers distributed under the GNU General Public License. gpsim has been designed to be as accurate as possible. Accuracy includes the entire PIC - from the core to the I/O pins and including ALL of the internal peripherals. Thus it's possible to create stimuli and tie them to the I/O pins and test the PIC the same PIC the same way you would in the real world. gpsim has been designed to be as fast as possible. Real time simulation speeds of 20Mhz pics are possible. A 'goto $' program runs at the same speed as a 25Mhz pic when simulated on my 400Mhz PII Linux Box. Of course, as you add stimuli and begin interacting with peripherals, the performance drops. But it's still fast! gpsim has been designed to be as useful as possible (at least that's the intent - honest). The standard simulation paradigm including breakpoints, single stepping, disassembling, memory inspect & change, and so on has been implemented. In addition, gpsim supports many debugging features that are only available with in-circuit emulators. For example, a continuous trace buffer tracks every action of the simulator (whether you want it or not). Also, it's possible to set read and write break points on values (e.g. break if a specific value is read from or written to a register). WWW: http://www.dattalo.com/gnupic/gpsim.html PR: ports/94436 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Notes
Notes: svn path=/head/; revision=157692
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 84a5aabfb20d..3ce2d3b39104 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -349,6 +349,7 @@
SUBDIR += gorm
SUBDIR += gpc
SUBDIR += gperf
+ SUBDIR += gpsim
SUBDIR += gputils
SUBDIR += gsoap
SUBDIR += gstreamer-plugins-gconf