aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-19 14:31:35 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-19 14:31:35 +0000
commitb933de4aaa16a51020f61f87f64063a97fc5b6d1 (patch)
tree5701048fb59c8b74acff6db606164733434824b7 /devel/Makefile
parent578714486767646ae5fbc76cac14d3d8e4a080a5 (diff)
downloadports-b933de4aaa16a51020f61f87f64063a97fc5b6d1.tar.gz
ports-b933de4aaa16a51020f61f87f64063a97fc5b6d1.zip
This package provides standardized, efficient versions of utility classes
commonly encountered in concurrent Java programming. This code consists of implementations of ideas that have been around for ages, and is merely intended to save you the trouble of coding them. The package mainly consists of implementations of a few interfaces: * Sync -- locks, conditions * Channel -- queues, buffers * Barrier -- multi-party synchronization * SynchronizedVariable -- atomic ints, refs etc * java.util.Collection -- collections * Executor -- replacements for direct use of Thread Plus some utilities and frameworks that build upon these. This package was the precursor to java.util.concurrent. WWW: http://gee.cs.oswego.edu/dl/classes/EDU/oswego/cs/dl/util/concurrent/intro.html
Notes
Notes: svn path=/head/; revision=121966
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7f6027c6931a..782ec3128aec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -358,6 +358,7 @@
SUBDIR += ixlib
SUBDIR += jakelib2
SUBDIR += jam
+ SUBDIR += java-util-concurrent
SUBDIR += jclassinfo
SUBDIR += jrtplib
SUBDIR += jude_take