aboutsummaryrefslogtreecommitdiff
path: root/devel/ORBit/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-08-19 06:15:08 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-08-19 06:15:08 +0000
commit1cda1ec091f98531cc5b0eee5da2a52a7494318a (patch)
tree44d9fe6828458011b7ddf95ea609389a0bacb756 /devel/ORBit/Makefile
parent9d9878ff7fc6081156046e578a3391b43509a25c (diff)
downloadports-1cda1ec091f98531cc5b0eee5da2a52a7494318a.tar.gz
ports-1cda1ec091f98531cc5b0eee5da2a52a7494318a.zip
ORBit is a high-performance CORBA ORB with support for the C language.
It is used by the GNOME Project. PR: ports/7654 Submitted by: Chia-liang Kao <clkao@cirx.org>
Notes
Notes: svn path=/head/; revision=12636
Diffstat (limited to 'devel/ORBit/Makefile')
-rw-r--r--devel/ORBit/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/ORBit/Makefile b/devel/ORBit/Makefile
new file mode 100644
index 000000000000..fd59f2f29157
--- /dev/null
+++ b/devel/ORBit/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: orbit
+# Version required: 0.2.1
+# Date Created: 16 Aug 1998
+# Whom: Chia-liang Kao <clkao@CirX.ORG>
+#
+# $Id$
+#
+
+DISTNAME= ORBit-0.2.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.gnome.org/pub/ORBit/
+
+MAINTAINER= clkao@CirX.ORG
+
+LIB_DEPENDS= glib11\\.0\\.:${PORTSDIR}/devel/glib
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ENV= INSTALL='$${INSTALL} -c'
+CONFIGURE_ARGS= --disable-indent
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>