aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-gsubfn/Makefile
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2012-08-22 18:05:29 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2012-08-22 18:05:29 +0000
commit9be126f0a7bd3ba64f2cb80181ae97316ad7c77f (patch)
tree6b013cac962062f8dcec20448456f1bcbf1a30d5 /devel/R-cran-gsubfn/Makefile
parentd3988d103e4b6f4b2416a47c3212092a1c380439 (diff)
downloadports-9be126f0a7bd3ba64f2cb80181ae97316ad7c77f.tar.gz
ports-9be126f0a7bd3ba64f2cb80181ae97316ad7c77f.zip
gsubfn is an R package used for string matching, substitution and parsing. A
seemingly small generalization of gsub, namely allow the replacement string to be a replacement function, list, formula or proto object, can result in increased power and applicability. The resulting function, gsubfn is the namesake of this package. WWW: https://code.google.com/p/gsubfn/
Notes
Notes: svn path=/head/; revision=302952
Diffstat (limited to 'devel/R-cran-gsubfn/Makefile')
-rw-r--r--devel/R-cran-gsubfn/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/R-cran-gsubfn/Makefile b/devel/R-cran-gsubfn/Makefile
new file mode 100644
index 000000000000..3d82cc7cf7ed
--- /dev/null
+++ b/devel/R-cran-gsubfn/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: R-cran-gsubfn
+# Date created: 2012-08-21
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsubfn
+DISTVERSION= 0.6-4
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= R package used for string matching, substitution and parsing
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= R-cran-proto>=0.3.9.2_6:${PORTSDIR}/devel/R-cran-proto
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>