aboutsummaryrefslogtreecommitdiff
path: root/devel/ZendOptimizer/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-09 21:41:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-09 21:41:28 +0000
commit1227b059ffeeb2fb98c1dfe0382793d6a73aef56 (patch)
treed8300d45aa226964d71b5c6fdfaabc7f0ddc715c /devel/ZendOptimizer/Makefile
parentd09618309ab0e0643a1309223303df96e7f91139 (diff)
downloadports-1227b059ffeeb2fb98c1dfe0382793d6a73aef56.tar.gz
ports-1227b059ffeeb2fb98c1dfe0382793d6a73aef56.zip
[New Port] devel/ZendOptimizer 2.1.0a
Port of the Zend Optimizer for PHP 4.3 and FreeBSD 4. The Zend Optimizer is a free application that runs the files encoded by the Zend Encoder and Zend SafeGuard Suite, while enhancing the running speed of PHP applications. Benefits: - Enables users to run files encoded by the Zend Encoder - Increases runtime performance up to 40%. WWW: http://www.zend.com/store/products/zend-optimizer.php Actually what is installed is 2.1.0b since 2.1.0a doesn't exist anymore. PR: ports/51334 Submitted by: Alex Dupre <sysadmin@alexdupre.com>
Notes
Notes: svn path=/head/; revision=97807
Diffstat (limited to 'devel/ZendOptimizer/Makefile')
-rw-r--r--devel/ZendOptimizer/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/devel/ZendOptimizer/Makefile b/devel/ZendOptimizer/Makefile
new file mode 100644
index 000000000000..cdcaab2838e4
--- /dev/null
+++ b/devel/ZendOptimizer/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: ZendOptimizer
+# Date created: Thu Apr 24 00:23:22 CET 2003
+# Whom: Alex Dupre <sysadmin@alexdupre.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZendOptimizer
+PORTVERSION= 2.1.0b
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}-${PORTVERSION}-FreeBSD4.0-i386
+
+MAINTAINER= sysadmin@alexdupre.com
+COMMENT= An optimizer for PHP code
+
+RUN_DEPENDS= ${LOCALBASE}/bin/php:${PORTSDIR}/www/mod_php4
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+
+RESTRICTED= "Redistribution of pre-compiled binaries is not permitted"
+NO_CDROM= "Redistribution of pre-compiled binaries is not permitted"
+
+EXT_DIR= 20020429
+PLIST_SUB= EXT_DIR=${EXT_DIR}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.include <bsd.port.pre.mk>
+
+# Check for FreeBSD version
+.if ${OSVERSION} < 400000 || ${OSVERSION} > 499999
+BROKEN= "This port is for FreeBSD 4 only."
+.endif
+
+# Check for ZendOptimizer sources
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= :\n\
+Because of licensing restrictions, you must fetch the source distribution\n\
+manually.\n\
+Please access http://www.zend.com/store/getfreefile.php?pid=13&zbid=547\n\
+with a web browser, read the license and click the \"I ACCEPT\" button.\n\
+Download the source file, ${DISTFILES},\n\
+and place it in ${DISTDIR}.\n
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/php/${EXT_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/4_3_x_comp/ZendOptimizer.so \
+ ${PREFIX}/lib/php/${EXT_DIR}/ZendOptimizer.so
+ ${INSTALL_DATA} ${WRKSRC}/data/4_3_x_comp/TS/ZendOptimizer.so \
+ ${PREFIX}/lib/php/${EXT_DIR}/ZendOptimizer_TS.so
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/data/doc/* ${DOCSDIR}
+.endif
+
+post-install:
+ @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%EXT_DIR%%|${EXT_DIR}|g" \
+ ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>