aboutsummaryrefslogtreecommitdiff
path: root/devel/ace
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-10 17:41:53 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-10 17:41:53 +0000
commit09cb048e6e15c440c1d45cad84f3207db4d63326 (patch)
tree0c9624761f09be42d1fb031cb789ed83ddee8cfd /devel/ace
parent24bfb7cb2f41a837f49fac7c63f5fa057eb245d6 (diff)
downloadports-09cb048e6e15c440c1d45cad84f3207db4d63326.tar.gz
ports-09cb048e6e15c440c1d45cad84f3207db4d63326.zip
- Fix build on 7.x
Reported by: pointyhat via erwin
Notes
Notes: svn path=/head/; revision=232022
Diffstat (limited to 'devel/ace')
-rw-r--r--devel/ace/Makefile11
-rw-r--r--devel/ace/files/extra-patch-ace-OS_NS_Thread.h11
2 files changed, 19 insertions, 3 deletions
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index ac2daf834c34..cd1333313381 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -30,13 +30,18 @@ WRKSRC= ${WRKDIR}/ACE_wrappers
BUILD_WRKSRC= ${WRKSRC}/objdir
INSTALL_WRKSRC= ${BUILD_WRKSRC}
NOT_FOR_ARCHS= sparc64
+MAKE_JOBS_SAFE= yes
MAN1= ace-gperf.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700015 || (${OSVERSION} < 700000 && ${OSVERSION} >= 601103)
-EXTRA_PATCHES= ${FILESDIR}/extra-ace-OS_NS_netdb.inl
+.if (${OSVERSION} >= 601103 && ${OSVERSION} < 700000) || ${OSVERSION} >= 700015
+EXTRA_PATCHES+= ${FILESDIR}/extra-ace-OS_NS_netdb.inl
+.endif
+
+.if ${OSVERSION} >= 700110 && ${OSVERSION} < 800000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ace-OS_NS_Thread.h
.endif
post-extract:
@@ -45,7 +50,7 @@ post-extract:
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|@libdir@/pkgconfig|@prefix@/libdata/pkgconfig|g'
-.if ${OSVERSION} >= 800024
+.if (${OSVERSION} >= 700110 && ${OSVERSION} < 800000) || ${OSVERSION} >= 800024
@${REINPLACE_CMD} -e 's|cpu_set_t|cpuset_t|g' ${WRKSRC}/ace/OS_NS_Thread.cpp \
${WRKSRC}/ace/OS_NS_Thread.h
.endif
diff --git a/devel/ace/files/extra-patch-ace-OS_NS_Thread.h b/devel/ace/files/extra-patch-ace-OS_NS_Thread.h
new file mode 100644
index 000000000000..df23d8732792
--- /dev/null
+++ b/devel/ace/files/extra-patch-ace-OS_NS_Thread.h
@@ -0,0 +1,11 @@
+--- ace/OS_NS_Thread.h.orig 2006-05-30 17:15:25.000000000 +0400
++++ ace/OS_NS_Thread.h 2009-04-10 17:59:13.000000000 +0400
+@@ -38,6 +38,8 @@
+ # include "ace/ACE_export.h"
+ # include "ace/Object_Manager_Base.h"
+
++# include <sys/cpuset.h>
++
+ # if defined (ACE_EXPORT_MACRO)
+ # undef ACE_EXPORT_MACRO
+ # endif