aboutsummaryrefslogtreecommitdiff
path: root/devel/adabooch
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 06:33:07 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-27 06:33:07 +0000
commitfe840965796f04e113c9beeceba034258223788c (patch)
tree515466383594528ca29c34fc0685d9e33636c129 /devel/adabooch
parente7ac705e54f5e4f3c7971aa5694f1471a4e0b2d2 (diff)
downloadports-fe840965796f04e113c9beeceba034258223788c.tar.gz
ports-fe840965796f04e113c9beeceba034258223788c.zip
New port: adabooch is a Booch implementation for Ada95
The Ada 95 version of the components will contain the same key abstractions as the C++ form (Structs, Tools and Support). However, the organization will be slightly different, particularly in the Support domain. This is because Ada 95 provides several special forms of memory management that are quite different from C++. The Structs category provides an array of structural abstractions (Bags, Collections, Deques, Graphs, Lists, Maps, Queues, Rings, Sets, Stacks, and Trees). The Tools category provides algorithmic abstractions (Searching, Sorting, etc.). The Support category contains all the "concrete" forms, plus structures to create the components. Some of the structures permit structural sharing (graphs, lists, and trees). Some structures may also be ordered (collections, dequeues, and queues). There are also multiple forms for some structures: single and double linked lists, directed and undirected graphs, and binary, multiway, and AVL trees. WWW: http://www.adapower.net/booch/ PR: ports/46448 Submitted by: David Holm <david@realityrift.com>
Notes
Notes: svn path=/head/; revision=89518
Diffstat (limited to 'devel/adabooch')
-rw-r--r--devel/adabooch/Makefile44
-rw-r--r--devel/adabooch/distinfo1
-rw-r--r--devel/adabooch/files/patch-demo-makefile11
-rw-r--r--devel/adabooch/files/patch-test-makefile11
-rw-r--r--devel/adabooch/pkg-descr21
-rw-r--r--devel/adabooch/pkg-plist235
6 files changed, 323 insertions, 0 deletions
diff --git a/devel/adabooch/Makefile b/devel/adabooch/Makefile
new file mode 100644
index 000000000000..cfd6f0ce3c4e
--- /dev/null
+++ b/devel/adabooch/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: adabooch
+# Date created: 21 December 2002
+# Whom: David Holm <david@realityrift.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adabooch
+PORTVERSION= 20020602
+CATEGORIES= devel
+MASTER_SITES= http://www.adapower.net/booch/download/
+DISTNAME= bc-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= david@realityrift.com
+COMMENT= Library which provide container classes as well as powertools for Ada
+
+NO_BUILD= yes
+
+do-install:
+ @${ECHO} Installing library files
+ @${MKDIR} ${PREFIX}/lib/adabooch
+ @for i in `cat pkg-plist|grep "lib/adabooch/"|sed "s/lib\/adabooch\///"`; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/lib/adabooch; \
+ done
+
+ @${MKDIR} ${PREFIX}/share/adabooch
+ @${ECHO} Installing demos and tests
+ @${MKDIR} ${PREFIX}/share/adabooch/demo
+ @for i in `cat pkg-plist|grep "share/adabooch/demo/"|sed "s/share\/adabooch\/demo\///"`; do \
+ ${INSTALL_DATA} ${WRKSRC}/demo/$${i} ${PREFIX}/share/adabooch/demo; \
+ done
+
+ @${MKDIR} ${PREFIX}/share/adabooch/test
+ @for i in `cat pkg-plist|grep "share/adabooch/test/"|sed "s/share\/adabooch\/test\///"`; do \
+ ${INSTALL_DATA} ${WRKSRC}/test/$${i} ${PREFIX}/share/adabooch/test; \
+ done
+
+post-install:
+ @${ECHO}
+ @${ECHO} "The booch library has been installed into ${PREFIX}/lib/adabooch"
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/devel/adabooch/distinfo b/devel/adabooch/distinfo
new file mode 100644
index 000000000000..569df4829439
--- /dev/null
+++ b/devel/adabooch/distinfo
@@ -0,0 +1 @@
+MD5 (bc-20020602.tgz) = 6457cf05462db6fe8d65774864012264
diff --git a/devel/adabooch/files/patch-demo-makefile b/devel/adabooch/files/patch-demo-makefile
new file mode 100644
index 000000000000..56646179aae5
--- /dev/null
+++ b/devel/adabooch/files/patch-demo-makefile
@@ -0,0 +1,11 @@
+--- demo/makefile.orig Sun Jun 2 16:49:53 2002
++++ demo/makefile Sat Dec 21 19:20:50 2002
+@@ -22,7 +22,7 @@
+ # Demos
+
+ GNATMAKE = gnatmake
+-GNATMAKE_FLAGS = -I.. -O2 -g -gnata -gnatf -gnatwu -gnatwl -gnaty
++GNATMAKE_FLAGS = -I/usr/local/lib/booch -O2 -g -gnata -gnatf -gnatwu -gnatwl -gnaty
+
+ all:: demos
+
diff --git a/devel/adabooch/files/patch-test-makefile b/devel/adabooch/files/patch-test-makefile
new file mode 100644
index 000000000000..41eaa114387c
--- /dev/null
+++ b/devel/adabooch/files/patch-test-makefile
@@ -0,0 +1,11 @@
+--- test/makefile.orig Sun Jun 2 16:49:53 2002
++++ test/makefile Sat Dec 21 19:20:33 2002
+@@ -28,7 +28,7 @@
+ ########
+ # Tests
+
+-GNATMAKE_FLAGS = -I.. -O2 -g -gnatafy -gnatwlu
++GNATMAKE_FLAGS = -I/usr/local/lib/booch -O2 -g -gnatafy -gnatwlu
+
+ test: testable
+ for t in $(TESTABLE); do \
diff --git a/devel/adabooch/pkg-descr b/devel/adabooch/pkg-descr
new file mode 100644
index 000000000000..ee1dcd34d0b2
--- /dev/null
+++ b/devel/adabooch/pkg-descr
@@ -0,0 +1,21 @@
+The Ada 95 version of the components will contain the same key abstractions
+as the C++ form (Structs, Tools and Support). However, the organization will
+be slightly different, particularly in the Support domain. This is because
+Ada 95 provides several special forms of memory management that are quite
+different from C++.
+
+The Structs category provides an array of structural abstractions (Bags,
+Collections, Deques, Graphs, Lists, Maps, Queues, Rings, Sets, Stacks, and
+Trees). The Tools category provides algorithmic abstractions (Searching,
+Sorting, etc.). The Support category contains all the "concrete" forms, plus
+structures to create the components.
+
+Some of the structures permit structural sharing (graphs, lists, and trees).
+Some structures may also be ordered (collections, dequeues, and queues). There
+are also multiple forms for some structures: single and double linked lists,
+directed and undirected graphs, and binary, multiway, and AVL trees.
+
+WWW: http://www.adapower.net/booch/
+
+- David Holm
+david@realityrift.com
diff --git a/devel/adabooch/pkg-plist b/devel/adabooch/pkg-plist
new file mode 100644
index 000000000000..255ce0c6da6d
--- /dev/null
+++ b/devel/adabooch/pkg-plist
@@ -0,0 +1,235 @@
+lib/adabooch/bc-containers-bags-bounded.adb
+lib/adabooch/bc-containers-bags-dynamic.adb
+lib/adabooch/bc-containers-bags-unbounded.adb
+lib/adabooch/bc-containers-bags.adb
+lib/adabooch/bc-containers-collections-bounded.adb
+lib/adabooch/bc-containers-collections-dynamic.adb
+lib/adabooch/bc-containers-collections-ordered-bounded.adb
+lib/adabooch/bc-containers-collections-ordered-dynamic.adb
+lib/adabooch/bc-containers-collections-ordered-unbounded.adb
+lib/adabooch/bc-containers-collections-unbounded.adb
+lib/adabooch/bc-containers-collections.adb
+lib/adabooch/bc-containers-deques-bounded.adb
+lib/adabooch/bc-containers-deques-dynamic.adb
+lib/adabooch/bc-containers-deques-unbounded.adb
+lib/adabooch/bc-containers-deques.adb
+lib/adabooch/bc-containers-guarded.adb
+lib/adabooch/bc-containers-lists-double.adb
+lib/adabooch/bc-containers-lists-single.adb
+lib/adabooch/bc-containers-maps-bounded.adb
+lib/adabooch/bc-containers-maps-dynamic.adb
+lib/adabooch/bc-containers-maps-hash_statistics.adb
+lib/adabooch/bc-containers-maps-synchronized.adb
+lib/adabooch/bc-containers-maps-unbounded.adb
+lib/adabooch/bc-containers-maps.adb
+lib/adabooch/bc-containers-queues-bounded.adb
+lib/adabooch/bc-containers-queues-dynamic.adb
+lib/adabooch/bc-containers-queues-ordered-bounded.adb
+lib/adabooch/bc-containers-queues-ordered-dynamic.adb
+lib/adabooch/bc-containers-queues-ordered-unbounded.adb
+lib/adabooch/bc-containers-queues-synchronized.adb
+lib/adabooch/bc-containers-queues-unbounded.adb
+lib/adabooch/bc-containers-queues.adb
+lib/adabooch/bc-containers-quicksort.adb
+lib/adabooch/bc-containers-rings-bounded.adb
+lib/adabooch/bc-containers-rings-dynamic.adb
+lib/adabooch/bc-containers-rings-unbounded.adb
+lib/adabooch/bc-containers-rings.adb
+lib/adabooch/bc-containers-sets-bounded.adb
+lib/adabooch/bc-containers-sets-dynamic.adb
+lib/adabooch/bc-containers-sets-unbounded.adb
+lib/adabooch/bc-containers-sets.adb
+lib/adabooch/bc-containers-shellsort.adb
+lib/adabooch/bc-containers-stacks-bounded.adb
+lib/adabooch/bc-containers-stacks-dynamic.adb
+lib/adabooch/bc-containers-stacks-unbounded.adb
+lib/adabooch/bc-containers-stacks.adb
+lib/adabooch/bc-containers-trees-avl-print.adb
+lib/adabooch/bc-containers-trees-avl-validate.adb
+lib/adabooch/bc-containers-trees-avl.adb
+lib/adabooch/bc-containers-trees-binary-in_order.adb
+lib/adabooch/bc-containers-trees-binary-post_order.adb
+lib/adabooch/bc-containers-trees-binary-pre_order.adb
+lib/adabooch/bc-containers-trees-binary.adb
+lib/adabooch/bc-containers-trees-multiway-post_order.adb
+lib/adabooch/bc-containers-trees-multiway-pre_order.adb
+lib/adabooch/bc-containers-trees-multiway.adb
+lib/adabooch/bc-containers.adb
+lib/adabooch/bc-copy.adb
+lib/adabooch/bc-filter.adb
+lib/adabooch/bc-graphs-directed.adb
+lib/adabooch/bc-graphs-undirected.adb
+lib/adabooch/bc-graphs.adb
+lib/adabooch/bc-smart.adb
+lib/adabooch/bc-support-bounded.adb
+lib/adabooch/bc-support-bounded_hash_tables.adb
+lib/adabooch/bc-support-dynamic.adb
+lib/adabooch/bc-support-exceptions.adb
+lib/adabooch/bc-support-hash_tables.adb
+lib/adabooch/bc-support-managed_storage.adb
+lib/adabooch/bc-support-synchronization.adb
+lib/adabooch/bc-support-unbounded.adb
+lib/adabooch/bc-support-unmanaged_storage.adb
+lib/adabooch/bc-containers-bags-bounded.ads
+lib/adabooch/bc-containers-bags-dynamic.ads
+lib/adabooch/bc-containers-bags-unbounded.ads
+lib/adabooch/bc-containers-bags.ads
+lib/adabooch/bc-containers-collections-bounded.ads
+lib/adabooch/bc-containers-collections-dynamic.ads
+lib/adabooch/bc-containers-collections-ordered-bounded.ads
+lib/adabooch/bc-containers-collections-ordered-dynamic.ads
+lib/adabooch/bc-containers-collections-ordered-unbounded.ads
+lib/adabooch/bc-containers-collections-ordered.ads
+lib/adabooch/bc-containers-collections-unbounded.ads
+lib/adabooch/bc-containers-collections.ads
+lib/adabooch/bc-containers-deques-bounded.ads
+lib/adabooch/bc-containers-deques-dynamic.ads
+lib/adabooch/bc-containers-deques-unbounded.ads
+lib/adabooch/bc-containers-deques.ads
+lib/adabooch/bc-containers-guarded.ads
+lib/adabooch/bc-containers-lists-double.ads
+lib/adabooch/bc-containers-lists-single.ads
+lib/adabooch/bc-containers-lists.ads
+lib/adabooch/bc-containers-maps-bounded.ads
+lib/adabooch/bc-containers-maps-dynamic.ads
+lib/adabooch/bc-containers-maps-hash_statistics.ads
+lib/adabooch/bc-containers-maps-synchronized.ads
+lib/adabooch/bc-containers-maps-unbounded.ads
+lib/adabooch/bc-containers-maps.ads
+lib/adabooch/bc-containers-queues-bounded.ads
+lib/adabooch/bc-containers-queues-dynamic.ads
+lib/adabooch/bc-containers-queues-ordered-bounded.ads
+lib/adabooch/bc-containers-queues-ordered-dynamic.ads
+lib/adabooch/bc-containers-queues-ordered-unbounded.ads
+lib/adabooch/bc-containers-queues-ordered.ads
+lib/adabooch/bc-containers-queues-synchronized.ads
+lib/adabooch/bc-containers-queues-unbounded.ads
+lib/adabooch/bc-containers-queues.ads
+lib/adabooch/bc-containers-quicksort.ads
+lib/adabooch/bc-containers-rings-bounded.ads
+lib/adabooch/bc-containers-rings-dynamic.ads
+lib/adabooch/bc-containers-rings-unbounded.ads
+lib/adabooch/bc-containers-rings.ads
+lib/adabooch/bc-containers-sets-bounded.ads
+lib/adabooch/bc-containers-sets-dynamic.ads
+lib/adabooch/bc-containers-sets-unbounded.ads
+lib/adabooch/bc-containers-sets.ads
+lib/adabooch/bc-containers-shellsort.ads
+lib/adabooch/bc-containers-stacks-bounded.ads
+lib/adabooch/bc-containers-stacks-dynamic.ads
+lib/adabooch/bc-containers-stacks-unbounded.ads
+lib/adabooch/bc-containers-stacks.ads
+lib/adabooch/bc-containers-trees-avl-print.ads
+lib/adabooch/bc-containers-trees-avl-validate.ads
+lib/adabooch/bc-containers-trees-avl.ads
+lib/adabooch/bc-containers-trees-binary-in_order.ads
+lib/adabooch/bc-containers-trees-binary-post_order.ads
+lib/adabooch/bc-containers-trees-binary-pre_order.ads
+lib/adabooch/bc-containers-trees-binary.ads
+lib/adabooch/bc-containers-trees-multiway-post_order.ads
+lib/adabooch/bc-containers-trees-multiway-pre_order.ads
+lib/adabooch/bc-containers-trees-multiway.ads
+lib/adabooch/bc-containers-trees.ads
+lib/adabooch/bc-containers.ads
+lib/adabooch/bc-copy.ads
+lib/adabooch/bc-filter.ads
+lib/adabooch/bc-graphs-directed.ads
+lib/adabooch/bc-graphs-undirected.ads
+lib/adabooch/bc-graphs.ads
+lib/adabooch/bc-smart.ads
+lib/adabooch/bc-support-bounded.ads
+lib/adabooch/bc-support-bounded_hash_tables.ads
+lib/adabooch/bc-support-dynamic.ads
+lib/adabooch/bc-support-exceptions.ads
+lib/adabooch/bc-support-hash_tables.ads
+lib/adabooch/bc-support-managed_storage.ads
+lib/adabooch/bc-support-standard_storage.ads
+lib/adabooch/bc-support-synchronization.ads
+lib/adabooch/bc-support-unbounded.ads
+lib/adabooch/bc-support-unmanaged_storage.ads
+lib/adabooch/bc-support.ads
+lib/adabooch/bc.ads
+share/adabooch/demo/ada_unit_support.adb
+share/adabooch/demo/ada_unit_support.ads
+share/adabooch/demo/ada_units.adb
+share/adabooch/demo/bcwords.ada
+share/adabooch/demo/configuration_demo.adb
+share/adabooch/demo/configuration_demo_support.adb
+share/adabooch/demo/configuration_demo_support.ads
+share/adabooch/demo/global_heap.ads
+share/adabooch/demo/lists_for_timing.ads
+share/adabooch/demo/lists_for_traversal.adb
+share/adabooch/demo/lists_for_traversal.ads
+share/adabooch/demo/lists_traversal.adb
+share/adabooch/demo/makefile
+share/adabooch/demo/ordering_support.adb
+share/adabooch/demo/ordering_support.ads
+share/adabooch/demo/ordering_test.adb
+share/adabooch/demo/queues_for_timing.ads
+share/adabooch/demo/storage.adb
+share/adabooch/demo/test_synchronization.adb
+share/adabooch/demo/time_lists.adb
+share/adabooch/demo/time_queues.adb
+share/adabooch/demo/unmanaged_storage.adb
+share/adabooch/demo/user_map.adb
+share/adabooch/demo/user_map_support.adb
+share/adabooch/demo/user_map_support.ads
+share/adabooch/demo/user_set.adb
+share/adabooch/demo/user_set_support.adb
+share/adabooch/demo/user_set_support.ads
+share/adabooch/test/assertions.adb
+share/adabooch/test/assertions.ads
+share/adabooch/test/avl_test.adb
+share/adabooch/test/avl_test_support.adb
+share/adabooch/test/avl_test_support.ads
+share/adabooch/test/bag_test.adb
+share/adabooch/test/bag_test_support.adb
+share/adabooch/test/bag_test_support.ads
+share/adabooch/test/chunks.adb
+share/adabooch/test/chunks.ads
+share/adabooch/test/collection_test.adb
+share/adabooch/test/collection_test_support.ads
+share/adabooch/test/deque_test.adb
+share/adabooch/test/deque_test_support.ads
+share/adabooch/test/global_heap.ads
+share/adabooch/test/graph_test.adb
+share/adabooch/test/graph_test_support.ads
+share/adabooch/test/list_test.adb
+share/adabooch/test/list_test_support.ads
+share/adabooch/test/makefile
+share/adabooch/test/map_test.adb
+share/adabooch/test/map_test_concurrent.adb
+share/adabooch/test/map_test_concurrent_support.ads
+share/adabooch/test/map_test_support.adb
+share/adabooch/test/map_test_support.ads
+share/adabooch/test/ordered_collection_test.adb
+share/adabooch/test/ordered_collection_test_support.ads
+share/adabooch/test/ordered_queue_test.adb
+share/adabooch/test/ordered_queue_test_support.ads
+share/adabooch/test/queue_test.adb
+share/adabooch/test/queue_test_concurrent.adb
+share/adabooch/test/queue_test_support.ads
+share/adabooch/test/queue_test_support_concurrent.ads
+share/adabooch/test/ring_test.adb
+share/adabooch/test/ring_test_support.ads
+share/adabooch/test/set_test.adb
+share/adabooch/test/set_test_support.adb
+share/adabooch/test/set_test_support.ads
+share/adabooch/test/smart_test.adb
+share/adabooch/test/smart_test_support.adb
+share/adabooch/test/smart_test_support.ads
+share/adabooch/test/sort_test.adb
+share/adabooch/test/stack_test.adb
+share/adabooch/test/stack_test_support.ads
+share/adabooch/test/stream_test.adb
+share/adabooch/test/stream_test_support-tcb.ads
+share/adabooch/test/stream_test_support-tcd.ads
+share/adabooch/test/stream_test_support-tcu.ads
+share/adabooch/test/stream_test_support.adb
+share/adabooch/test/stream_test_support.ads
+share/adabooch/test/tree_test.adb
+share/adabooch/test/tree_test_support.ads
+@dirrm lib/adabooch
+@dirrm share/adabooch/demo
+@dirrm share/adabooch/test
+@dirrm share/adabooch