aboutsummaryrefslogtreecommitdiff
path: root/devel/adime
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-16 20:41:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-16 20:41:59 +0000
commit92b67b5ed4829f7defe7be3615beceed5be0fa30 (patch)
tree3d79737ce6be74ac059274c93d5751e4055eb061 /devel/adime
parent68fa4ad8048af46da46911cb5b63c20682fc7f4b (diff)
downloadports-92b67b5ed4829f7defe7be3615beceed5be0fa30.tar.gz
ports-92b67b5ed4829f7defe7be3615beceed5be0fa30.zip
Adime is a portable add-on library for Allegro with functions for generating
Allegro dialogs in a very simple way. Its main purpose is to give as easy an API as possible to people who want dialogs for editing many kinds of input data. PR: ports/85165 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=142965
Diffstat (limited to 'devel/adime')
-rw-r--r--devel/adime/Makefile40
-rw-r--r--devel/adime/Makefile.man48
-rw-r--r--devel/adime/distinfo2
-rw-r--r--devel/adime/files/patch-misc-makefile.all28
-rw-r--r--devel/adime/files/patch-misc-makefile.uni45
-rw-r--r--devel/adime/pkg-descr6
-rw-r--r--devel/adime/pkg-plist5
7 files changed, 174 insertions, 0 deletions
diff --git a/devel/adime/Makefile b/devel/adime/Makefile
new file mode 100644
index 000000000000..37d9ea3575b9
--- /dev/null
+++ b/devel/adime/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: adime
+# Date Created: 20 Aug 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= adime
+PORTVERSION= 2.2.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Generate Allegro dialogs in a very simple way
+
+LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+.include "Makefile.man"
+
+INFO= adime
+
+MAKEFILE= makefile
+INSTALL_TARGET= install install-info install-man
+INSTALLS_SHLIB= yes
+
+pre-build:
+ @(cd ${WRKSRC} && ${SH} fix.sh unix)
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|gcc|${CC}| ; \
+ s|%%CFLAGS%%|${CFLAGS}| ; \
+ s|/usr/local|${PREFIX}| ; s|$$(OPT)||' \
+ ${WRKSRC}/misc/makefile.uni
+
+.include <bsd.port.mk>
diff --git a/devel/adime/Makefile.man b/devel/adime/Makefile.man
new file mode 100644
index 000000000000..5e4c579abc70
--- /dev/null
+++ b/devel/adime/Makefile.man
@@ -0,0 +1,48 @@
+MAN3= ADIME_DATE.3 \
+ ADIME_VERSION_MAJOR.3 \
+ ADIME_VERSION_MINOR.3 \
+ ADIME_VERSION_PATCH.3 \
+ adime_bmp.3 \
+ adime_button_font.3 \
+ adime_callback.3 \
+ adime_clean_screen.3 \
+ adime_d_button_proc.3 \
+ adime_d_calc_edit_result_proc.3 \
+ adime_d_check_proc.3 \
+ adime_d_double_calc_edit_proc.3 \
+ adime_d_edit_proc.3 \
+ adime_d_greyable_check_proc.3 \
+ adime_d_int_calc_edit_proc.3 \
+ adime_d_line_proc.3 \
+ adime_d_list_proc.3 \
+ adime_d_multiline_text_proc.3 \
+ adime_d_text_list_proc.3 \
+ adime_d_window_proc.3 \
+ adime_dialogf.3 \
+ adime_double2string.3 \
+ adime_draw_empty_button.3 \
+ adime_draw_picture_button.3 \
+ adime_draw_picture_button_down.3 \
+ adime_draw_text_button.3 \
+ adime_draw_text_button_down.3 \
+ adime_evaluate.3 \
+ adime_exit.3 \
+ adime_file_select.3 \
+ adime_fill_textout.3 \
+ adime_font.3 \
+ adime_init.3 \
+ adime_lowlevel_dialogf.3 \
+ adime_lowlevel_vdialogf.3 \
+ adime_scancode_to_pretty_name.3 \
+ adime_scancode_to_short_name.3 \
+ adime_short_name_to_scancode.3 \
+ adime_title_font.3 \
+ adime_udouble2string.3 \
+ adime_uevaluate.3 \
+ adime_va_arg.3 \
+ adime_va_end.3 \
+ adime_va_list.3 \
+ adime_va_start.3 \
+ adime_vdialogf.3 \
+ adime_window_visible.3 \
+ adime_yield.3
diff --git a/devel/adime/distinfo b/devel/adime/distinfo
new file mode 100644
index 000000000000..46e0f895cb06
--- /dev/null
+++ b/devel/adime/distinfo
@@ -0,0 +1,2 @@
+MD5 (adime-2.2.1.tar.gz) = aa71fbe7661e56421cab42e6bca70c7c
+SIZE (adime-2.2.1.tar.gz) = 244970
diff --git a/devel/adime/files/patch-misc-makefile.all b/devel/adime/files/patch-misc-makefile.all
new file mode 100644
index 000000000000..4f7806489bb6
--- /dev/null
+++ b/devel/adime/files/patch-misc-makefile.all
@@ -0,0 +1,28 @@
+--- misc/makefile.all.orig Sun Sep 5 17:59:45 2004
++++ misc/makefile.all Sat Aug 20 13:55:02 2005
+@@ -185,8 +185,6 @@
+
+ DOCBASEFILES = adime dime internal license readme changes expressi thanks wishlist
+ DOCS = $(addprefix docs/txt/,$(addsuffix .txt,adime internal expressi wishlist))
+-DOCS += $(addprefix docs/rtf/,$(addsuffix .rtf,$(DOCBASEFILES)))
+-DOCS += $(addprefix docs/html/,$(addsuffix $(HTML_SUFFIX),$(DOCBASEFILES)))
+ DOCS += license.txt readme.txt changes.txt thanks.txt
+ CHMDOCS = $(addprefix docs/chm/,$(addsuffix $(HTML_SUFFIX),$(DOCBASEFILES)))
+ DEVHELPDOCS = $(addprefix docs/devhelp/,$(addsuffix $(HTML_SUFFIX),$(DOCBASEFILES)))
+@@ -218,14 +216,14 @@
+ @echo Compiling Adime for $(PLATFORM), $(DESCRIPTION). Please wait.
+
+ all:
+- $(MAKE) startmsg lib DEBUGMODE=1
++ $(MAKE) startmsg lib
+ $(MAKE) startmsg lib examples docs
+ @echo Adime for $(PLATFORM) has been compiled.
+ @echo Run make installall to complete the installation.
+
+ installall:
+ $(MAKE) install
+- $(MAKE) install DEBUGMODE=1
++ $(MAKE) install
+ @echo Both Adime library versions have been installed!
+
+ lib: $(LIB_NAME)
diff --git a/devel/adime/files/patch-misc-makefile.uni b/devel/adime/files/patch-misc-makefile.uni
new file mode 100644
index 000000000000..e9b08a4f1f0e
--- /dev/null
+++ b/devel/adime/files/patch-misc-makefile.uni
@@ -0,0 +1,45 @@
+--- misc/makefile.uni.orig Fri Sep 10 16:34:54 2004
++++ misc/makefile.uni Sat Aug 20 13:45:44 2005
+@@ -118,16 +118,6 @@
+ WFLAGS = -Wall -Wno-unused
+ endif
+
+-ifdef PGCC
+-OFLAGS = -mcpu=pentium -O6 -ffast-math
+-else
+-ifdef PENTIUMONLY
+-OFLAGS = -march=pentium -O2 -funroll-loops -ffast-math
+-else
+-OFLAGS = -mcpu=pentium -O2 -funroll-loops -ffast-math
+-endif
+-endif
+-
+ ifdef STATICLINK_ALLEGRO
+ ALLEGRO_CONFIG_FLAGS = --static
+ else
+@@ -143,13 +133,14 @@
+ else
+ ifdef PROFILEMODE
+ # profiling build
+-CFLAGS = $(WFLAGS) $(OFLAGS) -pg
++CFLAGS = $(WFLAGS) -pg
+ SFLAGS = $(WFLAGS)
+ LFLAGS += -pg
+ LIB_FLAGS = `allegro-config --libs profile $(ALLEGRO_CONFIG_FLAGS)`
+ else
+ # optimised build
+-CFLAGS = $(WFLAGS) $(OFLAGS) -fomit-frame-pointer -fno-strength-reduce
++OPT = -O2 -ffast-math -fomit-frame-pointer -fno-strength-reduce
++CFLAGS = %%CFLAGS%% $(WFLAGS) -fPIC $(OPT) `allegro-config --cflags`
+ SFLAGS = $(WFLAGS)
+ ifndef SYMBOLMODE
+ LFLAGS += -s
+@@ -168,7 +159,7 @@
+ CFLAGS += -D_ADIME_FORTIFY=1 -DFORTIFY
+ endif
+
+-CFLAGS_NO_OPTIMIZE = $(WFLAGS)
++CFLAGS_NO_OPTIMIZE = $(WFLAGS) -fPIC `allegro-config --cflags`
+
+ COMPILE_FLAGS = $(subst src/,-DADIME_SRC ,$(findstring src/, $<))$(CFLAGS)
+ COMPILE_FLAGS_NO_OPTIMIZE = $(subst src/,-DADIME_SRC ,$(findstring src/, $<))$(CFLAGS_NO_OPTIMIZE)
diff --git a/devel/adime/pkg-descr b/devel/adime/pkg-descr
new file mode 100644
index 000000000000..f4f6cdc70625
--- /dev/null
+++ b/devel/adime/pkg-descr
@@ -0,0 +1,6 @@
+Adime is a portable add-on library for Allegro with functions for generating
+Allegro dialogs in a very simple way. Its main purpose is to give as easy an
+API as possible to people who want dialogs for editing many kinds of input
+data.
+
+WWW: http://adime.sourceforge.net/
diff --git a/devel/adime/pkg-plist b/devel/adime/pkg-plist
new file mode 100644
index 000000000000..89f269efac29
--- /dev/null
+++ b/devel/adime/pkg-plist
@@ -0,0 +1,5 @@
+include/adime.h
+include/adime/adimecfg.h
+include/adime/adimeint.h
+lib/libadime.so
+@dirrm include/adime