aboutsummaryrefslogtreecommitdiff
path: root/devel/aegis
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-04 18:32:32 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-04 18:32:32 +0000
commitfda41532f6c4fb5831d60fdffdb12d47484160b1 (patch)
tree885a5566855ec5539aa52a29a9c0183a7b3c0b11 /devel/aegis
parent9b875f47fd27cb7a94ed1cba5cb34d127c583f23 (diff)
downloadports-fda41532f6c4fb5831d60fdffdb12d47484160b1.tar.gz
ports-fda41532f6c4fb5831d60fdffdb12d47484160b1.zip
Aegis is a transaction-based software configuration management system. It
provides a framework within which a team of developers may work on many changes to a program independently, and Aegis coordinates integrating these changes back into the master source of the program, with as little disruption as possible. Some key features: * All operations on the repository are based on change sets. * True configurations. All changes are reproducible snapshots. Every change set has a unique configuration identifier. * Ability to rename files without losing their history. * Binary files are supported. * File meta-data are versioned. Aegis versions permissions also. * Commits are truly atomic. No part of a commit takes effect until the entire commit has succeeded. Log messages are attached to the change set, not stored redundantly in each file. * Access controls on lines of development (branches). Creating a branch in Aegis can be accomplished with a single, fast command. * Repository synchronization, geographically distributed development. * Optimal performance for all users, local or remote (no difference). * Disconnected commits. * Peer-to-peer architecture. Work may flow in without involving a master site. * Costs are proportional to change size, not data size. WWW: http://aegis.sourceforge.net/
Notes
Notes: svn path=/head/; revision=205012
Diffstat (limited to 'devel/aegis')
-rw-r--r--devel/aegis/Makefile74
-rw-r--r--devel/aegis/distinfo3
-rw-r--r--devel/aegis/files/patch-Makefile.in30
-rw-r--r--devel/aegis/pkg-descr24
-rw-r--r--devel/aegis/pkg-plist213
5 files changed, 344 insertions, 0 deletions
diff --git a/devel/aegis/Makefile b/devel/aegis/Makefile
new file mode 100644
index 000000000000..2be60eeddfb5
--- /dev/null
+++ b/devel/aegis/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: aegis
+# Date created: 2007-12-20
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= aegis
+PORTVERSION= 4.22
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Transaction-based software configuration management system
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= cook:${PORTSDIR}/devel/cook \
+ fhist:${PORTSDIR}/devel/fhist \
+ tkdiff:${PORTSDIR}/textproc/tkdiff
+
+USE_GETTEXT= yes
+USE_GNOME= libxml2
+USE_PERL5= yes
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-nlsdir="${PREFIX}/share/locale"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
+ WISH="${WISH}"
+REINPLACE_ARGS= -i ''
+
+MAN1= ae-cvs-ci.1 ae-repo-ci.1 ae-sccs-put.1 ae_c.1 ae_p.1 \
+ aeannotate.1 aeb.1 aebuffy.1 aeca.1 aecd.1 aechown.1 aeclean.1 \
+ aeclone.1 aecomp.1 aecomplete.1 aecp.1 aecpu.1 aecvsserver.1 \
+ aed.1 aedb.1 aedbu.1 aede.1 aede-policy.1 aedeu.1 aediff.1 \
+ aedist.1 aedn.1 aeedit.1 aefa.1 aefind.1 aefinish.1 aefp.1 \
+ aeget.1 aegis.1 aegis.cgi.1 aeib.1 aeibu.1 aeifail.1 aeimport.1 \
+ aeintegratq.1 aeipass.1 ael.1 aelcf.1 aelic.1 aelock.1 aelpf.1 \
+ aels.1 aemeasure.1 aemt.1 aemtu.1 aemv.1 aemvu.1 aena.1 aenbr.1 \
+ aenbru.1 aenc.1 aencu.1 aend.1 aenf.1 aenfu.1 aeni.1 aenpa.1 \
+ aenpr.1 aenrls.1 aenrv.1 aent.1 aentu.1 aepa.1 aepatch.1 \
+ aepromptcmd.1 aer.1 aera.1 aerb.1 aerbu.1 aerd.1 aerect.1 \
+ aerevml.1 aerfail.1 aeri.1 aerm.1 aermpr.1 aermu.1 aerpa.1 \
+ aerpass.1 aerpu.1 aerrv.1 aesub.1 aesubunit.1 aesvt.1 aet.1 \
+ aetar.1 aev.1 aexml.1 aexver.1 tkaeca.1 tkaegis.1 tkaenc.1 \
+ tkaepa.1 tkaer.1
+
+MAN5= aecattr.5 aecstate.5 aedir.5 aefattr.5 aefstate.5 aegis.5 \
+ aegstate.5 aelock.5 aemetrics.5 aepattr.5 aepconf.5 aepstate.5 \
+ aer.5 aerptidx.5 aesub.5 aetest.5 aeuconf.5 aeustate.5
+
+post-patch:
+# Avoid "2>/dev/null" redirect in csh (ends up with empty manpath).
+ @${REINPLACE_CMD} -Ee 's|(MANPATH_PROG) 2>/dev/null|\1|' \
+ ${WRKSRC}/configure
+# Fix path to Tk interpreter.
+ @cd ${WRKSRC}/script && ${REINPLACE_CMD} -e 's|wish $$0|${WISH} $$0|' \
+ aebuffy.in aecomp.in aexver.in tkaeca.in tkaegis.in tkaenc.in \
+ tkaepa.in tkaer.in xaegis.in
+# Import global variable "datadir" inside function (not found otherwise).
+ @${REINPLACE_CMD} -e 's|global lib|& datadir|' \
+ ${WRKSRC}/script/xaegis.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+. for dir in de en
+ ${MKDIR} ${DOCSDIR}/${dir}
+ cd ${WRKSRC}/lib/${dir} && ${INSTALL_DATA} *.ps *.txt ${DOCSDIR}/${dir}
+. endfor
+.endif
+# Fails to reinstall because keeps track of created directories, so make it
+# forget that, by recreating them on each install.
+ @${FIND} ${WRKSRC} -type f -name ".*dir" -delete
+
+.include <bsd.port.mk>
diff --git a/devel/aegis/distinfo b/devel/aegis/distinfo
new file mode 100644
index 000000000000..907d657bba83
--- /dev/null
+++ b/devel/aegis/distinfo
@@ -0,0 +1,3 @@
+MD5 (aegis-4.22.tar.gz) = 19238b7f51822518f3651e7c1243ee0f
+SHA256 (aegis-4.22.tar.gz) = 43b2a4f3a0d5bb3539461e417ef937851e375ab61737d88239d8854f170ecae5
+SIZE (aegis-4.22.tar.gz) = 4520815
diff --git a/devel/aegis/files/patch-Makefile.in b/devel/aegis/files/patch-Makefile.in
new file mode 100644
index 000000000000..2df56738aad0
--- /dev/null
+++ b/devel/aegis/files/patch-Makefile.in
@@ -0,0 +1,30 @@
+--- ./Makefile.in.orig Wed Mar 29 06:07:48 2006
++++ ./Makefile.in Fri Dec 21 03:23:09 2007
+@@ -25500,8 +25500,7 @@
+
+ LibFiles =
+
+-DataFiles = $(RPM_BUILD_ROOT)$(sysconfdir)/profile.d/aegis.sh \
+- $(RPM_BUILD_ROOT)$(sysconfdir)/profile.d/aegis.csh \
++DataFiles = \
+ $(RPM_BUILD_ROOT)$(datadir)/aedefault.css \
+ $(RPM_BUILD_ROOT)$(datadir)/aegis.icon \
+ $(RPM_BUILD_ROOT)$(datadir)/aegis.mask \
+@@ -25563,8 +25562,6 @@
+ $(RPM_BUILD_ROOT)$(datadir)/if.sh \
+ $(RPM_BUILD_ROOT)$(datadir)/ip.inews.sh \
+ $(RPM_BUILD_ROOT)$(datadir)/ip.sh \
+- $(RPM_BUILD_ROOT)$(datadir)/man1/en/ae_c.1 \
+- $(RPM_BUILD_ROOT)$(datadir)/man1/en/ae_p.1 \
+ $(RPM_BUILD_ROOT)$(datadir)/profile \
+ $(RPM_BUILD_ROOT)$(datadir)/remind/awt_dvlp.sh \
+ $(RPM_BUILD_ROOT)$(datadir)/remind/awt_intgrtn.sh \
+@@ -28305,7 +28302,7 @@
+
+ install-man: install-man-$(HAVE_GROFF)
+
+-install-doc: install-doc-$(HAVE_GROFF)
++install-doc:
+
+ install: install-bin install-lib install-po install-man install-doc
+
diff --git a/devel/aegis/pkg-descr b/devel/aegis/pkg-descr
new file mode 100644
index 000000000000..a15d69cc7b7b
--- /dev/null
+++ b/devel/aegis/pkg-descr
@@ -0,0 +1,24 @@
+Aegis is a transaction-based software configuration management system. It
+provides a framework within which a team of developers may work on many
+changes to a program independently, and Aegis coordinates integrating these
+changes back into the master source of the program, with as little disruption
+as possible. Some key features:
+
+* All operations on the repository are based on change sets.
+* True configurations. All changes are reproducible snapshots. Every change
+ set has a unique configuration identifier.
+* Ability to rename files without losing their history.
+* Binary files are supported.
+* File meta-data are versioned. Aegis versions permissions also.
+* Commits are truly atomic. No part of a commit takes effect until the entire
+ commit has succeeded. Log messages are attached to the change set, not
+ stored redundantly in each file.
+* Access controls on lines of development (branches). Creating a branch in
+ Aegis can be accomplished with a single, fast command.
+* Repository synchronization, geographically distributed development.
+* Optimal performance for all users, local or remote (no difference).
+* Disconnected commits.
+* Peer-to-peer architecture. Work may flow in without involving a master site.
+* Costs are proportional to change size, not data size.
+
+WWW: http://aegis.sourceforge.net/
diff --git a/devel/aegis/pkg-plist b/devel/aegis/pkg-plist
new file mode 100644
index 000000000000..3e63f14c9bd7
--- /dev/null
+++ b/devel/aegis/pkg-plist
@@ -0,0 +1,213 @@
+@exec mkdir -p %D/com/aegis
+bin/ae-cvs-ci
+bin/ae-repo-ci
+bin/ae-sccs-put
+bin/ae_diff2htm
+bin/aeannotate
+bin/aebuffy
+bin/aecomp
+bin/aecomplete
+bin/aecvsserver
+bin/aede-policy
+bin/aediff
+bin/aedist
+bin/aeedit
+bin/aefind
+bin/aefinish
+bin/aeget
+bin/aeget.instal
+bin/aegis
+bin/aegis.cgi
+bin/aegis.cgi.i
+bin/aeimport
+bin/aeintegratq
+bin/aelcf
+bin/aelock
+bin/aelpf
+bin/aels
+bin/aemeasure
+bin/aepatch
+bin/aepromptcmd
+bin/aerect
+bin/aereport
+bin/aerevml
+bin/aesub
+bin/aesubunit
+bin/aesvt
+bin/aetar
+bin/aexml
+bin/aexver
+bin/tkaeca
+bin/tkaegis
+bin/tkaenc
+bin/tkaepa
+bin/tkaer
+bin/xaegis
+%%DATADIR%%/aedefault.css
+%%DATADIR%%/aegis.icon
+%%DATADIR%%/aegis.mask
+%%DATADIR%%/aegis.pgm
+%%DATADIR%%/config.example/aesvt
+%%DATADIR%%/config.example/architecture
+%%DATADIR%%/config.example/cake
+%%DATADIR%%/config.example/cook
+%%DATADIR%%/config.example/diff
+%%DATADIR%%/config.example/diff3
+%%DATADIR%%/config.example/diff_not
+%%DATADIR%%/config.example/fhist
+%%DATADIR%%/config.example/gnu_diff
+%%DATADIR%%/config.example/make
+%%DATADIR%%/config.example/makefile
+%%DATADIR%%/config.example/merge
+%%DATADIR%%/config.example/rcs
+%%DATADIR%%/config.example/sccs
+%%DATADIR%%/cshrc
+%%DATADIR%%/db_forced.sh
+%%DATADIR%%/de.inews.sh
+%%DATADIR%%/de.sh
+%%DATADIR%%/de/LC_MESSAGES/glossary
+%%DATADIR%%/deu.inews.sh
+%%DATADIR%%/deu.sh
+%%DATADIR%%/en/html/chan_hstry.rpt
+%%DATADIR%%/en/html/chan_menu.rpt
+%%DATADIR%%/en/html/changes.rpt
+%%DATADIR%%/en/html/cp_command.rpt
+%%DATADIR%%/en/html/file_activ.rpt
+%%DATADIR%%/en/html/file_cflct.rpt
+%%DATADIR%%/en/html/file_densi.rpt
+%%DATADIR%%/en/html/file_diff.rpt
+%%DATADIR%%/en/html/file_hstry.rpt
+%%DATADIR%%/en/html/file_list.rpt
+%%DATADIR%%/en/html/file_menu.rpt
+%%DATADIR%%/en/html/proj_cch1.rpt
+%%DATADIR%%/en/html/proj_cch2.rpt
+%%DATADIR%%/en/html/proj_cch3.rpt
+%%DATADIR%%/en/html/proj_filme.rpt
+%%DATADIR%%/en/html/proj_hstg2.rpt
+%%DATADIR%%/en/html/proj_hstg3.rpt
+%%DATADIR%%/en/html/proj_hstgm.rpt
+%%DATADIR%%/en/html/proj_hstry.rpt
+%%DATADIR%%/en/html/proj_list.rpt
+%%DATADIR%%/en/html/proj_menu.rpt
+%%DATADIR%%/en/html/proj_prgr1.rpt
+%%DATADIR%%/en/html/proj_prgr2.rpt
+%%DATADIR%%/en/html/proj_prgr3.rpt
+%%DATADIR%%/en/html/proj_staff.rpt
+%%DATADIR%%/en/html/proj_stats.rpt
+%%DATADIR%%/en/notes/locale.man
+%%DATADIR%%/fr/LC_MESSAGES/glossaire
+%%DATADIR%%/icon/64x64.png
+%%DATADIR%%/icon/aegis.gif
+%%DATADIR%%/icon/bigger.png
+%%DATADIR%%/icon/rss.gif
+%%DATADIR%%/if.inews.sh
+%%DATADIR%%/if.sh
+%%DATADIR%%/ip.inews.sh
+%%DATADIR%%/ip.sh
+%%DATADIR%%/profile
+%%DATADIR%%/remind/awt_dvlp.sh
+%%DATADIR%%/remind/awt_intgrtn.sh
+%%DATADIR%%/remind/bng_dvlpd.sh
+%%DATADIR%%/remind/bng_rvwd.sh
+%%DATADIR%%/report.index
+%%DATADIR%%/report/chan_detai.rpt
+%%DATADIR%%/report/chan_files.rpt
+%%DATADIR%%/report/chan_histo.rpt
+%%DATADIR%%/report/chan_lists.rpt
+%%DATADIR%%/report/chan_log.rpt
+%%DATADIR%%/report/chan_recur.rpt
+%%DATADIR%%/report/chan_so.rpt
+%%DATADIR%%/report/debchanlog.rpt
+%%DATADIR%%/report/file_activ.rpt
+%%DATADIR%%/report/file_cflct.rpt
+%%DATADIR%%/report/file_hstry.rpt
+%%DATADIR%%/report/file_vhist.rpt
+%%DATADIR%%/report/proj_activ.rpt
+%%DATADIR%%/report/proj_admin.rpt
+%%DATADIR%%/report/proj_ances.rpt
+%%DATADIR%%/report/proj_brada.rpt
+%%DATADIR%%/report/proj_bran.rpt
+%%DATADIR%%/report/proj_brana.rpt
+%%DATADIR%%/report/proj_detai.rpt
+%%DATADIR%%/report/proj_devel.rpt
+%%DATADIR%%/report/proj_files.rpt
+%%DATADIR%%/report/proj_gantt.rpt
+%%DATADIR%%/report/proj_integ.rpt
+%%DATADIR%%/report/proj_lists.rpt
+%%DATADIR%%/report/proj_parent.rpt
+%%DATADIR%%/report/proj_recur.rpt
+%%DATADIR%%/report/proj_rvwrs.rpt
+%%DATADIR%%/report/proj_staff.rpt
+%%DATADIR%%/report/proj_stats.rpt
+%%DATADIR%%/report/user_list.rpt
+%%DATADIR%%/report/user_recurs.rpt
+%%DATADIR%%/rf.inews.sh
+%%DATADIR%%/rf.sh
+%%DATADIR%%/rp.inews.sh
+%%DATADIR%%/rp.sh
+%%DATADIR%%/rpu.inews.sh
+%%DATADIR%%/rpu.sh
+%%DATADIR%%/wish/aebuffy.rpt
+%%DATADIR%%/wish/aecomp.rpt
+%%DATADIR%%/wish/chan_attr.rpt
+%%DATADIR%%/wish/chan_list.rpt
+%%DATADIR%%/wish/devs_list.rpt
+%%DATADIR%%/wish/proj_attr.rpt
+%%DATADIR%%/wish/proj_conf.rpt
+%%DATADIR%%/wish/proj_list.rpt
+%%DATADIR%%/wish/tkaer_info.rpt
+%%PORTDOCS%%%%DOCSDIR%%/de/auug97.ps
+%%PORTDOCS%%%%DOCSDIR%%/de/auug97.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/aoss4.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/aoss4.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/auug93.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/auug93.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/auug96.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/auug96.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/auug97.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/auug97.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/building.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/building.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/change_log.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/change_log.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/cvs-comparison.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/cvs-comparison.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/faq.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/howto.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/howto.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/lsm.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/lsm.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/readme.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/refman.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/refman.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/release.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/release.txt
+%%PORTDOCS%%%%DOCSDIR%%/en/user-guide.ps
+%%PORTDOCS%%%%DOCSDIR%%/en/user-guide.txt
+share/locale/de/LC_MESSAGES/aegis.mo
+share/locale/en/LC_MESSAGES/aegis.mo
+share/locale/es/LC_MESSAGES/aegis.mo
+share/locale/fr/LC_MESSAGES/aegis.mo
+share/locale/nl/LC_MESSAGES/aegis.mo
+share/locale/ro/LC_MESSAGES/aegis.mo
+share/locale/ru/LC_MESSAGES/aegis.mo
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/en
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/de
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/wish
+@dirrm %%DATADIR%%/report
+@dirrm %%DATADIR%%/remind
+@dirrm %%DATADIR%%/icon
+@dirrm %%DATADIR%%/fr/LC_MESSAGES
+@dirrm %%DATADIR%%/fr
+@dirrm %%DATADIR%%/en/notes
+@dirrm %%DATADIR%%/en/html
+@dirrm %%DATADIR%%/en
+@dirrm %%DATADIR%%/de/LC_MESSAGES
+@dirrm %%DATADIR%%/de
+@dirrm %%DATADIR%%/config.example
+@dirrm %%DATADIR%%
+@dirrmtry com/aegis
+@dirrmtry com