aboutsummaryrefslogtreecommitdiff
path: root/devel/allegro-devel/files
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2002-02-23 21:21:49 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2002-02-23 21:21:49 +0000
commite1235235ee09a1f902771522805c872bfa1a0479 (patch)
tree033f9a13c84de57f89d936f5a057df52205b7126 /devel/allegro-devel/files
parenteed8ea7bc628a629e121c66b624ab6de2d2a63e4 (diff)
downloadports-e1235235ee09a1f902771522805c872bfa1a0479.tar.gz
ports-e1235235ee09a1f902771522805c872bfa1a0479.zip
Update port to version 4.0.0.
Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=55146
Diffstat (limited to 'devel/allegro-devel/files')
-rw-r--r--devel/allegro-devel/files/patch-aclocal.m411
-rw-r--r--devel/allegro-devel/files/patch-configure.in9
-rw-r--r--devel/allegro-devel/files/patch-makefile.in64
3 files changed, 77 insertions, 7 deletions
diff --git a/devel/allegro-devel/files/patch-aclocal.m4 b/devel/allegro-devel/files/patch-aclocal.m4
new file mode 100644
index 000000000000..45dc3fe47e5d
--- /dev/null
+++ b/devel/allegro-devel/files/patch-aclocal.m4
@@ -0,0 +1,11 @@
+--- aclocal.m4.orig Thu Feb 7 19:52:21 2002
++++ aclocal.m4 Thu Feb 7 19:52:45 2002
+@@ -181,7 +181,7 @@
+ LDFLAGS="$allegro_save_LDFLAGS"])
+ if test $allegro_cv_support_export_dynamic = yes; then
+ allegro_support_modules=yes
+- LIBS="-ldl $LIBS"
++ LIBS="$LIBS"
+ LDFLAGS="-Wl,-export-dynamic $LDFLAGS"
+ fi])
+ fi
diff --git a/devel/allegro-devel/files/patch-configure.in b/devel/allegro-devel/files/patch-configure.in
new file mode 100644
index 000000000000..d71c977159a8
--- /dev/null
+++ b/devel/allegro-devel/files/patch-configure.in
@@ -0,0 +1,9 @@
+--- configure.in.orig Wed Feb 13 22:27:04 2002
++++ configure.in Wed Feb 13 22:27:10 2002
+@@ -498,5 +498,5 @@
+
+ dnl Run "make depend" if necessary.
+ if test "X$allegro_make_depend" = "Xyes"; then
+- make depend
++ ${MAKE} depend
+ fi
diff --git a/devel/allegro-devel/files/patch-makefile.in b/devel/allegro-devel/files/patch-makefile.in
index 8ec2a46a71b3..d62d72d642ac 100644
--- a/devel/allegro-devel/files/patch-makefile.in
+++ b/devel/allegro-devel/files/patch-makefile.in
@@ -1,11 +1,61 @@
---- makefile.in.orig Wed Jan 24 00:15:20 2001
-+++ makefile.in Sat Dec 15 13:24:16 2001
-@@ -279,7 +279,7 @@
- done
+--- makefile.in.orig Mon Dec 10 11:37:39 2001
++++ makefile.in Thu Feb 14 08:59:06 2002
+@@ -31,7 +31,7 @@
+ ACLOCAL = aclocal
+ ACLOCAL_M4 = $(srcdir)/aclocal.m4
+ AUTOCONF = autoconf
+-AUTOHEADER = autoheader
++AUTOHEADER =autoheader213
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -323,18 +323,19 @@
+ fi
$(mkinstalldirs) $(bindir)
@echo Installing allegro-config to $(bindir)
- @$(INSTALL_PROGRAM) allegro-config $(bindir)
+- @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
+- (grep -q $(libdir) /etc/ld.so.conf || \
+- test $(libdir) = /lib || test $(libdir) = /usr/lib) \
+- && ($(LDCONFIG) $(libdir) || true) || (\
+- echo "" ; \
+- echo "Warning: shared library destination $(libdir) is not in ldd search path." ; \
+- echo "Unless you add it to /etc/ld.so.conf, you must set LD_LIBRARY_PATH to include"; \
+- echo "$(libdir) each time you want to run an Allegro program." ; \
+- $(LDCONFIG) -n $(libdir) ; \
+- ) ; \
+- fi
+ @$(INSTALL) allegro-config $(bindir)
- @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
- grep -q $(libdir) /etc/ld.so.conf && ($(LDCONFIG) $(libdir) || true) || (\
- echo "" ; \
++# Don't worry about this,
++# @if test -n "$(LIBDIR)/liball*-$(shared_version).so"; then \
++# (grep -q $(libdir) /etc/ld.so.conf || \
++# test $(libdir) = /lib || test $(libdir) = /usr/lib) \
++# && ($(LDCONFIG) $(libdir) || true) || (\
++# echo "" ; \
++# echo "Warning: shared library destination $(libdir) is not in ldd search path." ; \
++# echo "Unless you add it to /etc/ld.so.conf, you must set LD_LIBRARY_PATH to include"; \
++# echo "$(libdir) each time you want to run an Allegro program." ; \
++# $(LDCONFIG) $(libdir) ; \
++# ) ; \
++# fi
+
+ install-headers:
+ $(mkinstalldirs) $(includedir)/allegro
+@@ -367,7 +368,7 @@
+ @for prog in $(ALLEGRO_LIB_EXES) $(ALLEGRO_DATAFILE_EXES); do \
+ if test "X`echo $$prog | sed -e s,tools/.\*,,`" = X; then \
+ echo Installing $$prog to $(bindir); \
+- $(INSTALL_PROGRAM) $$prog $(bindir); \
++ $(INSTALL) $$prog $(bindir); \
+ fi; \
+ done
+
+@@ -424,7 +425,7 @@
+ @for l in alleg alld allp; do \
+ rm -f $(libdir)/lib$${l}-${shared_version}.so; \
+ done
+- $(LDCONFIG) -n $(libdir) # remove symlinks
++ $(LDCONFIG) $(libdir) # remove symlinks
+ -$(LDCONFIG) $(libdir) # update cache (only works if we're root)
+
+ uninstall-modules: