aboutsummaryrefslogtreecommitdiff
path: root/devel/alog
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-10-16 13:19:32 +0000
committerJohn Marino <marino@FreeBSD.org>2014-10-16 13:19:32 +0000
commit834184d193aede5e6b7dc32793a9e8e42fc60496 (patch)
treedef54e2e9e94c4bd6321114dc3dc87121e0f7413 /devel/alog
parentfa93bad1215e901cfebdeeb3dcf02440416def7a (diff)
downloadports-834184d193aede5e6b7dc32793a9e8e42fc60496.tar.gz
ports-834184d193aede5e6b7dc32793a9e8e42fc60496.zip
net/alog: Upgrade version 0.4.1 => 0.5.0
The upgrade removes: * The version package * The full option (pgsql, smtp, and xmpp facilities) It switches to build with gprbuild It fixes the policy database so that it's safe for concurrent access.
Notes
Notes: svn path=/head/; revision=371005
Diffstat (limited to 'devel/alog')
-rw-r--r--devel/alog/Makefile29
-rw-r--r--devel/alog/distinfo4
-rw-r--r--devel/alog/pkg-plist113
3 files changed, 18 insertions, 128 deletions
diff --git a/devel/alog/Makefile b/devel/alog/Makefile
index 33667a9ccfb1..0ee1bce04262 100644
--- a/devel/alog/Makefile
+++ b/devel/alog/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= alog
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.0
CATEGORIES= devel
MASTER_SITES= http://www.codelabs.ch/download/
DISTNAME= libalog-${PORTVERSION}
@@ -12,54 +12,49 @@ COMMENT= Stackable logging framework for Ada
LICENSE= LGPL21
+BUILD_DEPENDS= gprbuild:${PORTSDIR}/devel/gprbuild
+
USES= ada tar:bzip2
ALL_TARGET= all
+PORTDOCS= html
MAKE_ARGS+= NUM_CPUS=${MAKE_JOBS_NUMBER} \
LIBRARY_KIND=static
-OPTIONS_DEFINE= FULL TEST DOCS
+OPTIONS_DEFINE= TEST DOCS
OPTIONS_SUB= yes
TEST_DESC= Run unit test suite before installation
-FULL_DESC= Full capabilities (requires PGSQL and AWS)
NO_OPTIONS_SORT=yes
+DOCS_USES= gmake
+DOCS_BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ source-highlight:${PORTSDIR}/textproc/source-highlight
+TEST_BUILD_DEPENDS= ${LOCALBASE}/lib/gnat/ahven.gpr:${PORTSDIR}/devel/ahven
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTEST}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/gnat/ahven.gpr:${PORTSDIR}/devel/ahven
ALL_TARGET+= tests
.endif
-.if ${PORT_OPTIONS:MFULL}
-MAKE_ENV+= TARGET=full
-BUILD_DEPENDS+= apq-pgsql>0:${PORTSDIR}/databases/apq-pgsql \
- aws>0:${PORTSDIR}/www/aws
-.endif
-
.if ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
- source-highlight:${PORTSDIR}/textproc/source-highlight
ALL_TARGET+= doc
-USES+= gmake
.endif
post-patch:
${REINPLACE_CMD} -e '/^NUM_CPUS/d' ${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's/\(not-allowed\)/NONEXISTENT\/\1/' \
${WRKSRC}/tests/facility_tests-fd.adb
- ${REINPLACE_CMD} -e "s|\.Linker_Switches;|.Linker_Switches \& (\"-R`gnatls -v|awk '/adalib/ {print $$1}'`\");|" \
- ${WRKSRC}/alog_full_tests.gpr
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
${STAGEDIR}${PREFIX}/lib/alog \
- ${STAGEDIR}${PREFIX}/include/alog
+ ${STAGEDIR}${PREFIX}/include/alog \
+ ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/include/alog
${INSTALL_DATA} ${WRKSRC}/lib/*/*.ali ${STAGEDIR}${PREFIX}/lib/alog
${INSTALL_DATA} ${WRKSRC}/gnat/alog.gpr ${STAGEDIR}${PREFIX}/lib/gnat
${INSTALL_DATA} ${WRKSRC}/lib/*/libalog.a ${STAGEDIR}${PREFIX}/lib/alog
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
.endif
diff --git a/devel/alog/distinfo b/devel/alog/distinfo
index db4d613a61b3..c25117c2cf06 100644
--- a/devel/alog/distinfo
+++ b/devel/alog/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libalog-0.4.1.tar.bz2) = 215a763f8680c51fa7c0afc9e9c01409b743e25df7b4598aec7cf47b38095f29
-SIZE (libalog-0.4.1.tar.bz2) = 166973
+SHA256 (libalog-0.5.0.tar.bz2) = 2b49e703e5f2ce88de012482f2b8798e72ecb67c23fb10c424178688b1999380
+SIZE (libalog-0.5.0.tar.bz2) = 72000
diff --git a/devel/alog/pkg-plist b/devel/alog/pkg-plist
index 5b165baf345e..ef127d64bf7d 100644
--- a/devel/alog/pkg-plist
+++ b/devel/alog/pkg-plist
@@ -5,14 +5,8 @@ include/alog/alog-controlled_map.ads
include/alog/alog-exceptions.ads
include/alog/alog-facilities-file_descriptor.adb
include/alog/alog-facilities-file_descriptor.ads
-include/alog/alog-facilities-pgsql.adb
-include/alog/alog-facilities-pgsql.ads
-include/alog/alog-facilities-smtp.adb
-include/alog/alog-facilities-smtp.ads
include/alog/alog-facilities-syslog.adb
include/alog/alog-facilities-syslog.ads
-include/alog/alog-facilities-xmpp.adb
-include/alog/alog-facilities-xmpp.ads
include/alog/alog-facilities.adb
include/alog/alog-facilities.ads
include/alog/alog-helpers.adb
@@ -25,6 +19,8 @@ include/alog/alog-maps.adb
include/alog/alog-maps.ads
include/alog/alog-policy_db.adb
include/alog/alog-policy_db.ads
+include/alog/alog-policy_db-types.adb
+include/alog/alog-policy_db-types.ads
include/alog/alog-protected_containers.adb
include/alog/alog-protected_containers.ads
include/alog/alog-tasked_logger.adb
@@ -33,125 +29,24 @@ include/alog/alog-transforms-casing.adb
include/alog/alog-transforms-casing.ads
include/alog/alog-transforms.adb
include/alog/alog-transforms.ads
-include/alog/alog-version.ads
include/alog/alog.ads
+include/alog/glue_syslog.c
lib/alog/alog-active_logger.ali
lib/alog/alog-controlled_map.ali
lib/alog/alog-exceptions.ali
lib/alog/alog-facilities-file_descriptor.ali
-%%FULL%%lib/alog/alog-facilities-pgsql.ali
-%%FULL%%lib/alog/alog-facilities-smtp.ali
lib/alog/alog-facilities-syslog.ali
-%%FULL%%lib/alog/alog-facilities-xmpp.ali
lib/alog/alog-facilities.ali
lib/alog/alog-helpers.ali
lib/alog/alog-log_request.ali
lib/alog/alog-logger.ali
lib/alog/alog-maps.ali
lib/alog/alog-policy_db.ali
+lib/alog/alog-policy_db-types.ali
lib/alog/alog-protected_containers.ali
lib/alog/alog-tasked_logger.ali
lib/alog/alog-transforms-casing.ali
lib/alog/alog-transforms.ali
-lib/alog/alog-version.ali
lib/alog/alog.ali
lib/alog/libalog.a
lib/gnat/alog.gpr
-%%PORTDOCS%%%%DOCSDIR%%/html/CHANGELOG.html
-%%PORTDOCS%%%%DOCSDIR%%/html/README.html
-%%PORTDOCS%%%%DOCSDIR%%/html/alog-arch.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-active_logger.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-controlled_map.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-exceptions.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-facilities-file_descriptor.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-facilities-pgsql.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-facilities-smtp.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-facilities-syslog.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-facilities-xmpp.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-facilities.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-helpers.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-log_request.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-logger.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-maps.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-policy_db.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-protected_containers.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-tasked_logger.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-transforms-casing.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-transforms.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog-version.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/alog.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeA.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeB.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeC.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeD.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeF.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeG.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeH.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeI.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeK.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeL.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeM.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeN.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeO.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeP.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeR.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeT.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeU.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeV.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeW.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeX.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexeother.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexfA.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/indexsA.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-active_logger.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-controlled_map.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-exceptions.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-facilities-file_descriptor.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-facilities-pgsql.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-facilities-smtp.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-facilities-syslog.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-facilities-xmpp.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-facilities.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-helpers.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-log_request.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-logger.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-maps.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-policy_db.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-protected_containers.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-tasked_logger.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-transforms-casing.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-transforms.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog-version.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/src_alog.ads.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/docgen.css
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/docgen.js
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/arrow_close.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/arrow_open.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/generic-spec.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/link.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/menubar.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/menubarbottom.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/nav1_btn_mo.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/nav1_btn_up.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/nav2_btn_mo.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/nav2_btn_up.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/package-spec.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/rightside.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/rightsidebottom.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/sidebarframe.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/sidebarframebottom.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/subprogram-spec.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/tree_item.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/tree_root.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/treechildren_bg.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/treechildren_bg_bottom.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/type-spec.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/images/variable-spec.png
-%%PORTDOCS%%%%DOCSDIR%%/html/api/support/tags.css
-%%PORTDOCS%%%%DOCSDIR%%/html/api/toc.html
-%%PORTDOCS%%%%DOCSDIR%%/html/api/tree.html
-%%PORTDOCS%%%%DOCSDIR%%/html/asciidoc.css
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html