aboutsummaryrefslogtreecommitdiff
path: root/devel/amulet
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2001-03-11 04:57:34 +0000
committerSteve Price <steve@FreeBSD.org>2001-03-11 04:57:34 +0000
commit81dbac7e07ad49e6b48b29763e26a1bc521257af (patch)
tree3b683694a61e64a8c9d990c9cf23c16e282fc08d /devel/amulet
parent2fad275c89efe75395c55fd60fbe5f25583a9978 (diff)
downloadports-81dbac7e07ad49e6b48b29763e26a1bc521257af.tar.gz
ports-81dbac7e07ad49e6b48b29763e26a1bc521257af.zip
Use '-O0' on the Alpha so this builds without internal compiler errors.
Notes
Notes: svn path=/head/; revision=39540
Diffstat (limited to 'devel/amulet')
-rw-r--r--devel/amulet/files/Makefile.vars.gcc.FreeBSD12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/amulet/files/Makefile.vars.gcc.FreeBSD b/devel/amulet/files/Makefile.vars.gcc.FreeBSD
index 31407b989ebc..bfa30a622355 100644
--- a/devel/amulet/files/Makefile.vars.gcc.FreeBSD
+++ b/devel/amulet/files/Makefile.vars.gcc.FreeBSD
@@ -22,21 +22,27 @@ AM_CFLAGS = -I$(AMULET_DIR)/include $(X11_INC) -Wall \
AM_LIBS = $(X11_LIB) -lX11 -lm
+.if $(MACHINE_ARCH) == "alpha"
+OPT_CFLAGS = -O0
+.else
+OPT_CFLAGS = -O2
+.endif
+
##
## Parameters for the Amulet library
##
# additional compiler flags for development version
-AM_DEVELOP = -O2 -DDEBUG -g -DAMULET2_CONVERSION
+AM_DEVELOP = $(OPT_CFLAGS) -DDEBUG -g -DAMULET2_CONVERSION
# additional compiler flags for release version
-AM_RELEASE = -O2 -DAMULET2_CONVERSION
+AM_RELEASE = $(OPT_CFLAGS) -DAMULET2_CONVERSION
# additional compiler flags for optimized version with inspector and debugging enabled
AM_INHOUSE = -DDEBUG -g
# additional compiler flags for optimized version with inspector but no debugging symbols
-AM_NODEBUGSYM = -O2 -DDEBUG -DAMULET2_CONVERSION
+AM_NODEBUGSYM = $(OPT_FLAGS) -DDEBUG -DAMULET2_CONVERSION
# Flags used to build the sample programs
AM_SAMPLE_FLAGS = $(AM_NODEBUGSYM)