aboutsummaryrefslogtreecommitdiff
path: root/devel/android-tools-fastboot
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-09-26 20:25:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-09-26 20:25:57 +0000
commitd76aaa066388b7a35761a72f50f87858d870116d (patch)
tree25e1325e395dca4a264c676ffa5b2a8e2e2fc202 /devel/android-tools-fastboot
parent137926f29177accf5136523ad2145b7f00d7d60e (diff)
downloadports-d76aaa066388b7a35761a72f50f87858d870116d.tar.gz
ports-d76aaa066388b7a35761a72f50f87858d870116d.zip
devel/android-tools-*: restore CPPFLAGS support after r390135
Notes
Notes: svn path=/head/; revision=398011
Diffstat (limited to 'devel/android-tools-fastboot')
-rw-r--r--devel/android-tools-fastboot/Makefile2
-rw-r--r--devel/android-tools-fastboot/files/Makefile34
2 files changed, 20 insertions, 16 deletions
diff --git a/devel/android-tools-fastboot/Makefile b/devel/android-tools-fastboot/Makefile
index 43beb44a20c6..0a0043300427 100644
--- a/devel/android-tools-fastboot/Makefile
+++ b/devel/android-tools-fastboot/Makefile
@@ -35,7 +35,7 @@ MAKEFILE= ${FILESDIR}/Makefile
MAKE_ENV= FILESDIR="${FILESDIR}" BINDIR="${PREFIX}/bin" \
MANDIR="${PREFIX}/man/man" \
LIBPCRE="${LOCALBASE}/lib/libpcre.a"
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/fastboot \
%%BASH%%etc/bash_completion.d/fastboot \
diff --git a/devel/android-tools-fastboot/files/Makefile b/devel/android-tools-fastboot/files/Makefile
index b2830f1471b4..72eadb098245 100644
--- a/devel/android-tools-fastboot/files/Makefile
+++ b/devel/android-tools-fastboot/files/Makefile
@@ -36,7 +36,7 @@ SRCS+= init.c
SRCS+= label.c
SRCS+= label_android_property.c
SRCS+= label_file.c
-CFLAGS.init.c+= -DDARWIN # statfs
+CPPFLAGS.init.c+= -DDARWIN # statfs
.PATH: ${.CURDIR}/../libsparse
SRCS+= backed_block.c
@@ -49,21 +49,25 @@ SRCS+= sparse_read.c
.PATH: ${.CURDIR}/../libzipfile
SRCS+= centraldir.c
SRCS+= zipfile.c
-CFLAGS.centraldir.c+= -Ulseek64 # utils/Compat.h
+CPPFLAGS.centraldir.c+= -Ulseek64 # utils/Compat.h
-CFLAGS+=-D_FILE_OFFSET_BITS=64 # utils/Compat.h
-CFLAGS+=-Doff64_t=off_t
-CFLAGS+=-Dftruncate64=ftruncate
-CFLAGS+=-Dlseek64=lseek
-CFLAGS+=-Dmmap64=mmap
-CFLAGS+=-I${.CURDIR}
-CFLAGS+=-I${.CURDIR}/../include
-CFLAGS+=-I${.CURDIR}/../mkbootimg
-CFLAGS+=-I${.CURDIR}/../ext4_utils
-CFLAGS+=-I${.CURDIR}/../f2fs_utils
-CFLAGS+=-I${.CURDIR}/../libselinux/include
-CFLAGS+=-I${.CURDIR}/../libsparse/include
-CFLAGS+=${CFLAGS.${.IMPSRC:T}}
+CPPFLAGS+= -D_FILE_OFFSET_BITS=64 # utils/Compat.h
+CPPFLAGS+= -Doff64_t=off_t
+CPPFLAGS+= -Dftruncate64=ftruncate
+CPPFLAGS+= -Dlseek64=lseek
+CPPFLAGS+= -Dmmap64=mmap
+CPPFLAGS+= -I${.CURDIR}
+CPPFLAGS+= -I${.CURDIR}/../include
+CPPFLAGS+= -I${.CURDIR}/../mkbootimg
+CPPFLAGS+= -I${.CURDIR}/../ext4_utils
+CPPFLAGS+= -I${.CURDIR}/../f2fs_utils
+CPPFLAGS+= -I${.CURDIR}/../libselinux/include
+CPPFLAGS+= -I${.CURDIR}/../libsparse/include
+CPPFLAGS+= ${CPPFLAGS.${.IMPSRC:T}}
+
+.ifndef COMPILE.c
+CFLAGS+= ${CPPFLAGS}
+.endif
LDADD+= -lpcre -lusb -lz
DPADD+= ${LIBPCRE} ${LIBUSB} ${LIBZ}