aboutsummaryrefslogtreecommitdiff
path: root/devel/apr/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-29 14:04:32 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-29 14:04:32 +0000
commit0a64105e315ae88550b71deb0d1b2090303db59a (patch)
tree4073ab0990d8f0b2874f4e7f9bf66307c14c229d /devel/apr/Makefile
parentfde06f265cbf40fbb7acc0f6e091e2db3d2aed33 (diff)
downloadports-0a64105e315ae88550b71deb0d1b2090303db59a.tar.gz
ports-0a64105e315ae88550b71deb0d1b2090303db59a.zip
- silence a portlint warning(tab)
- fix pkg-plist for LDAP case - Bump PORTREVISION Added file(s): - files/patch-apr-util-1.3.2__build__apu-conf.m4 (Will be removed in 1.3.3 release) http://svn.apache.org/viewvc/apr/apr-util/branches/1.3.x/build/apu-conf.m4?r1=668323&r2=675009&pathrev=675009&view=patch PR: ports/125411 Reported by: several on ports@ Approved by: araujo (mentor)
Notes
Notes: svn path=/head/; revision=217816
Diffstat (limited to 'devel/apr/Makefile')
-rw-r--r--devel/apr/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/apr/Makefile b/devel/apr/Makefile
index 61c8e2b19101..13a15c71b6c9 100644
--- a/devel/apr/Makefile
+++ b/devel/apr/Makefile
@@ -16,6 +16,7 @@
PORTNAME= apr
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= apr
@@ -35,7 +36,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
-PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
SHLIB_MAJOR= 3
APR_UTIL_CONF_ARGS= --with-apr=../apr-${PORTVERSION} \
@@ -87,6 +88,7 @@ PKGNAMESUFFIX= -${BDB_INCLUDE_DIR:S,^${LOCALBASE}/include/,,}
.endif
.if defined(APR_UTIL_WITH_LDAP)
+PLIST_SUB+= LDAP=""
USE_OPENLDAP= yes
APR_UTIL_CONF_ARGS+= --with-ldap-include=${LOCALBASE}/include \
--with-ldap-lib=${LOCALBASE}/lib --with-ldap=ldap
@@ -95,6 +97,8 @@ PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-ldap
.else
PKGNAMESUFFIX= -ldap
.endif
+.else
+PLIST_SUB+= LDAP="@comment "
.endif
pre-extract: