aboutsummaryrefslogtreecommitdiff
path: root/devel/apr1/Makefile
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2002-03-14 16:39:26 +0000
committerOllivier Robert <roberto@FreeBSD.org>2002-03-14 16:39:26 +0000
commitbeafdedff556413bd156435068f1c2f665f9bb01 (patch)
treef4d69b0197963a2e0a2bab97d3d1bb3b07448bd5 /devel/apr1/Makefile
parentd7db143eea75c9260a0f24e7b61809e4c2f3078a (diff)
downloadports-beafdedff556413bd156435068f1c2f665f9bb01.tar.gz
ports-beafdedff556413bd156435068f1c2f665f9bb01.zip
New port of apr-devel:
The Apache Portable Runtime is a library of C data structures and routines, forming a system portability layer that covers as many operating systems as possible, including Unices, Win32, BeOS, and OS/2. This port also includes the APR-Util package, which contains some useful utilities built on top of APR. There is no apr port as it is still in development. Submitted by: Garrett Rooney <rooneg@electricjellyfish.net>
Notes
Notes: svn path=/head/; revision=56090
Diffstat (limited to 'devel/apr1/Makefile')
-rw-r--r--devel/apr1/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
new file mode 100644
index 000000000000..ba2ecba26526
--- /dev/null
+++ b/devel/apr1/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: apr-snapshot
+# Date created: 19 February 2002
+# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apr-devel
+PORTVERSION= 20020309172416
+CATEGORIES= devel
+MASTER_SITES= http://www.apache.org/dist/apr/not-released/
+DISTFILES= apr_20020309172416.tar.gz apr-util_20020309172426.tar.gz
+
+MAINTAINER= rooneg@electricjellyfish.net
+
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+ libtool:${PORTSDIR}/devel/libtool
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat
+
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}
+
+pre-fetch:
+ ${SH} pkg-install apr-devel PRE-INSTALL
+
+pre-configure:
+ (cd ${WRKDIR}/apr/ && ./buildconf)
+ (cd ${WRKDIR}/apr-util/ && ./buildconf)
+
+do-configure:
+ (cd ${WRKDIR}/apr/ && ./configure --prefix=${PREFIX})
+ (cd ${WRKDIR}/apr-util/ && ./configure --prefix=${PREFIX} --with-apr=../apr/ --with-expat=${PREFIX})
+
+do-build:
+ (cd ${WRKDIR}/apr/ && make)
+ (cd ${WRKDIR}/apr-util/ && make)
+
+do-install:
+ (cd ${WRKDIR}/apr/ && make install)
+ (cd ${WRKDIR}/apr-util/ && make install)
+
+.include <bsd.port.mk>