aboutsummaryrefslogtreecommitdiff
path: root/devel/apr
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2004-04-10 17:34:39 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2004-04-10 17:34:39 +0000
commitef8adfc71f775150af9c81fad3d1ed8dbe2ce0fe (patch)
tree48d03c29e8c20107191d152a8339b3e0ba2961c2 /devel/apr
parentc0669efed5bfc1feca96a758bf4cbe54cb51ba70 (diff)
downloadports-ef8adfc71f775150af9c81fad3d1ed8dbe2ce0fe.tar.gz
ports-ef8adfc71f775150af9c81fad3d1ed8dbe2ce0fe.zip
Unbreak port after last ade's commit.
PR: ports/65173 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=106672
Diffstat (limited to 'devel/apr')
-rw-r--r--devel/apr/Makefile33
-rw-r--r--devel/apr/files/patch-buildconf17
2 files changed, 28 insertions, 22 deletions
diff --git a/devel/apr/Makefile b/devel/apr/Makefile
index 7df8adf07407..31febb4fbac7 100644
--- a/devel/apr/Makefile
+++ b/devel/apr/Makefile
@@ -29,11 +29,12 @@ COMMENT= The Apache Group's Portability Library
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
USE_ICONV= yes
-WANT_AUTOCONF_VER= 253
+USE_AUTOCONF_VER= 257
USE_PERL5= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
LIBTOOLFILES= # none
+USE_AUTOMAKE_VER= 17
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -44,6 +45,13 @@ APR_UTIL_CONF_ARGS= --with-apr=../apr-${PORTVERSION} \
.include <bsd.port.pre.mk>
+<<<<<<< Makefile
+#.if ${OSVERSION} < 500000
+#BROKEN= "Configure fails on 4.x"
+#.endif
+
+=======
+>>>>>>> 1.37
.if defined(APR_UTIL_WITHOUT_THREADS)
CONFIGURE_ARGS+= --disable-threads
APR_UTIL_CONF_ARGS+= --disable-threads
@@ -76,6 +84,8 @@ PKGNAMESUFFIX= -db4
.endif
.endif
+LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${USE_LIBTOOL_VER}.m4
+
pre-extract:
@${ECHO_MSG} ""
.if defined(APR_UTIL_WITHOUT_THREADS)
@@ -117,14 +127,15 @@ post-extract:
${LN} -s apr-util-APU_0_9_BRANCH apr-util-${PORTVERSION}
pre-configure:
- cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} ./buildconf
+ ${DO_NADA}
+
+run-autotools:
+ cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
- ${SH} ./buildconf \
+ ${SETENV} ${SCRIPTS_EV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
-
-run-autotools:
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
cd ${WRKDIR}/apr-util-${PORTVERSION}; \
@@ -142,4 +153,16 @@ do-install:
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${MAKE_ENV} ${GMAKE} install
cd ${WRKDIR}/apr-util-${PORTVERSION}; ${SETENV} ${MAKE_ENV} ${GMAKE} install
+debug_autoconf:
+ @echo "LIBTOOL: ${LIBTOOL_VERSION}"
+ @echo "AUTOCONF: dev ${dev_acver} cur ${cur_acver} use ${use_acver}"
+ @echo "AUTOMAKE: dev ${dev_amver} cur ${cur_amver} use ${use_amver}"
+ @echo "AUTOCONF_DIR: ${AUTOCONF_DIR}"
+ @echo "BUILD_DEPENDS: ${BUILD_DEPENDS}"
+ @echo "ACLOCAL_DIR: ${ACLOCAL_DIR}"
+ @echo "LIBTOOLFILES: ${LIBTOOLFILES}"
+ @echo "LIBTOOL_SHAREDIR: ${LIBTOOL_SHAREDIR}"
+ @echo "LIBTOOL_LIBEXECDIR: ${LIBTOOL_LIBEXECDIR}"
+ @echo "LIBTOOL_M4: ${LIBTOOL_M4}"
+
.include <bsd.port.post.mk>
diff --git a/devel/apr/files/patch-buildconf b/devel/apr/files/patch-buildconf
deleted file mode 100644
index b4aab3e2d063..000000000000
--- a/devel/apr/files/patch-buildconf
+++ /dev/null
@@ -1,17 +0,0 @@
---- apr-0.9.4/buildconf.orig Tue Jun 17 13:44:25 2003
-+++ apr-0.9.4/buildconf Tue Mar 23 21:53:36 2004
-@@ -83,3 +83,3 @@
- ltpath=`dirname $libtoolize`
--ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/libtool.m4}
-+ltfile=${LIBTOOL_M4-`cd $ltpath/../../share/aclocal ; pwd`/libtool15.m4}
-
-@@ -102,3 +102,3 @@
- echo "Creating include/arch/unix/apr_private.h.in ..."
--${AUTOHEADER:-autoheader}
-+${AUTOHEADER:-autoheader257}
-
-@@ -106,3 +106,3 @@
- ### do some work to toss config.cache?
--${AUTOCONF:-autoconf}
-+${AUTOCONF:-autoconf257}
-