aboutsummaryrefslogtreecommitdiff
path: root/devel/arcanist
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2015-07-15 10:16:35 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2015-07-15 10:16:35 +0000
commitb2868001dcbee10e61c3ae0e674c0ce5ba384ad5 (patch)
tree56ad0fc29b864a744f50a13054d74d0a05a3f497 /devel/arcanist
parent5012d294a8a17101863431f9c5f72de1e0c38bd1 (diff)
downloadports-b2868001dcbee10e61c3ae0e674c0ce5ba384ad5.tar.gz
ports-b2868001dcbee10e61c3ae0e674c0ce5ba384ad5.zip
Patch 'arc version' so it shows package versions.
Differential Revision: https://reviews.freebsd.org/D3071 Approved by: eadler, mentors (implicit)
Notes
Notes: svn path=/head/; revision=392125
Diffstat (limited to 'devel/arcanist')
-rw-r--r--devel/arcanist/Makefile1
-rw-r--r--devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php16
2 files changed, 17 insertions, 0 deletions
diff --git a/devel/arcanist/Makefile b/devel/arcanist/Makefile
index 3a378fd1ffe7..af4f3c71db30 100644
--- a/devel/arcanist/Makefile
+++ b/devel/arcanist/Makefile
@@ -2,6 +2,7 @@
PORTNAME= arcanist
PORTVERSION= 20150626
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= php5-
diff --git a/devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php b/devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php
new file mode 100644
index 000000000000..20a5214006b4
--- /dev/null
+++ b/devel/arcanist/files/patch-src-workflow-ArcanistVersionWorkflow.php
@@ -0,0 +1,16 @@
+--- src/workflow/ArcanistVersionWorkflow.php.orig 2015-07-14 00:07:20.409019999 +0200
++++ src/workflow/ArcanistVersionWorkflow.php 2015-07-14 00:27:09.586063998 +0200
+@@ -27,6 +27,13 @@
+ public function run() {
+ $console = PhutilConsole::getConsole();
+
++ $versions = array();
++ exec("pkg query '%n %v (%o)' php5-arcanist php5-libphutil", $versions);
++ foreach ($versions as $pkg) {
++ $console->writeOut($pkg."\n");
++ }
++ return;
++
+ if (!Filesystem::binaryExists('git')) {
+ throw new ArcanistUsageException(
+ pht(