aboutsummaryrefslogtreecommitdiff
path: root/devel/argouml/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-09-01 20:44:53 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-09-01 20:44:53 +0000
commit913f56da81db9e1b92e4731679c88f8004389490 (patch)
treef2f25242bca68885de506b7e6645254c52f21233 /devel/argouml/Makefile
parent509cdc26e44774af89493655cb89aa054bedb9d5 (diff)
downloadports-913f56da81db9e1b92e4731679c88f8004389490.tar.gz
ports-913f56da81db9e1b92e4731679c88f8004389490.zip
. Update to 0.18.1.
. Install the documentation (manual). Approved by: maintainer timeout (3 weeks)
Notes
Notes: svn path=/head/; revision=141731
Diffstat (limited to 'devel/argouml/Makefile')
-rw-r--r--devel/argouml/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/devel/argouml/Makefile b/devel/argouml/Makefile
index 75de9e13cbf2..08444016fe80 100644
--- a/devel/argouml/Makefile
+++ b/devel/argouml/Makefile
@@ -7,10 +7,15 @@
#
PORTNAME= argouml
-PORTVERSION= 0.16.1
+PORTVERSION= 0.18.1
CATEGORIES= devel java
MASTER_SITES= http://argouml.tigris.org/files/documents/4/0/argouml-${PORTVERSION}/
DISTNAME= ArgoUML-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+.if !defined(NOPORTDOCS)
+DISTFILES+= argomanual-${PORTVERSION}.pdf
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
MAINTAINER= philip.reynolds@rfc-networks.ie
COMMENT= A UML design tool with cognitive support
@@ -20,13 +25,20 @@ RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.4+
SUB_FILES= argouml.sh
+.if !defined(NOPORTDOCS)
+PORTDOCS= argomanual-${PORTVERSION}.pdf
+.endif
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/argouml.sh ${PREFIX}/bin/argouml
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.jar ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/argomanual-${PORTVERSION}.pdf ${DOCSDIR}
+.endif
.include <bsd.port.mk>