aboutsummaryrefslogtreecommitdiff
path: root/devel/asmutils/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-10 21:32:47 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-10 21:32:47 +0000
commit51cac8b9b02f01aa0fe06edb1789698620183458 (patch)
tree2f00c403df35798ec55c8cfe861eb201968f1fe0 /devel/asmutils/Makefile
parent0aabf2b10560ced78e46ee0d8f3a5aa349733227 (diff)
downloadports-51cac8b9b02f01aa0fe06edb1789698620183458.tar.gz
ports-51cac8b9b02f01aa0fe06edb1789698620183458.zip
Add asmutils 0.13, a set of UNIX utilities written in assembly
language. PR: 24519 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Notes
Notes: svn path=/head/; revision=39472
Diffstat (limited to 'devel/asmutils/Makefile')
-rw-r--r--devel/asmutils/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
new file mode 100644
index 000000000000..e6d3a075a44d
--- /dev/null
+++ b/devel/asmutils/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: asmutils
+# Date created: 22 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asmutils
+PORTVERSION= 0.13
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.linuxassembly.org/pub/asm/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+
+ONLY_FOR_ARCHS= i386
+
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= ${PREFIX}/lib/asmutils
+
+# This will play merry hell with portlint
+BINARIES= cat basename chmod chroot chown cp cpuinfo dirname echo \
+ env id extname factor grep head hostname httpd kill ln ls \
+ lzss mkdir more mv nc pwd renice rm sh sleep strings sync \
+ tee true uname wc yes md5sum rmdsum rc6crypt execve report \
+ asmutils domainname sln rmdir false arch cpuspeed regs
+
+DOCFILES= Asmutils-HOWTO acknowledgements endorsements history \
+ index s-contrib s-debug s-include s-layout s-optimize
+
+post-patch:
+ @(${SED} -e 's,%%KERNEL%%,${OSREL:S/.//g},g' ${WRKSRC}/MCONFIG > foo \
+ && ${MV} foo ${WRKSRC}/MCONFIG)
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin/asmutils
+ ${MKDIR} ${PREFIX}/lib/asmutils
+.for B in ${BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/$B ${PREFIX}/bin/asmutils
+.endfor
+.for L in c crypto m
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/lib$L.so.0 ${PREFIX}/lib/asmutils
+ ${INSTALL_DATA} ${WRKSRC}/lib/lib$L.a ${PREFIX}/lib/asmutils
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/asmutils
+.for D in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/$D.html ${PREFIX}/share/doc/asmutils
+.endfor
+.endif
+
+.include <bsd.port.mk>