aboutsummaryrefslogtreecommitdiff
path: root/devel/asmutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-05-21 16:37:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-05-21 16:37:00 +0000
commit40f8bcbdeecec2f19aa693d96ac198c553ca8a68 (patch)
tree5b090157fef183f42d1d7b289328ffde5ec3262c /devel/asmutils
parente5cd15143479aad5a772a3c212c8d687ab7f9bb6 (diff)
downloadports-40f8bcbdeecec2f19aa693d96ac198c553ca8a68.tar.gz
ports-40f8bcbdeecec2f19aa693d96ac198c553ca8a68.zip
- Unbreak with recent nasm: starting with v2.07, nasm has a regression that
prevents certain macros from expanding correctly, and the build woes - Clean up Makefile while here: fix line wraps, reorder knobs, simplify PORTDOCS handling Bug ID (nasm@sf.net tracker): 3005117 Fix suggested by: Frank Kotler
Notes
Notes: svn path=/head/; revision=254742
Diffstat (limited to 'devel/asmutils')
-rw-r--r--devel/asmutils/Makefile39
1 files changed, 17 insertions, 22 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index d4e12119b03b..d61095d28806 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -13,36 +13,31 @@ MASTER_SITES= http://asm.sourceforge.net/asmutils/
MAINTAINER= danfe@FreeBSD.org
COMMENT= A set of UNIX utilities written in assembly language
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-
-BROKEN= does not install
ONLY_FOR_ARCHS= i386
-USE_GMAKE= yes
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+USE_GMAKE= yes
USE_LDCONFIG= yes
LDCONFIG_DIRS= ${PREFIX}/lib/asmutils
# This will play merry hell with portlint
BINS= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
- cpuinfo cut date dc dd deflate dirname du echo env bonus/execve \
- extname factor fromdos ftpd getty grep head hexdump host hostname \
- httpd id idea init kill kldload less ln ls lzss m_inetd md5 \
- md5sum mkdir mknod mount mv nc netstat nice nm nohup od \
- paste ping pop3d proxy pwd rc6crypt readelf readkey readlink \
- reboot renice bonus/report rm rmdsum rot13 scan scons sh sha1sum \
- sleep strings sync tail tar tee telnet telnetd test touch tr \
- true uname uuencode watch wc wget which whoami write yes
+ cpuinfo cut date dc dd deflate dirname du echo env \
+ bonus/execve extname factor fromdos ftpd getty grep head \
+ hexdump host hostname httpd id idea init kill kldload less \
+ ln ls lzss m_inetd md5 md5sum mkdir mknod mount mv nc \
+ netstat nice nm nohup od paste ping pop3d proxy pwd rc6crypt \
+ readelf readkey readlink reboot renice bonus/report rm \
+ rmdsum rot13 scan scons sh sha1sum sleep strings sync tail \
+ tar tee telnet telnetd test touch tr true uname uuencode \
+ watch wc wget which whoami write yes
LINKS= arch cpuspeed domainname false halt inflate kldstat kldunload \
mkfifo more poweroff regs rmdir size sln todos umount usleep
LIBS= libc.so.0 libcrypto.so.0 libm.so.0
-DOCS= Asmutils-HOWTO.html acknowledgements.html endorsements.html \
- history.html s-contrib.html s-debug.html s-include.html \
- s-layout.html s-optimize.html sha1sum.html sha1sum_toc.html
-
PLIST_FILES= ${BINS:S/^/bin\/asmutils\//:S/bonus\///} \
${LINKS:S/^/bin\/asmutils\//} ${LIBS:S/^/lib\/asmutils\//}
PLIST_DIRS= bin/asmutils lib/asmutils
@@ -51,13 +46,15 @@ PORTDOCS= *
post-patch:
@${REINPLACE_CMD} -e 's,%%KERNEL%%,${OSREL:S/.//g},g' ${WRKSRC}/MCONFIG
@${REINPLACE_CMD} -e 's,^static ,,' ${WRKSRC}/lib/libm.c
+# Workaround for broken macro local labels in nasm v2.07+
+ @${REINPLACE_CMD} -e 's,%{$$strucname},&%+,' ${WRKSRC}/inc/elf.inc \
+ ${WRKSRC}/inc/system.inc
# Stripping binaries will break install
STRIP= #
do-install:
- @${MKDIR} ${PREFIX}/bin/asmutils
- @${MKDIR} ${PREFIX}/lib/asmutils
+ @${MKDIR} ${PREFIX}/bin/asmutils ${PREFIX}/lib/asmutils
.for B in ${BINS}
${INSTALL_PROGRAM} ${WRKSRC}/src/${B} ${PREFIX}/bin/asmutils
.endfor
@@ -86,10 +83,8 @@ do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for D in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${D} ${DOCSDIR}
-.endfor
- cd ${DOCSDIR} && ${LN} -sf Asmutils-HOWTO.html index.html
+ ${INSTALL_DATA} ${WRKSRC}/doc/[^i]* ${DOCSDIR}
+ @cd ${DOCSDIR} && ${LN} -sf Asmutils-HOWTO.html index.html
.endif
.include <bsd.port.mk>