aboutsummaryrefslogtreecommitdiff
path: root/devel/asmutils
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-07 17:24:16 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-07 17:24:16 +0000
commite023b6a5a5fb96b13ba15eb695a646a1004a381f (patch)
tree373683d9f6f977302cc0156b2d090087485ae31a /devel/asmutils
parent3b8591d72d5080e5b238ddd22d1470858d8dade8 (diff)
downloadports-e023b6a5a5fb96b13ba15eb695a646a1004a381f.tar.gz
ports-e023b6a5a5fb96b13ba15eb695a646a1004a381f.zip
update to asmutils-0.17, keep up with nasm-0.98.38, and unbreak this port.
Notes
Notes: svn path=/head/; revision=100266
Diffstat (limited to 'devel/asmutils')
-rw-r--r--devel/asmutils/Makefile24
-rw-r--r--devel/asmutils/distinfo4
-rw-r--r--devel/asmutils/files/patch-MCONFIG22
-rw-r--r--devel/asmutils/pkg-plist14
4 files changed, 27 insertions, 37 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index f19fd2f26f8f..2fa99ecaaf31 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= asmutils
-PORTVERSION= 0.14
-PORTREVISION= 1
+PORTVERSION= 0.17
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= http://linuxassembly.org/asmutils/
@@ -30,14 +30,9 @@ BINARIES= asmutils basename cat chmod chown chroot cp cpuinfo date \
mkdir more mv nc ping pwd rc6crypt renice report rm rmdsum \
sh sleep strings sync tee true uname wc yes
-DOCFILES= Asmutils-HOWTO acknowledgements endorsements history \
- index s-contrib s-debug s-include s-layout s-optimize
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
+PORTDOCS= Asmutils-HOWTO.html acknowledgements.html endorsements.html \
+ history.html index.html s-contrib.html s-debug.html \
+ s-include.html s-layout.html s-optimize.html
post-patch:
@(${SED} -e 's,%%KERNEL%%,${OSREL:S/.//g},g' ${WRKSRC}/MCONFIG > ${WRKDIR}/foo \
@@ -59,13 +54,12 @@ do-install:
${LN} -sf ln sln)
.for L in c crypto m
${INSTALL_PROGRAM} ${WRKSRC}/lib/lib$L.so.0 ${PREFIX}/lib/asmutils
- ${INSTALL_DATA} ${WRKSRC}/lib/lib$L.a ${PREFIX}/lib/asmutils
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/asmutils
-.for D in ${DOCFILES}
- ${INSTALL_DATA} ${WRKSRC}/doc/$D.html ${PREFIX}/share/doc/asmutils
+ ${MKDIR} ${DOCSDIR}
+.for D in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/$D ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/asmutils/distinfo b/devel/asmutils/distinfo
index 0dde3265be7a..e32204e48c9e 100644
--- a/devel/asmutils/distinfo
+++ b/devel/asmutils/distinfo
@@ -1,2 +1,2 @@
-MD5 (asmutils-0.14.tar.gz) = 9fac89195bc43e38224695e11f27ba10
-SIZE (asmutils-0.14.tar.gz) = 180226
+MD5 (asmutils-0.17.tar.gz) = 9027cff8f8f50cf4fa9b0e62fc4a8854
+SIZE (asmutils-0.17.tar.gz) = 332675
diff --git a/devel/asmutils/files/patch-MCONFIG b/devel/asmutils/files/patch-MCONFIG
index 274c24850911..25ea1fdd8883 100644
--- a/devel/asmutils/files/patch-MCONFIG
+++ b/devel/asmutils/files/patch-MCONFIG
@@ -1,15 +1,25 @@
---- MCONFIG.orig Sat Mar 10 21:03:55 2001
-+++ MCONFIG Sat Mar 10 21:04:12 2001
-@@ -12,11 +12,11 @@
-
- # Target Operating System (LINUX/FREEBSD/NETBSD/OPENBSD/BEOS/ATHEOS/LIBC)
+--- MCONFIG.orig Fri Mar 15 01:42:46 2002
++++ MCONFIG Sun Feb 8 01:06:18 2004
+@@ -13,11 +13,11 @@
+ # Target operating system. Valid values are:
+ # LINUX FREEBSD OPENBSD NETBSD SOLARIS UNIXWARE BEOS ATHEOS
-OS = LINUX
+OS = FREEBSD
- # Kernel version (1.2 = 12, 2.4 = 24, 3.6 = 36, etc)
+ # Kernel version of target OS (1.2 = 12, 2.4 = 24, 3.6 = 36, etc)
-KERNEL = 24
+KERNEL = %%KERNEL%%
# Optimization method (SIZE/SPEED)
+
+@@ -93,7 +93,7 @@
+
+ ASVER := $(shell $(AS) -r | cut -d ' ' -f 3)
+ #LDVER := $(shell $(LD) -v | cut -d ' ' -f 4)
+-CORRECT_ASVER = 0.98
++CORRECT_ASVER = 0.98.38
+
+ #
+ # avoid using asmutils during the build process if PATH has '.'
diff --git a/devel/asmutils/pkg-plist b/devel/asmutils/pkg-plist
index 5e597d906587..867ee55073f6 100644
--- a/devel/asmutils/pkg-plist
+++ b/devel/asmutils/pkg-plist
@@ -53,22 +53,8 @@ bin/asmutils/true
bin/asmutils/uname
bin/asmutils/wc
bin/asmutils/yes
-lib/asmutils/libc.a
lib/asmutils/libc.so.0
-lib/asmutils/libcrypto.a
lib/asmutils/libcrypto.so.0
-lib/asmutils/libm.a
lib/asmutils/libm.so.0
-%%PORTDOCS%%share/doc/asmutils/Asmutils-HOWTO.html
-%%PORTDOCS%%share/doc/asmutils/acknowledgements.html
-%%PORTDOCS%%share/doc/asmutils/endorsements.html
-%%PORTDOCS%%share/doc/asmutils/history.html
-%%PORTDOCS%%share/doc/asmutils/index.html
-%%PORTDOCS%%share/doc/asmutils/s-contrib.html
-%%PORTDOCS%%share/doc/asmutils/s-debug.html
-%%PORTDOCS%%share/doc/asmutils/s-include.html
-%%PORTDOCS%%share/doc/asmutils/s-layout.html
-%%PORTDOCS%%share/doc/asmutils/s-optimize.html
-%%PORTDOCS%%@dirrm share/doc/asmutils
@dirrm lib/asmutils
@dirrm bin/asmutils