aboutsummaryrefslogtreecommitdiff
path: root/devel/autoconf257
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-05-31 22:14:42 +0000
committerAde Lovett <ade@FreeBSD.org>2001-05-31 22:14:42 +0000
commitd0db855ae03644a32313825afc166157e2b9c400 (patch)
tree43de479826bb3edc3438ff094f6910b0bfcdb74e /devel/autoconf257
parent313e762e51d7f6e5ad8bb23aad80936976525092 (diff)
downloadports-d0db855ae03644a32313825afc166157e2b9c400.tar.gz
ports-d0db855ae03644a32313825afc166157e2b9c400.zip
Finally nail the nasty autoconf habit of leaving ${TMPDIR}/acin.*
turds lying around in certain circumstances.
Notes
Notes: svn path=/head/; revision=43363
Diffstat (limited to 'devel/autoconf257')
-rw-r--r--devel/autoconf257/Makefile1
-rw-r--r--devel/autoconf257/files/patch-ad27
2 files changed, 17 insertions, 11 deletions
diff --git a/devel/autoconf257/Makefile b/devel/autoconf257/Makefile
index cf7c01fc44db..2fa096871a1b 100644
--- a/devel/autoconf257/Makefile
+++ b/devel/autoconf257/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoconf
PORTVERSION= 2.13
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= autoconf
diff --git a/devel/autoconf257/files/patch-ad b/devel/autoconf257/files/patch-ad
index 4d5742be10e5..20401d060f61 100644
--- a/devel/autoconf257/files/patch-ad
+++ b/devel/autoconf257/files/patch-ad
@@ -1,21 +1,26 @@
--- autoconf.sh.orig Tue Jan 5 07:27:53 1999
-+++ autoconf.sh Wed Feb 16 11:17:50 2000
-@@ -45,7 +45,6 @@
- esac
-
++++ autoconf.sh Thu May 31 15:56:39 2001
+@@ -47,3 +47,2 @@
: ${TMPDIR=/tmp}
-tmpout=${TMPDIR}/acout.$$
localdir=
- show_version=no
-
-@@ -97,7 +96,9 @@
+@@ -97,5 +96,8 @@
++tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
++tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
++
trap 'rm -f $tmpin $tmpout; exit 1' 1 2 15
-tmpin=${TMPDIR}/acin.$$ # Always set this, to avoid bogus errors from some rm's.
-+tmpout=`mktemp ${TMPDIR}/acout.XXXXXXXXXX` || exit 1
-+tmpin=`mktemp ${TMPDIR}/acin.XXXXXXXXXX` || { rm -f $tmpout; exit 1; }
+# Always set this, to avoid bogus errors from some rm's.
if test z$infile = z-; then
- infile=$tmpin
- cat > $infile
+@@ -120,3 +122,3 @@
+ *traditional*) ;;
+-*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin; exit 1 ;;
++*) echo Autoconf requires GNU m4 1.1 or later >&2; rm -f $tmpin $tmpout; exit 1 ;;
+ esac
+@@ -156,3 +158,3 @@
+
+-rm -f $tmpout
++rm -f $tmpin $tmpout
+