aboutsummaryrefslogtreecommitdiff
path: root/devel/automake110/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2003-06-29 01:58:53 +0000
committerAde Lovett <ade@FreeBSD.org>2003-06-29 01:58:53 +0000
commitf20d630fa64b92750043aaa96a579fa7ddcc4082 (patch)
tree8bae99ee5b103dbb29512bc3ebf1e47cdd2b8228 /devel/automake110/Makefile
parent85e8ed21ea7377174b1d691dff4eeee35ce53dd8 (diff)
downloadports-f20d630fa64b92750043aaa96a579fa7ddcc4082.tar.gz
ports-f20d630fa64b92750043aaa96a579fa7ddcc4082.zip
Use the cosmetic BUILD_VERSION variable (a la libtool), switch portnames
away from using the version number twice. Unbreak automake17, base on work from Rui Lopes <rui@ruilopes.com>
Notes
Notes: svn path=/head/; revision=83800
Diffstat (limited to 'devel/automake110/Makefile')
-rw-r--r--devel/automake110/Makefile40
1 files changed, 18 insertions, 22 deletions
diff --git a/devel/automake110/Makefile b/devel/automake110/Makefile
index bff17961e46e..babd4fff2357 100644
--- a/devel/automake110/Makefile
+++ b/devel/automake110/Makefile
@@ -5,9 +5,8 @@
# $FreeBSD$
#
-PORTNAME= automake17
-PORTVERSION= 1.7.2
-PORTEPOCH= 1
+PORTNAME= automake
+PORTVERSION= 1.7.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= automake
@@ -16,15 +15,20 @@ DISTNAME= automake-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
COMMENT= GNU automake generates input files for GNU autoconf
-BROKEN= Needs at least autoconf 254 to build.
+BUILD_DEPENDS= autoconf257:${PORTSDIR}/devel/autoconf257
+RUN_DEPENDS= autoconf257:${PORTSDIR}/devel/autoconf257
+BUILD_VERSION= -1.7
+PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
+LATEST_LINK= automake${BUILD_VERSION}
+USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PERL=${PERL5}
+CONFIGURE_ENV= AUTOCONF=autoconf257 AUTOHEADER=autoheader257
+CONFIGURE_ARGS= --program-suffix=${BUILD_VERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
-STRIP= # none
-
.if defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
pre-everything::
@${ECHO} ===========================================================
@@ -35,20 +39,12 @@ pre-everything::
@${FALSE}
.endif # defined(USE_AUTOMAKE) || defined(USE_AUTOMAKE_VER)
-pre-configure:
- @${REINPLACE_CMD} -i -e "s,%%X11BASE%%,${X11BASE}," \
- ${WRKSRC}/aclocal.in
-
-pre-install:
- ${RM} -fr ${PREFIX}/libexec/automake17
- ${MKDIR} ${PREFIX}/libexec/automake17
-
-post-install:
-.for i in aclocal automake
- ${LN} -sf ${PREFIX}/bin/${i}17 \
- ${PREFIX}/libexec/automake17/${i}
-.endfor
- @install-info ${PREFIX}/info/automake17.info \
- ${PREFIX}/info/dir
+post-patch:
+ @(cd ${WRKSRC} && \
+ ${RM} -f *.info && \
+ ${MV} automake.texi automake${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(automake)\.(info),\1${BUILD_VERSION}\.\2,g' automake${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(automake)\.(info|texi),\1${BUILD_VERSION}\.\2,g ; \
+ s,^.+ install-exec-hook$$,,' Makefile.in)
.include <bsd.port.mk>