aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc-3
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2006-04-20 20:32:32 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2006-04-20 20:32:32 +0000
commit39b22ee0a41b2ccd31d0e139557ee9d0a52fd37c (patch)
tree35d658c9d9ab290674426fe718f80b53cc8a79c1 /devel/avr-gcc-3
parentb9c8c770e14ff195ebb24ed603bdb6fadcc973c2 (diff)
downloadports-39b22ee0a41b2ccd31d0e139557ee9d0a52fd37c.tar.gz
ports-39b22ee0a41b2ccd31d0e139557ee9d0a52fd37c.zip
Fix the link specification in the patch so ATmega*P devices will get
their correct -Tdata option passed down. Submitted by: Anatoly Sokolov
Notes
Notes: svn path=/head/; revision=160042
Diffstat (limited to 'devel/avr-gcc-3')
-rw-r--r--devel/avr-gcc-3/Makefile2
-rw-r--r--devel/avr-gcc-3/files/patch-newdevices2
2 files changed, 2 insertions, 2 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 3b1acd87cd56..a3f0908eeccd 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 3.4.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc-3/files/patch-newdevices b/devel/avr-gcc-3/files/patch-newdevices
index 30f86a8a2bd4..6a3954d0f273 100644
--- a/devel/avr-gcc-3/files/patch-newdevices
+++ b/devel/avr-gcc-3/files/patch-newdevices
@@ -88,7 +88,7 @@ diff -ur ../gcc-3.4.6.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
-%{mmcu=atmega64|mmcu=atmega128|mmcu=atmega162|mmcu=atmega169: -Tdata 0x800100} "
+%{mmcu=atmega8*|mmcu=atmega48|mmcu=at90pwm*:-m avr4}\
+%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega406|mmcu=atmega64*|mmcu=atmega128*|mmcu=at90can*|mmcu=at90usb*|mmcu=at94k:-m avr5}\
-+%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
++%{mmcu=atmega324*|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644*|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164*|mmcu=atmega165*|mmcu=atmega168|mmcu=atmega169*|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
+%{mmcu=atmega640|mmcu=atmega1280|mmcu=atmega1281: -Tdata 0x800200} "
/* A C string constant that tells the GCC driver program options to