aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2007-06-23 21:30:40 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2007-06-23 21:30:40 +0000
commit16aee5cd101facfd4470fdee123e061bb80f9124 (patch)
tree76d5b0428548a85818571d5079a63a0d9d4ea482 /devel/avr-gcc
parent0a2993d06e14d9003c531991783adbc45e521c93 (diff)
downloadports-16aee5cd101facfd4470fdee123e061bb80f9124.tar.gz
ports-16aee5cd101facfd4470fdee123e061bb80f9124.zip
Add device support for ATmega8HVA/ATmega16HVA.
Change AT90USB82 from avr5 to avr5.
Notes
Notes: svn path=/head/; revision=194141
Diffstat (limited to 'devel/avr-gcc')
-rw-r--r--devel/avr-gcc/Makefile2
-rw-r--r--devel/avr-gcc/files/patch-newdevices28
-rw-r--r--devel/avr-gcc/files/patch-zz-atmega256x4
-rw-r--r--devel/avr-gcc/pkg-descr2
4 files changed, 22 insertions, 14 deletions
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 9eede0b19956..ac030e25d664 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 4.1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc/files/patch-newdevices b/devel/avr-gcc/files/patch-newdevices
index e6db84f603ab..32a3f677317e 100644
--- a/devel/avr-gcc/files/patch-newdevices
+++ b/devel/avr-gcc/files/patch-newdevices
@@ -1,5 +1,5 @@
--- gcc/config/avr/avr.c.orig Thu Jul 28 00:29:46 2005
-+++ gcc/config/avr/avr.c Sat Apr 7 00:34:02 2007
++++ gcc/config/avr/avr.c Mon May 14 07:18:20 2007
@@ -169,10 +169,19 @@
{ "at90s8515", 2, "__AVR_AT90S8515__" },
{ "at90c8534", 2, "__AVR_AT90C8534__" },
@@ -21,14 +21,14 @@
/* Classic, > 8K. */
{ "avr3", 3, NULL },
{ "atmega103", 3, "__AVR_ATmega103__" },
-@@ -187,24 +196,53 @@
+@@ -187,24 +196,55 @@
{ "atmega88", 4, "__AVR_ATmega88__" },
{ "atmega8515", 4, "__AVR_ATmega8515__" },
{ "atmega8535", 4, "__AVR_ATmega8535__" },
++ { "atmega8hva", 4, "__AVR_ATmega8HVA__" },
+ { "at90pwm1", 4, "__AVR_AT90PWM1__" },
+ { "at90pwm2", 4, "__AVR_AT90PWM2__" },
+ { "at90pwm3", 4, "__AVR_AT90PWM3__" },
-+ { "at90usb82", 4, "__AVR_AT90USB82__" },
/* Enhanced, > 8K. */
{ "avr5", 5, NULL },
{ "atmega16", 5, "__AVR_ATmega16__" },
@@ -64,8 +64,10 @@
{ "atmega128", 5, "__AVR_ATmega128__" },
+ { "atmega1280",5, "__AVR_ATmega1280__" },
+ { "atmega1281",5, "__AVR_ATmega1281__" },
++ { "atmega16hva",5, "__AVR_ATmega16HVA__" },
+ { "at90can32", 5, "__AVR_AT90CAN32__" },
+ { "at90can64", 5, "__AVR_AT90CAN64__" },
++ { "at90usb82", 5, "__AVR_AT90USB82__" },
{ "at90can128", 5, "__AVR_AT90CAN128__" },
+ { "at90usb162", 5, "__AVR_AT90USB162__" },
+ { "at90usb646", 5, "__AVR_AT90USB646__" },
@@ -76,8 +78,8 @@
/* Assembler only. */
{ "avr1", 1, NULL },
--- gcc/config/avr/t-avr.orig Wed Apr 6 07:34:30 2005
-+++ gcc/config/avr/t-avr Sat Apr 7 00:37:08 2007
-@@ -42,21 +42,62 @@
++++ gcc/config/avr/t-avr Mon May 14 07:16:32 2007
+@@ -42,21 +42,64 @@
# The many avr2 matches are not listed here - this is the default.
MULTILIB_MATCHES = \
@@ -98,6 +100,7 @@
- mmcu?avr5=mmcu?atmega161 mmcu?avr5=mmcu?atmega162 \
- mmcu?avr5=mmcu?atmega163 mmcu?avr5=mmcu?atmega169 \
- mmcu?avr5=mmcu?atmega16 mmcu?avr5=mmcu?atmega168 \
++ mmcu?avr4=mmcu?atmega8hva \
+ mmcu?avr4=mmcu?at90pwm1 \
+ mmcu?avr4=mmcu?at90pwm2 \
+ mmcu?avr4=mmcu?at90pwm3 \
@@ -140,6 +143,7 @@
+ mmcu?avr5=mmcu?atmega128 \
+ mmcu?avr5=mmcu?atmega1280 \
+ mmcu?avr5=mmcu?atmega1281 \
++ mmcu?avr5=mmcu?atmega16hva \
+ mmcu?avr5=mmcu?at90can32 \
+ mmcu?avr5=mmcu?at90can64 \
+ mmcu?avr5=mmcu?at90can128 \
@@ -152,9 +156,9 @@
MULTILIB_EXCEPTIONS =
---- gcc/config/avr/avr.h.orig Wed Apr 11 17:36:15 2007
-+++ gcc/config/avr/avr.h Wed Apr 11 17:41:25 2007
-@@ -763,12 +763,67 @@
+--- gcc/config/avr/avr.h.orig Mon May 14 07:12:25 2007
++++ gcc/config/avr/avr.h Mon May 14 07:15:46 2007
+@@ -763,12 +763,69 @@
#define ASM_SPEC "%{mmcu=*:-mmcu=%*}"
#define LINK_SPEC " %{!mmcu*:-m avr2}\
@@ -219,6 +223,8 @@
+ mmcu=atmega165*|\
+ mmcu=atmega168|\
+ mmcu=atmega169*|\
++ mmcu=atmega8hva|\
++ mmcu=atmega16hva|\
+ mmcu=at90can*|\
+ mmcu=at90pwm*|\
+ mmcu=at90usb*: -Tdata 0x800100}\
@@ -228,7 +234,7 @@
#define LIB_SPEC \
"%{!mmcu=at90s1*:%{!mmcu=attiny11:%{!mmcu=attiny12:%{!mmcu=attiny15:%{!mmcu=attiny28: -lc }}}}}"
-@@ -804,6 +859,15 @@
+@@ -804,6 +861,15 @@
%{mmcu=at86rf401:crt86401.o%s} \
%{mmcu=attiny13:crttn13.o%s} \
%{mmcu=attiny2313:crttn2313.o%s} \
@@ -244,7 +250,7 @@
%{mmcu=atmega103|mmcu=avr3:crtm103.o%s} \
%{mmcu=atmega603:crtm603.o%s} \
%{mmcu=at43usb320:crt43320.o%s} \
-@@ -814,22 +878,51 @@
+@@ -814,22 +880,53 @@
%{mmcu=atmega88:crtm88.o%s} \
%{mmcu=atmega8515:crtm8515.o%s} \
%{mmcu=atmega8535:crtm8535.o%s} \
@@ -285,6 +291,8 @@
%{mmcu=atmega128:crtm128.o%s} \
+%{mmcu=atmega1280:crtm1280.o%s} \
+%{mmcu=atmega1281:crtm1281.o%s} \
++%{mmcu=atmega8hva:crtm8hva.o%s} \
++%{mmcu=atmega16hva:crtm16hva.o%s} \
+%{mmcu=at90can32:crtcan32.o%s} \
+%{mmcu=at90can64:crtcan64.o%s} \
%{mmcu=at90can128:crtcan128.o%s} \
diff --git a/devel/avr-gcc/files/patch-zz-atmega256x b/devel/avr-gcc/files/patch-zz-atmega256x
index b096badd2a5f..f4af252afa38 100644
--- a/devel/avr-gcc/files/patch-zz-atmega256x
+++ b/devel/avr-gcc/files/patch-zz-atmega256x
@@ -241,9 +241,9 @@ diff -ur gcc/config/avr/avr.h gcc-4.1.1-new-devices-m256/gcc/config/avr/avr.h
#define LIB_SPEC \
"%{!mmcu=at90s1*:%{!mmcu=attiny11:%{!mmcu=attiny12:%{!mmcu=attiny15:%{!mmcu=attiny28: -lc }}}}}"
@@ -904,6 +915,8 @@
- %{mmcu=atmega128:crtm128.o%s} \
- %{mmcu=atmega1280:crtm1280.o%s} \
%{mmcu=atmega1281:crtm1281.o%s} \
+ %{mmcu=atmega8hva:crtm8hva.o%s} \
+ %{mmcu=atmega16hva:crtm16hva.o%s} \
+%{mmcu=atmega2560:crtm2560.o%s} \
+%{mmcu=atmega2561:crtm2561.o%s} \
%{mmcu=at90can32:crtcan32.o%s} \
diff --git a/devel/avr-gcc/pkg-descr b/devel/avr-gcc/pkg-descr
index 6fd5b14e9401..d2cbc744ba4b 100644
--- a/devel/avr-gcc/pkg-descr
+++ b/devel/avr-gcc/pkg-descr
@@ -16,7 +16,7 @@ Locally added support for the following AVR devices:
ATmega329/ATmega3290/ATmega649/ATmega6490, including their "P" variants
ATmega406
ATmega640/ATmega1280/ATmega1281
- AT90PWM1/PWM2/AT90PWM3 AT90CAN32/64
+ AT90PWM1/PWM2/AT90PWM3 AT90CAN32/64 ATmega8HVA/ATmega16HVA
AT90USB82/162/646/647/1286/1287
ATmega2560/ATmega2561 (beta test)