aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gdb/Makefile
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2002-09-10 08:52:42 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2002-09-10 08:52:42 +0000
commit9998b9f45d14d336a986e091c97bb8eb18e2397b (patch)
tree5d13bab88f107dbba1d49c3be1dfbf53e14471bc /devel/avr-gdb/Makefile
parent705008922b9b727b3ba3e81030a3db9bbde536b7 (diff)
downloadports-9998b9f45d14d336a986e091c97bb8eb18e2397b.tar.gz
ports-9998b9f45d14d336a986e091c97bb8eb18e2397b.zip
Complete the support for the AVR microcontroller toolchain: a port of
GDB to the AVR.
Notes
Notes: svn path=/head/; revision=66027
Diffstat (limited to 'devel/avr-gdb/Makefile')
-rw-r--r--devel/avr-gdb/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/avr-gdb/Makefile b/devel/avr-gdb/Makefile
new file mode 100644
index 000000000000..e54bd0a95d4f
--- /dev/null
+++ b/devel/avr-gdb/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: avr-gdb
+# Date created: 3 Sep 2002
+# Whom: Joerg Wunsch <joerg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= avr-gdb
+PORTVERSION= 5.2.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= gdb/releases
+DISTNAME= gdb-${PORTVERSION}
+
+MAINTAINER= joerg@FreeBSD.org
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --target=avr --program-prefix=avr
+
+pre-configure:
+ cd ${WRKSRC} ; ${RM} -rf dejagnu expect sim tcl texinfo
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb \
+ ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>