aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-libc
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-09-01 19:26:03 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-09-01 19:26:03 +0000
commitb2a907119447c8e2d75680414eaf5178cd04e87e (patch)
treea93b3b1f6b0d6c57fc480e774362ac5ad48588f0 /devel/avr-libc
parentecfd66a4483a414aa41e69b0aa710f9ae4b61423 (diff)
downloadports-b2a907119447c8e2d75680414eaf5178cd04e87e.tar.gz
ports-b2a907119447c8e2d75680414eaf5178cd04e87e.zip
The doxygen build was failing on 8 and 9 for non-obvious reasons.
As a stopgap (and as a favour to anyone building from ports ;-), change the DOCS option to DOXYGEN, and default it to off. THere are still some stage-qa issues but it should build and package on all platforms now. Approved by: joerg (maintainer)
Notes
Notes: svn path=/head/; revision=366936
Diffstat (limited to 'devel/avr-libc')
-rw-r--r--devel/avr-libc/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index 2e57f6019a9c..055113d51703 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= avr-libc
PORTVERSION= 1.8.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= SAVANNAH
@@ -21,15 +22,15 @@ RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils \
avr-gcc:${PORTSDIR}/devel/avr-gcc
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOXYGEN
.include <bsd.port.options.mk>
-.if ! ${PORT_OPTIONS:MDOCS}
+.if ! ${PORT_OPTIONS:MDOXYGEN}
.undef WITHOUT_AVRLIBCDOCS= true
.endif
-.if ${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOXYGEN}
USE_TEX= latex:build
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
fig2dev:${PORTSDIR}/print/transfig \
@@ -41,7 +42,7 @@ USES= gettext:build tar:bzip2 gmake
HAS_CONFIGURE= yes
CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
-.if ${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOXYGEN}
CONFIGURE_ARGS= --build=`./config.guess` --host=avr \
--enable-doc --disable-versioned-doc --prefix=${PREFIX} \
--mandir=${PREFIX}/share/doc/avr-libc/man
@@ -58,13 +59,13 @@ CFLAGS+= -O
CXXFLAGS+= -O
post-patch:
-.if ! ${PORT_OPTIONS:MDOCS}
+.if ! ${PORT_OPTIONS:MDOXYGEN}
${REINPLACE_CMD} -e '/SUBDIRS/s,examples,,' ${WRKSRC}/doc/Makefile.in
.endif
do-install:
${RM} -f ${TMPPLIST}
-.if ${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOXYGEN}
(cd ${BUILD_WRKSRC}/doc/api/avr-libc-user-manual && \
${FIND} . -type f \
\( -name '*.html' -or -name '*.css' -or \