aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-libc
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2004-12-21 14:42:36 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2004-12-21 14:42:36 +0000
commit207cfea59fcb3b8dcc2214e43180f03315a729a6 (patch)
treed8f660bb2aacb690d6cc9f965060d6c69b5902cd /devel/avr-libc
parentfb632d156e0cd5ad930f42d1d7188c4015d4abc1 (diff)
downloadports-207cfea59fcb3b8dcc2214e43180f03315a729a6.tar.gz
ports-207cfea59fcb3b8dcc2214e43180f03315a729a6.zip
Fix 3 out of 5 portlint warnings. (The remaining 2 are bogus.)
Notes
Notes: svn path=/head/; revision=124705
Diffstat (limited to 'devel/avr-libc')
-rw-r--r--devel/avr-libc/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index 6ad57a8b8fab..897f944d0939 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -17,8 +17,7 @@ COMMENT= A C and math library for the Atmel AVR controller family
BUILD_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils \
- avr-gcc:${PORTSDIR}/devel/avr-gcc \
- ${GMAKE}:${PORTSDIR}/devel/gmake
+ avr-gcc:${PORTSDIR}/devel/avr-gcc
RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils \
avr-gcc:${PORTSDIR}/devel/avr-gcc
@@ -29,6 +28,7 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
.endif
USE_BZIP2= yes
+USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
CONFIGURE_SCRIPT= doconf
@@ -54,7 +54,7 @@ do-build:
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE})
do-install:
- rm -f ${TMPPLIST}; cat ${PLIST_DOC} ${PLIST} > ${TMPPLIST}
+ ${RM} -f ${TMPPLIST}; ${CAT} ${PLIST_DOC} ${PLIST} > ${TMPPLIST}
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE} install)
${MKDIR} ${PREFIX}/share/doc/avr-libc
${MKDIR} ${PREFIX}/share/doc/avr-libc/examples