aboutsummaryrefslogtreecommitdiff
path: root/devel/b2
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-12-04 09:39:19 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-12-04 09:39:19 +0000
commita36112d51ae5687683f59bdb0ab3c7f23522e7e5 (patch)
treefd4334aa4c20a37ccbb1030ddfa7d14f2ecafaee /devel/b2
parent87e7baea34afbb83b94edcbe1a70fd1c99180b03 (diff)
downloadports-a36112d51ae5687683f59bdb0ab3c7f23522e7e5.tar.gz
ports-a36112d51ae5687683f59bdb0ab3c7f23522e7e5.zip
py-futures is only for the py27 flavor
With hat: portmgr
Notes
Notes: svn path=/head/; revision=455502
Diffstat (limited to 'devel/b2')
-rw-r--r--devel/b2/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/b2/Makefile b/devel/b2/Makefile
index a0745fbf695e..4d6542185bb7 100644
--- a/devel/b2/Makefile
+++ b/devel/b2/Makefile
@@ -13,7 +13,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>=0.8.0:devel/py-arrow@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}futures>=3.0.5:devel/py-futures@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}logfury>=0.1.2:devel/py-logfury@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.10:devel/py-six@${FLAVOR} \
@@ -29,4 +28,10 @@ USE_GITHUB= yes
GH_ACCOUNT= Backblaze
GH_PROJECT= B2_Command_Line_Tool
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>=3.0.5:devel/py-futures@${FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>