aboutsummaryrefslogtreecommitdiff
path: root/devel/bam
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-12 12:12:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-12 12:12:10 +0000
commit438824d9a7d0d11e19794c5ecab5d14e6b58c3d4 (patch)
tree4efa58e17aee0385dff772d75c4588f133933400 /devel/bam
parentbc211ca30d70acaea21155d3adcba4e3cb004809 (diff)
downloadports-438824d9a7d0d11e19794c5ecab5d14e6b58c3d4.tar.gz
ports-438824d9a7d0d11e19794c5ecab5d14e6b58c3d4.zip
Bam is a fast and flexible build system. Bam uses Lua to describe the build
process. It takes its inspiration for the script files from scons. While scons focuses on being 100% correct when building, bam makes a few sacrifices to acquire fast full and incremental build times. WWW: http://matricks.github.com/bam/ PR: ports/175857 Submitted by: Timothy Beyer <beyert@cs.ucr.edu>
Notes
Notes: svn path=/head/; revision=312106
Diffstat (limited to 'devel/bam')
-rw-r--r--devel/bam/Makefile32
-rw-r--r--devel/bam/distinfo2
-rw-r--r--devel/bam/pkg-descr6
3 files changed, 40 insertions, 0 deletions
diff --git a/devel/bam/Makefile b/devel/bam/Makefile
new file mode 100644
index 000000000000..f803c83ab6d0
--- /dev/null
+++ b/devel/bam/Makefile
@@ -0,0 +1,32 @@
+# Created by: Timothy Beyer <beyert@cs.ucr.edu>
+# $FreeBSD$
+
+PORTNAME= bam
+PORTVERSION= 0.4.0
+CATEGORIES= devel
+MASTER_SITES= http://github.com/downloads/matricks/bam/
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= A fast and flexible build system using Lua
+
+LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+FETCH_ARGS= "-Fpr"
+USE_BZIP2= yes
+
+PLIST_FILES= bin/bam
+
+do-build:
+.if defined(CC) && ${CC:T:Mclang}
+ @${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/make_unix_clang.sh
+ (cd ${WRKSRC} && ${SH} make_unix_clang.sh)
+.else
+ @${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/make_unix.sh
+ (cd ${WRKSRC} && ${SH} make_unix.sh)
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bam ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/bam/distinfo b/devel/bam/distinfo
new file mode 100644
index 000000000000..8fa0efa6f3c9
--- /dev/null
+++ b/devel/bam/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bam-0.4.0.tar.bz2) = 56030670aa21e227ce0a00f1ee0c9b5129469a6e69e7b67c3dd459d2fce6207d
+SIZE (bam-0.4.0.tar.bz2) = 164033
diff --git a/devel/bam/pkg-descr b/devel/bam/pkg-descr
new file mode 100644
index 000000000000..d201986076c0
--- /dev/null
+++ b/devel/bam/pkg-descr
@@ -0,0 +1,6 @@
+Bam is a fast and flexible build system. Bam uses Lua to describe the build
+process. It takes its inspiration for the script files from scons. While
+scons focuses on being 100% correct when building, bam makes a few sacrifices
+to acquire fast full and incremental build times.
+
+WWW: http://matricks.github.com/bam/