aboutsummaryrefslogtreecommitdiff
path: root/devel/bazaar/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-09 20:40:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-09 20:40:59 +0000
commit972562de16199704c111680e78e428a3f7a14c99 (patch)
tree74636342a20b1e99c450525a291aa4b8c213dc9b /devel/bazaar/Makefile
parentd0ff577059ab2a63c40defb0d209106caedc9877 (diff)
downloadports-972562de16199704c111680e78e428a3f7a14c99.tar.gz
ports-972562de16199704c111680e78e428a3f7a14c99.zip
This is a new port of bazaar, a C implementation of GNU Arch (based on tla)
from Canonical. The difference between this and bazaar-ng is that this is the "mainline" version of bazaar, beeing faster and more stable, while bazaar-ng is the somwhat future platform. I thought it would be nice to have this in ports as well, this is a very good implemenation that is easy to use, much easier than TLA. PR: ports/88476 Submitted by: Ulf Lilleengen <lulf@kerneled.org>
Notes
Notes: svn path=/head/; revision=147753
Diffstat (limited to 'devel/bazaar/Makefile')
-rw-r--r--devel/bazaar/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/devel/bazaar/Makefile b/devel/bazaar/Makefile
new file mode 100644
index 000000000000..a15b18e80bff
--- /dev/null
+++ b/devel/bazaar/Makefile
@@ -0,0 +1,65 @@
+# Ports collection makefile for: bazaar
+# Date created: 11 October 2005
+# Whom: Ulf Lilleengen
+#
+# $FreeBSD$
+#
+
+PORTNAME= bazaar
+PORTVERSION= 1.4.2
+CATEGORIES= devel
+MASTER_SITES= http://bazaar.canonical.com/releases/src/
+MASTER_SITE_SUBDIR= gnu-arch
+DISTNAME= bazaar_${PORTVERSION}
+
+MAINTAINER= lulf@kerneled.org
+COMMENT= An implementation of the GNU Arch RCS protocol in C by Canonical
+
+BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake \
+ gpatch:${PORTSDIR}/devel/patch \
+ gdiff:${PORTSDIR}/textproc/diffutils \
+ gtar:${PORTSDIR}/archivers/gtar
+RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= neon.24:${PORTSDIR}/www/neon \
+ gpgme.15:${PORTSDIR}/security/gpgme
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_PERL5_BUILD=yes
+GNU_CONFIGURE= yes
+
+MAN1= baz.1
+
+MAJORVERSION= 1.4
+BASEWRKDIR= ${WRKDIR}/thelove@canonical.com---dists--bazaar--${MAJORVERSION}
+WRKSRC= ${BASEWRKDIR}/src/=build
+PATCH_WRKSRC= ${BASEWRKDIR}
+LDFLAGS+= -L ${LOCALBASE}/lib
+CFLAGS+= -I ${LOCALBASE}/include ${LDFLAGS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "does not compile (missing va_copy)"
+.endif
+
+pre-patch:
+ ${MKDIR} ${WRKSRC}
+
+# I know the CFLAGS export is ugly, but it's the only way i've gotten bazaars
+# own autotools to detect libraries the "correct" way.
+do-configure:
+ cd ${WRKSRC} && export CFLAGS="${CFLAGS}" \
+ && ../configure --prefix ${PREFIX} \
+ --with-gnu-patch gpatch \
+ --with-gnu-diff gdiff \
+ --with-gnu-diff3 gdiff3 \
+ --with-gnu-tar gtar
+
+post-install:
+ cd ${BASEWRKDIR}/src/baz-manpage && ${PERL} generate-manpage.pl ${MAN1}\
+ && \
+ ${INSTALL_MAN} ${BASEWRKDIR}/src/baz-manpage/${MAN1} \
+ ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.post.mk>