aboutsummaryrefslogtreecommitdiff
path: root/devel/bin86
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-11-03 00:22:08 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-11-03 00:22:08 +0000
commit222baa33aacf95a23985df8288894514f52a65b4 (patch)
tree2b31c3c7c4ed95037aa1f25f9e4911bd34142e8e /devel/bin86
parent79b6e55418ddf16547f5dfe3cd9f607100fadf73 (diff)
downloadports-222baa33aacf95a23985df8288894514f52a65b4.tar.gz
ports-222baa33aacf95a23985df8288894514f52a65b4.zip
Add new port of bin86 0.15.3, a 16-bit assembler and loader for
Intel-style assembly.
Notes
Notes: svn path=/head/; revision=34691
Diffstat (limited to 'devel/bin86')
-rw-r--r--devel/bin86/Makefile51
-rw-r--r--devel/bin86/distinfo1
-rw-r--r--devel/bin86/files/patch-ld_bindef_h10
-rw-r--r--devel/bin86/files/patch-ld_ld_c10
-rw-r--r--devel/bin86/files/patch-ld_objdump86_c10
-rw-r--r--devel/bin86/files/patch-ld_writebin_c11
-rw-r--r--devel/bin86/files/patch-ld_writerel.c11
-rw-r--r--devel/bin86/files/patch-man_as86_115
-rw-r--r--devel/bin86/pkg-comment1
-rw-r--r--devel/bin86/pkg-descr9
10 files changed, 129 insertions, 0 deletions
diff --git a/devel/bin86/Makefile b/devel/bin86/Makefile
new file mode 100644
index 000000000000..e72825db9596
--- /dev/null
+++ b/devel/bin86/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: bin86
+# Date created: 2000-10-19
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= bin86
+PORTVERSION= 0.15.3
+CATEGORIES= devel
+MASTER_SITES= http://www.cix.co.uk/~mayday/
+
+MAINTAINER= trevor@FreeBSD.org
+
+DOCS= ChangeLog README README-0.4
+DOCDIR= share/doc/${PORTNAME}
+.if !defined(NOPORTDOCS)
+MAN1= as86.1 ld86.1
+.endif
+ONLY_FOR_ARCHS= i386
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-extract:
+ find ${WRKSRC} -type f -print0 | xargs -0 ${CHMOD} 644
+
+pre-install:
+ ${RM} -f ${PLIST}
+ cd ${WRKSRC} && \
+ find -s ${WRKSRC} -perm 755 -type f -exec ${BASENAME} \{\} \; \
+ | ${SED} -e 's:^:bin/:' >> ${PLIST}
+.if !defined(NOPORTDOCS)
+.for i in ${DOCS}
+ ${ECHO} ${DOCDIR}/${i} >> ${PLIST}
+.endfor
+ ${ECHO} "@dirrm " ${DOCDIR} >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} `find ${WRKSRC} -type f -perm 755 |grep -v encap` \
+ ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/as/as86_encap ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/${DOCDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCDIR}
+ ${INSTALL_MAN} ${WRKSRC}/man/*1 ${PREFIX}/man/man1
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/bin86/distinfo b/devel/bin86/distinfo
new file mode 100644
index 000000000000..054734c36024
--- /dev/null
+++ b/devel/bin86/distinfo
@@ -0,0 +1 @@
+MD5 (bin86-0.15.3.tar.gz) = 37338c39b6461f5c7fd745ef9c88484f
diff --git a/devel/bin86/files/patch-ld_bindef_h b/devel/bin86/files/patch-ld_bindef_h
new file mode 100644
index 000000000000..e377ffb4dba3
--- /dev/null
+++ b/devel/bin86/files/patch-ld_bindef_h
@@ -0,0 +1,10 @@
+--- ld/bindef.h.orig Tue Mar 30 10:58:34 1999
++++ ld/bindef.h Thu Oct 19 16:52:33 2000
+@@ -1,6 +1,6 @@
+
+ #ifndef MSDOS
+-#ifndef NO_AOUT
++#if 0
+ /* Ok, I'm just gonna make it simple ... override this if you like. */
+ #ifndef A_OUT_INCL
+ #define A_OUT_INCL "a.out.h"
diff --git a/devel/bin86/files/patch-ld_ld_c b/devel/bin86/files/patch-ld_ld_c
new file mode 100644
index 000000000000..0ca2fd413825
--- /dev/null
+++ b/devel/bin86/files/patch-ld_ld_c
@@ -0,0 +1,10 @@
+--- ld/ld.c.orig Wed Dec 30 12:20:50 1998
++++ ld/ld.c Thu Oct 19 17:04:00 2000
+@@ -2,6 +2,7 @@
+
+ /* Copyright (C) 1994 Bruce Evans */
+
++#undef BUGCOMPAT
+ #include "syshead.h"
+ #include "const.h"
+ #include "byteord.h"
diff --git a/devel/bin86/files/patch-ld_objdump86_c b/devel/bin86/files/patch-ld_objdump86_c
new file mode 100644
index 000000000000..59f013fa51d5
--- /dev/null
+++ b/devel/bin86/files/patch-ld_objdump86_c
@@ -0,0 +1,10 @@
+--- ld/objdump86.c.orig Fri Dec 17 09:44:32 1999
++++ ld/objdump86.c Thu Nov 2 15:27:45 2000
+@@ -16,7 +16,6 @@
+ */
+
+ #include <stdio.h>
+-#include <malloc.h>
+ #include <string.h>
+ #ifdef __STDC__
+ #include <stdlib.h>
diff --git a/devel/bin86/files/patch-ld_writebin_c b/devel/bin86/files/patch-ld_writebin_c
new file mode 100644
index 000000000000..11234a100962
--- /dev/null
+++ b/devel/bin86/files/patch-ld_writebin_c
@@ -0,0 +1,11 @@
+--- ld/writebin.c.orig Sun Mar 14 13:07:12 1999
++++ ld/writebin.c Thu Oct 19 16:52:50 2000
+@@ -3,7 +3,7 @@
+
+ /* Copyright (C) 1994 Bruce Evans */
+
+-#ifndef NO_AOUT
++#if 0
+ #ifndef A_OUT_INCL
+ #define A_OUT_INCL <a.out.h>
+ #endif
diff --git a/devel/bin86/files/patch-ld_writerel.c b/devel/bin86/files/patch-ld_writerel.c
new file mode 100644
index 000000000000..22f621f85678
--- /dev/null
+++ b/devel/bin86/files/patch-ld_writerel.c
@@ -0,0 +1,11 @@
+--- ld/writerel.c.orig Wed Apr 23 21:05:51 1997
++++ ld/writerel.c Thu Oct 19 17:01:59 2000
+@@ -9,7 +9,7 @@
+ * an as86 object file.
+ */
+
+-#ifdef BUGCOMPAT
++#if 0
+ #define A_OUT_INCL "rel_aout.h"
+ #define BSD_A_OUT 1
+ #define FILEHEADERLENGTH 32
diff --git a/devel/bin86/files/patch-man_as86_1 b/devel/bin86/files/patch-man_as86_1
new file mode 100644
index 000000000000..14061485cf0e
--- /dev/null
+++ b/devel/bin86/files/patch-man_as86_1
@@ -0,0 +1,15 @@
+--- man/as86.1.orig Tue Sep 26 13:18:31 2000
++++ man/as86.1 Thu Nov 2 16:10:08 2000
+@@ -20,8 +20,8 @@
+
+ .SH DESCRIPTION
+ .B as86
+-is an assembler for the 8086..80386 processors, it's syntax is closer
+-to the intel/microsoft form rather than the more normal generic form of
+-the unix system assembler.
++is an assembler for the 8086..80386 processors. Its syntax is closer
++to the Intel/Microsoft form rather than the more normal generic form of
++the Unix system assembler.
+
+ The
+ .B src
diff --git a/devel/bin86/pkg-comment b/devel/bin86/pkg-comment
new file mode 100644
index 000000000000..a24cbf3f06da
--- /dev/null
+++ b/devel/bin86/pkg-comment
@@ -0,0 +1 @@
+16-bit assembler and loader
diff --git a/devel/bin86/pkg-descr b/devel/bin86/pkg-descr
new file mode 100644
index 000000000000..c1f474ae9800
--- /dev/null
+++ b/devel/bin86/pkg-descr
@@ -0,0 +1,9 @@
+This consists of a 16-bit assembler and loader for x86 or 6809
+CPUs. Since they use Intel syntax, they are incompatible with the
+GNU binutils in the base system (recent versions of which can also
+generate 16-bit code).
+
+WWW: http://www.cix.co.uk/~mayday
+
+Trevor Johnson
+trevor@FreeBSD.org