aboutsummaryrefslogtreecommitdiff
path: root/devel/boehm-gc
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-12-18 04:08:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-12-18 04:08:56 +0000
commit29618efb6cee01f1d89cfe211b8021b5e70cdd7b (patch)
tree680a87dd7bac33b59112900371f21317aa9f17ef /devel/boehm-gc
parent3c4f18635e797c2c88ac9a2448c03cac8d8bca2d (diff)
downloadports-29618efb6cee01f1d89cfe211b8021b5e70cdd7b.tar.gz
ports-29618efb6cee01f1d89cfe211b8021b5e70cdd7b.zip
- Drop REDIRECT/THREADED options as this libgc variants were moved into the
separate ports.
Notes
Notes: svn path=/head/; revision=246112
Diffstat (limited to 'devel/boehm-gc')
-rw-r--r--devel/boehm-gc/Makefile23
1 files changed, 2 insertions, 21 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 9277713a5a8c..f4273b4de602 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -18,31 +18,12 @@ COMMENT= Garbage collection and memory leak detection for C and C++
GNU_CONFIGURE= yes
USE_GNOME= gnometarget gnomehack
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-cplusplus --disable-static
+CONFIGURE_ARGS= --enable-cplusplus --disable-static --disable-threads
MAKE_JOBS_UNSAFE= yes
-OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
- FULLDEBUG "Debugging support (see documentation)" off \
- THREADING "POSIX thread support" off \
- PARALLEL_MARK "Parallel-thread marking (faster for SMP)" off
+OPTIONS= FULLDEBUG "Debugging support (see documentation)" off
.include <bsd.port.pre.mk>
-.if defined(WITH_THREADING)
-CONFIGURE_ARGS+= --enable-threads=posix --enable-thread-local-alloc
-CONFIGURE_ENV= CFLAGSS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/}"
-.if defined(WITH_PARALLEL_MARK)
-CONFIGURE_ARGS+= --enable-parallel-mark
-.endif
-PKGNAMESUFFIX= +threaded
-.else
-CONFIGURE_ARGS+= --disable-threads
-PKGNAMESUFFIX= # empty
-.endif
-.if defined(WITH_REDIRECT)
-CONFIGURE_ARGS+= --enable-redirect-malloc
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+redirect
-.endif
.if defined(WITH_FULLDEBUG)
CONFIGURE_ARGS+= --enable-gc-debug
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug